Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Family Sharing results in "Redownload Unavailable with This Apple ID"

I recently converted from having my Apple ID on all of our 5 devices, to setting up separate accounts. I just got a new iPhone 6 for my wife tonight. I didn't restore form backup, because she wanted to start fresh, and not have every App on the phone. So when I started downloading Apps, I got and in setting it up, I started downloading Apps and after installing 10 Apps, I got the following error message:


Redownload Unavailable with This Apple ID

This redownload is not available for this Apple ID either because it was bought by a different user or the item was refunded or cancelled.


Anyone else having this issue?

Come on Apple. Seriously?

iPhone 6, iOS 8, 64 GB, Space Gray

Posted on

Reply

Sep 26, 2014 10:14 AM in response to adambplummer In response to adambplummer

I'm having the same error pop up. I finally accepted an iPad from my job now thinking that I wouldn't have to worry about using my own personal iTunes account on my work iPad. The "Redownload Unavailable with This Apple ID" message appears when trying to download Microsoft Word for iPad as well as Rhapsody. For some reason, the apps are not showing up on the list of apps even though they are running on the Organizer's device. I've restarted both iPads, my iPhone, logged in and out of the iTunes store and iCloud, and still have the issue.


Family sharing is frustratingly hit or miss. All 3 devices have been updated to iOS 8.0.2 as of this morning.

Sep 26, 2014 10:14 AM

Reply Helpful (1)

Sep 27, 2014 6:28 AM in response to adambplummer In response to adambplummer

OK so my wife's phone is doing the same thing this morning. Been on Family sharing all week and has updated apps until today. Walmart, Pinterest, Amazon say "Redownload Unavailable".

I went to Settings>iTunes/App Store> her apple id (signed in with her password and clicked "Done")

Went back to App Store and was able to download WalMart, was unable to redownload the others.

It was one small step, thought I'd throw it out there.

Sep 27, 2014 6:28 AM

Reply Helpful (1)

Sep 30, 2014 1:46 PM in response to adambplummer In response to adambplummer

For what its worth i've been having this issue too and have followed all the advice i could find, none of which worked. However the only apps we were having trouble with were those make in the update list (and the app's info page on the App Store) as "Non shareable". If the Family Sharing lead has "purchased" (and the "" are there as there are free apps in the list *cough* Twitter, Dropbox, Kindle *cough*) any non shareable apps then they need to mark them as hidden (tap and swipe the app to the left in the list of apps in the purchased section of the App Store app and then tap hide. Now, the non family lead who wants to buy/download the previously downloaded app needs to go back to the purchased section, select the Family Sharing leads name to show their app list (this seems to be important to refresh the information) then search for the app in the App Store, then instead of the cloud with download arrow there should be the "Free" or "Price of app" box, which they can tap to install and provide password/tap the touch ID scanner/ however you authenticate your purchases in that App Store. This worked for me and was the only thing that worked and seems to be the obvious answer in hindsight - however the distinction between whats shareable and whats not is very strange - there's free apps, that are and aren't, apps that login to web services that aren and aren't, apps that have in app purchases that are and aren't and paid apps that are and aren't its confusing so if you get this error, check the status and try this. Then complain to the app developer. I'm thinking of raising a bug report with some of the apps i've found as its confusing and there seems to be no reason for it.


Good luck!


Michael

Sep 30, 2014 1:46 PM

Reply Helpful (2)

Oct 2, 2014 9:45 PM in response to adambplummer In response to adambplummer

I had this problem and here's what I found out along with the solution:


I setup family sharing and my wife wanted to download a free app that I had "purchased". When she went to download it, she got the "Update unavailable with this Apple ID" error message. I tried another app and it was fine. I tried another app and I got the message again. It turned out the the apps receiving this message were labeled as "Not Shareable" in my purchased apps list on my iPhone . These apps didn't even show up as purchases under my name on my wife's iphone. Frustration and a "Hulk smash" rampage ensued.


The solution:

As you might guess, the Hulk smash rampage was ineffective at solving the problem. However, downloading the app using iTunes on my wife's account on our Mac did work. After she downloaded the app using iTunes, the app showed up as a purchased app in the App Store on her iPhone and she was able to download and use it.


Sounds like a bug. Apple: fix, please!

Oct 2, 2014 9:45 PM

Reply Helpful (1)

Oct 5, 2014 10:40 AM in response to adambplummer In response to adambplummer

So, I had this same issue. After playing around with the apps that would not re-download or update I found that I could get it to eventually work by doing the following:


-Delete the Troubled App

-Go to the App store to the Apps' page and you should see the "Download from the Cloud" icon.

-Quickly double click the Cloud icon (you might need to click more than twice, actually just click the button very quickly numerous times).

-Eventually it will ask for your password as if you are downloading for the very first time.

Oct 5, 2014 10:40 AM

Reply Helpful

Dec 13, 2014 2:24 PM in response to big daddy doolittle In response to big daddy doolittle

sign out in both:

Settings > iCloud > Sign Out

Settings > iTunes & App Store

and do not sign in.


I found this answer on http://appletoolbox.com from Alex. It worked for me.

But yes, it is very frustrating. I'm really hoping that the executives at Apple realize that they have a serious and growing quality control issue.

Dec 13, 2014 2:24 PM

Reply Helpful
User profile for user: adambplummer

Question: Family Sharing results in "Redownload Unavailable with This Apple ID"