Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Yosemite (OS X 10.10) killed my WiFi :(

I just updated to Yosemite on a brand new 15" MBP Retina Display. For some reason my WiFi is not working. I turn it on and select the network I want to join (my regular network at home that I've been using with this same computer before updating). So, I turn it on and select the network and doesn't seem to want to join it and then my WiFi switches back off completely.


Is anyone else having problems with their WiFi on Yosemite?

MacBook Pro (Retina, 15-inch, Mid 2014), OS X Yosemite (10.10)

Posted on

Reply
Question marked as Helpful

Oct 16, 2014 9:01 PM in response to GalagBasha In response to GalagBasha

I am not sure how or why, but the suggestion above to delete the bluetooth.plist and rebooting has seemed to help. I have not yet lost the connection wifi in say the last 15 minutes. Which I wouldn't go 3 minutes before. I will keep an eye on it and update later if it comes back, but this appears to have put me back on track to having working WIFI.

Question marked as Helpful

Oct 17, 2014 6:30 AM in response to GalagBasha In response to GalagBasha

The good folks at the Apple Helpline gave me this solutions and it worked.


Open Finder > Choose Go From the menu at the top of the screen > Click on Computer > Double Click on Macintosh HD > Double Click on Library > Double Click on Preferences > Click once on the file called "SystemConfirguration" > CMD+DEL the file > Enter your password > restart.


It worked like a charm 🙂


Hope it helps you guys out.

There’s more to the conversation

Read all replies

Oct 16, 2014 6:36 PM in response to GalagBasha In response to GalagBasha

Alt+Click on your WiFi icon in the Menu bar and open Wireless Diagnostics. Click on "Windows" and choose "Scan". There are Logs that you can collect and analyze.


Have you also tried forgetting the network and adding it back via System Preferences -> Network -> WiFi -> Advanced -> "-".

Oct 16, 2014 6:36 PM

Reply Helpful

Oct 16, 2014 7:01 PM in response to GalagBasha In response to GalagBasha

Ever since Yosemite Developer Preview 4 my 13" MacBook Pro (non-Retina) has not been able to connect properly to the WPA2-Enterprise wireless network at my university. I literally bought the computer FOR my university work. I reported the issue to Apple through Feedback Assistant using Wireless Diagnostics. I briefly had Developer Preview 5 installed earlier today and that seemed to fix everything. I then upgraded further to Developer Preview 6 (I hadn't been on my Mac lately so I was behind in updates. There was no reason to use it since the Internet was nearly impossible to use) The WiFi seemed to be working flawlessly in both DP 5 and 6, so I thought the error had been resolved. After installing Yosemite Golden Master today, the issue is back!


My WiFi indicator is doing the "trying to connect" animation but the wireless is actually connected since I can load webpages. Sometimes after I load a few webpages, the WiFi will drop entirely. Then the network will pick back up, I will be authenticated, and then I can use the Internet again. It seems like there is a bug in the 802.1X authentication since my Network preference pane shows a "Working" indicator and the status says "Authenticating" and the WiFi indicator is animated as "Trying to connect" but I am actually connected currently. It is driving me insane.

Oct 16, 2014 7:01 PM

Reply Helpful

Oct 16, 2014 7:20 PM in response to nalexander50 In response to nalexander50

I am on DP6 and plan to wait for a few weeks for patches. It seems what was fixed in DP6 never made it to the GA release. 😟


I am able to connect to WPA2-Enterprise without any issues throughout the DP 1-6 rollout on a 13" MBP2012 (non-Retina).


OP has a later AC wifi card, while I have an a/b/g/n card.

Oct 16, 2014 7:20 PM

Reply Helpful

Oct 16, 2014 7:29 PM in response to GalagBasha In response to GalagBasha

SInce OS X Mavericks, I noticed that Wifi is not stable on my Retina Macbook Pro 2013. This change is definitely due to the changes on the protocol a,b,g,n I believe. Before Mavericks, and before the arrival of "n" everything was perfect. But I had to set the channel on my wifi router to either 6 or 11 if I'm not wrong, and this fix had worked, until the latest mMavericks version Came. When my PCs or iPad, iPod are working well, my Reina MacBook Pro wouldn't. The signal drops every now and then. Now, my educated guess is that you might try setting different channels on your wifi modem (if possible) and see which is better for you. Before Mavericks, I used the Auto Channel mode, but not anymore. Hope this helps.

I Will upgrade to Yosemite tonight, and I'll keep posting.

Oct 16, 2014 7:29 PM

Reply Helpful

Oct 16, 2014 7:49 PM in response to Sungyub Han In response to Sungyub Han

To fulfill the goal of longer battery life, the WiFi Radios on the Mac are the most often tuned pieces of HW/SW.


They are also one of the most power hungry devices (BT is another) and the most affected by the "tuning" that Apple has done via Mavericks and Yosemite.


In my experience, WiFi connectivity issues get worse, as the Mac spends more time off the charger and on battery.

Oct 16, 2014 7:49 PM

Reply Helpful (1)

Oct 16, 2014 8:22 PM in response to GalagBasha In response to GalagBasha

Same issue. It works for a limited time, and then appears to be connected, but all network traffic just stops to. Hooked into wired network and haven't had an issue yet. If I reset the connection, by turning off and on the wifi, it works again for a short amount of time, and dies. This will making working tomorrow interesting.

Oct 16, 2014 8:22 PM

Reply Helpful
User profile for user: GalagBasha

Question: Yosemite (OS X 10.10) killed my WiFi :(