Announcement: Upgrade to macOS Catalina

Experience dedicated apps for music, TV, and podcasts, plus smart new features like Sidecar. Learn how to upgrade >

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Command key shortcuts don't work anymore in Safari since upgrade to Yosemite!

Hi,

I recently upgraded the MacOSX to Yosemite. Since this moment Safari doesn't work properly anymore, because the command key shortcuts are out of order.

Cmd + Q

Cmd + C

Cmd + V

Cmd + X


These are now the key shortcuts I've noticed that aren't working anymore. Other apps (a part from Firefox) don't seem to have these problems.

In the meantime I have to use the mouse cursor and choose from the menu bar.

Apple support wasn't able to help me! They just gave me the advice force quit Safari and restart it while pushing the ALT-key. Result: Nothing!


Thanks in advance for your help.


Kind regard,

Steven


--

MacBook Air

Version 10.10

1.3 GHz Intel Core i5

8 GB 1600 MHz DDR3

MacBook Air (13-inch Mid 2013), OS X Yosemite (10.10)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Problem fixed!

I compared the system preferences for each user and found out that I had several languages activated in the language/region settings. So I deleted the language adding the option "list sort order". This option wasn't activated in my test account.


You have to try which language is the "bad one" on your system (In my case it was "german"...haha) and delete it. UPDATE: I've tried to re-add the deleted language and still safari works fine.


All this sounds a bit weird to me, but it helped to get rid of my CMD-key annoyance. Let my know if it helped you too.

Posted on

Oct 21, 2014 4:06 PM in response to stevendeluxe In response to stevendeluxe

That is rather odd if they are all visible as shortcut commands.


Here are some more tests to do…

1) Disable all your Safari Extensions & retest (in Safari Preferences).


2) Logout of the account (from the Apple menu). At the login window enter your password & hold shift as you click the login button. Keep it held until the Desktop has become usable. This disables 'User login items' - retest. Logout after testing.


3) Try a safe boot… OS X: What is Safe Boot, Safe Mode?

Does it still happen in safe mode? This disables third party extensions & some inessential Apple system extensions - things will not be normal, however the Mac should be 'functional', test as much as you can.


Post the results of those here, it may give us a better idea where to look.

Oct 21, 2014 4:06 PM

Reply Helpful

Oct 22, 2014 12:39 AM in response to Drew Reece In response to Drew Reece

Hi Drew,


I tried all of the above, 2) and 3) even twice, but the problem stays the same. I want to add that shortcuts don't work in FIREFOX either. For instance, I see the EDIT-tab light up, when I press CMD+C, but it doesn't actually copy. As for SAFARI, it doesn't react at all with shortcuts.


Best,

Vic

Oct 22, 2014 12:39 AM

Reply Helpful

Oct 22, 2014 8:59 AM in response to stevendeluxe In response to stevendeluxe

Hi,


I'm getting closer to the solution since I've created a new user (in my example "Alter ego"). Safari and the CMD-keys work fine after the login under the new user. That means there must be some software/app messing up under my regular user (ok, that was a bit of Columbo ;-) ).


Any clue how I can check which apps/processes are running in the background? (UPDATE: Activity Monitor should help, right?)

Oct 22, 2014 8:59 AM

Reply Helpful
Question marked as Solved

Oct 22, 2014 10:44 AM in response to stevendeluxe In response to stevendeluxe

Problem fixed!

I compared the system preferences for each user and found out that I had several languages activated in the language/region settings. So I deleted the language adding the option "list sort order". This option wasn't activated in my test account.


You have to try which language is the "bad one" on your system (In my case it was "german"...haha) and delete it. UPDATE: I've tried to re-add the deleted language and still safari works fine.


All this sounds a bit weird to me, but it helped to get rid of my CMD-key annoyance. Let my know if it helped you too.

Oct 22, 2014 10:44 AM

Reply Helpful (2)
User profile for user: stevendeluxe

Question: Command key shortcuts don't work anymore in Safari since upgrade to Yosemite!