Announcement: macOS Big Sur is here

macOS Big Sur elevates the most advanced desktop operating system in the world to a new level of power and beauty. Update now and join the conversation here in the community.

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: The phone number "is not registered with iMessage"

Hi everyone,


Right now I can't seem to send some text messages from my OS X. Here is a list of things I have done that will have caused the error:

  • I fresh installed Yosemite about 2 days ago
  • I updated my iPhone to 8.1 this afternoon
  • I paired my device (I was able to send some texts from OS X)
  • I fresh installed iOS 8.1 on my iPhone
  • I can't send some text messages from my computer


When I start a new conversation on iMessage, the name of the person remains red. When I try to send a message I get a popup saying: "<the number> is not registered with iMessage". The handoff is well configured because I am able to see an icon appear in the dock when I use the notes app.


What can I do to make this functionality work again?


Thanks

Posted on

Reply
Question marked as Helpful

Nov 5, 2014 2:40 AM in response to Philibobby In response to Philibobby

Hi,


I'm also having the same problem. I keep on getting the message ("phone number" is not registered with iMessage) whenever I tried to send an SMS text message from my Macbook Air.


I can't get the text messages from my iPhone 5s to synchronise with iMessage using the latest Yosemite update. On the previous Mac OS X Mavericks, only a few contact numbers worked.


I would greatly appreciate if anyone can help me with this issue.


Cheers,


Demo14

Question marked as Helpful

Nov 27, 2014 7:15 PM in response to Philibobby In response to Philibobby

You must register your phone number by signing into iMessage from your iPhone. If you are already signed into iMessage on the iPhone, sign out and sign back in on the iPhone.

If it still doesn't appear on the computer, sign out of iMessage there and sign back in. It should appear then.


Also, in order to send SMS messages from the computer, you must enable it on the iPhone. In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.

Also enable SMS on the iPhone.

Question marked as Helpful

Nov 16, 2014 8:00 AM in response to Philibobby In response to Philibobby

I have same prob, and Apple said we'd no longer have this problem with YOSEMITE, that you'd be able to message anyone even those without macs or iphones! Amazing it's still a prob. I wonder if they know or anyone else how to fix? So frustrating!

Question marked as Helpful

Dec 28, 2014 4:35 PM in response to tranquildavid In response to tranquildavid

Maybe I can be clearer. My iphone shows up in messages on my mac and I can text a large number of person with and without iphones. It's not my phone for which I receive the mmsg not registered but for toehres, their numbers are highlighted in red in the recipient box. My phone and my iphone have no problem texting the same people just my mac.

Question marked as Helpful

Jan 1, 2015 9:26 AM in response to Parrish Jones In response to Parrish Jones

Hi Parrish Jones, my problem was identical to yours. My iPhone showed up in Messages on my MacBook Pro. I could text anyone from my phone that I wanted to. The problem was on my MacBook Pro. Many people I tried to text via the MacBook Pro would be highlighted in red and I would get that number not registered message. When I read that the solution was to go to the phone and change a setting on the phone, I thought, that won't help my MacBook Pro problem, but it did. It solved the MacBook Pro problem.


If you follow the instructions that Glenn provided, I think that it might solve your problem. I know the instructions sound counterintuitive as your problem isn't on the phone, but you should try it. It worked for me. I hope you get the same results.


In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.

Also enable SMS on the iPhone.

Question marked as Helpful

Jan 30, 2015 9:44 PM in response to blackdogaudio In response to blackdogaudio

That worked -- yes do go to your computer and turn on iMessage then Preferences and log into your Apple ID. Here's how to perform these 2 steps to get your iMessage able to send & receive from non-iPhone numbers/accounts.

From iMessage>Preference> Log into your Apple ID. This will likely take you to a browser window. From there log in with your Apple ID. Then once you're logged on at My Apple ID>go to Phone Numbers then select from Daytime, Evening or Mobile. Key in your Mobile number (include the 1 then area code).


Now Step 2 -- You also need to go to your iphone itself. Go to Settings>Messages ("Messages" is likely best located if you scroll down on your phone below Mail, Contacts, Calendars; below Notes, below Reminders, below Phone).

When you see Messages then> iMessage and make sure it's on by sliding the tab so that you see green, indicating that iMessage is ALSO turned ON on your iPhone.

There’s more to the conversation

Read all replies
Question marked as Helpful

Nov 5, 2014 2:40 AM in response to Philibobby In response to Philibobby

Hi,


I'm also having the same problem. I keep on getting the message ("phone number" is not registered with iMessage) whenever I tried to send an SMS text message from my Macbook Air.


I can't get the text messages from my iPhone 5s to synchronise with iMessage using the latest Yosemite update. On the previous Mac OS X Mavericks, only a few contact numbers worked.


I would greatly appreciate if anyone can help me with this issue.


Cheers,


Demo14

Nov 5, 2014 2:40 AM

Reply Helpful (47)
Question marked as Helpful

Nov 16, 2014 8:00 AM in response to Philibobby In response to Philibobby

I have same prob, and Apple said we'd no longer have this problem with YOSEMITE, that you'd be able to message anyone even those without macs or iphones! Amazing it's still a prob. I wonder if they know or anyone else how to fix? So frustrating!

Nov 16, 2014 8:00 AM

Reply Helpful (18)

Nov 27, 2014 7:42 AM in response to Eric Root In response to Eric Root

So how does one do that. It seems the help notes in iMessages do not give complete instructions. The person I wish to message is in my contacts and I can send him msgs using my iphone and ipad but not my computer.

Nov 27, 2014 7:42 AM

Reply Helpful (4)
Question marked as Helpful

Nov 27, 2014 7:15 PM in response to Philibobby In response to Philibobby

You must register your phone number by signing into iMessage from your iPhone. If you are already signed into iMessage on the iPhone, sign out and sign back in on the iPhone.

If it still doesn't appear on the computer, sign out of iMessage there and sign back in. It should appear then.


Also, in order to send SMS messages from the computer, you must enable it on the iPhone. In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.

Also enable SMS on the iPhone.

Nov 27, 2014 7:15 PM

Reply Helpful (31)

Nov 28, 2014 5:19 AM in response to Glenn Leblanc In response to Glenn Leblanc

The problem is not not being able to send msgs at all. I'm doing a fair amount of texting. On my MAC, I cannot send to some people to whom I can text on iPhone or iPad. When I do text them on the iPhone or iPad the msg then shows on my MAC but I cannot send or reply to them on the MAC.

Nov 28, 2014 5:19 AM

Reply Helpful (1)

Nov 28, 2014 5:37 AM in response to Parrish Jones In response to Parrish Jones

My reply was to the OP.


You say you can't send at all, then you say you just can't send to some. Not sure what you are saying. For the ones you can't sent to: do they have an iPhone or are they registered with iMessage? If not, then those people will be SMS messages. You will need to enable your computer on the iPhone as I described.


If this is not the case and your problem is different than the OP, then start a new discussion stating what your problem is.

Nov 28, 2014 5:37 AM

Reply Helpful (1)
Question marked as Helpful

Dec 28, 2014 4:35 PM in response to tranquildavid In response to tranquildavid

Maybe I can be clearer. My iphone shows up in messages on my mac and I can text a large number of person with and without iphones. It's not my phone for which I receive the mmsg not registered but for toehres, their numbers are highlighted in red in the recipient box. My phone and my iphone have no problem texting the same people just my mac.

Dec 28, 2014 4:35 PM

Reply Helpful (10)
Question marked as Helpful

Jan 1, 2015 9:26 AM in response to Parrish Jones In response to Parrish Jones

Hi Parrish Jones, my problem was identical to yours. My iPhone showed up in Messages on my MacBook Pro. I could text anyone from my phone that I wanted to. The problem was on my MacBook Pro. Many people I tried to text via the MacBook Pro would be highlighted in red and I would get that number not registered message. When I read that the solution was to go to the phone and change a setting on the phone, I thought, that won't help my MacBook Pro problem, but it did. It solved the MacBook Pro problem.


If you follow the instructions that Glenn provided, I think that it might solve your problem. I know the instructions sound counterintuitive as your problem isn't on the phone, but you should try it. It worked for me. I hope you get the same results.


In iPhone settings, open iMessage. Select Text Message Forwarding. You must be on the same wi-fi network. Your computer or other device should show in the list. Just click on the device you want to enable.

Also enable SMS on the iPhone.

Jan 1, 2015 9:26 AM

Reply Helpful (8)
Question marked as Helpful

Jan 30, 2015 9:44 PM in response to blackdogaudio In response to blackdogaudio

That worked -- yes do go to your computer and turn on iMessage then Preferences and log into your Apple ID. Here's how to perform these 2 steps to get your iMessage able to send & receive from non-iPhone numbers/accounts.

From iMessage>Preference> Log into your Apple ID. This will likely take you to a browser window. From there log in with your Apple ID. Then once you're logged on at My Apple ID>go to Phone Numbers then select from Daytime, Evening or Mobile. Key in your Mobile number (include the 1 then area code).


Now Step 2 -- You also need to go to your iphone itself. Go to Settings>Messages ("Messages" is likely best located if you scroll down on your phone below Mail, Contacts, Calendars; below Notes, below Reminders, below Phone).

When you see Messages then> iMessage and make sure it's on by sliding the tab so that you see green, indicating that iMessage is ALSO turned ON on your iPhone.

Jan 30, 2015 9:44 PM

Reply Helpful (6)
User profile for user: Philibobby

Question: The phone number "is not registered with iMessage"