Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone won't send texts to Android phones

I can send texts to iPhones as either iMessages or SMS messages. However, I can't send texts to contacts who use other mobile devices (ie. Not an iPhone). However, I can receive SMS messages from non iPhones,

I've reset network settings and nothing has changed.

I only purchased my phone a week ago and have had this problem since new.

Any ideas anyone? Your help is much appreciated


Note: iPhone 6 16GB using iOS 8.1.2

[Re-Titled by Host]

iPhone 6, iOS 8.1.2

Posted on Dec 30, 2014 2:06 AM

Reply
Question marked as Helpful

Nov 14, 2016 12:09 PM in response to Rhys1998 In response to Rhys1998

I'm getting an "undelivered" message beneath this one text in a group thread that has one or more non-iOS user(s). I tried the sign out of iMessage and FaceTime then sign back in thing --I even rebooted the phone after signing out -- but to no avail whatever. I have never had this problem before, and it's really rubbing me the wrong way. That green bubble is just disgusting. I guess I need to call AT&T.

Nov 14, 2016 12:09 PM

Question marked as Helpful

Dec 31, 2014 8:47 AM in response to Rhys1998 In response to Rhys1998

Hi Rhys1998,

Happy New Year! If you are not able to send SMS messages to a non-Apple phone, try these troubleshooting steps:



If you can't send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

http://support.apple.com/en-us/HT204065


Check your device settings

  1. Make sure that you’re connected to a cellular data or Wi-Fi network.
  2. Go to Settings > Messages and make sure that iMessage, Send as SMS, or MMS Messaging is turned on (whichever method you're trying to use). Learn about the different types of messages you can send.
    User uploaded file

Check the recipient's contact info

  1. Make sure that you're using the right phone number or email address.
  2. Go to Settings > Messages > Blocked and make sure that they're not on your block list.

Restart your device and check for updates

  1. Restart your device.
  2. Check for a carrier settings update.
  3. Check for an iOS software update.

Check the system status for iMessage

Go to the Apple Services System Status page and check iMessage.

Turn iMessage off and back on

Go to Settings > Messages and turn iMessage off, then back on.

Sign out and back in to iMessage and FaceTime

  1. Go to Settings > Messages > Send & Receive, tap your Apple ID, then tap Sign Out.
  2. Go to Settings > FaceTime, tap your Apple ID, then tap Sign Out.
  3. On your iPhone first, sign back in to iMessage and Facetime.
  4. Sign back in to iMessage and Facetime on your other devices.

Reset your network settings

Tap Settings > General > Reset > Reset Network Settings.

Back up and restore your device

Use iTunes or iCloud to back up your content, then restore your device.



Send messages with your iPhone, iPad, or iPod touch - Apple Support
http://support.apple.com/en-us/HT201287

What's the difference between SMS/MMS and iMessage?

SMS/MMS lets you send text messages and photos to other cellular phones or devices. iMessage lets you send text messages and photos to another iOS device over Wi-Fi, without worrying about text-messaging charges (cellular data charges may apply).


What do I need to use SMS/MMS and iMessage?

Here's what you need to use SMS/MMS and iMessage:

  • SMS/MMS: A text-messaging plan. Contact your carrier for more information.
  • iMessage: An iPhone, iPad, or iPod touch with iOS 5 or later.


Can’t get text messages from an iPhone - Apple Support
http://support.apple.com/en-us/TS5185


You can't send SMS or text messages to a non-Apple phone (such as an Android, Windows, or BlackBerry phone), because the messages are sent as iMessage


This can happen if you used iMessage on your iPhone and then transferred your SIM card or phone number to a non-Apple phone. If you didn't turn off or deactivate iMessage before switching to a non-Apple phone, other iOS devices will still try to use iMessage to send text messages to your phone number. Follow the appropriate steps below to resolve the issue. Likewise, if you can't send someone a text who used to have an iPhone, having them follow these steps should resolve the issue.

If you still have your iPhone

  1. Put the SIM card you transferred from your iPhone back into your iPhone.
  2. Make sure that you're connected to a cellular data network (such as 3G or LTE).
  3. Tap Settings > Messages and turn iMessage off.

If you don't have your iPhone or if you can't turn off iMessage

Use the deregister iMessage webpage. For more information, see Deregister iMessage: Frequently Asked Questions.

These steps won't deregister your phone number with iMessage

  • Logging in to My Support Profile and changing your password or removing your phone number
  • Texting STOP to 48369
  • Resetting your network settings
  • Changing your Apple ID password
Last Modified:



I hope this information helps ....


- Judy

Dec 31, 2014 8:47 AM

Question marked as Helpful

May 6, 2017 8:08 PM in response to Rhys1998 In response to Rhys1998

May 2017 Update, Fix, Solution,: This started happening to me recently where iMessage on MacBook Pro and iMac wouldn't send unless the contact had iMessage and won't send to the mobile number.


After reading all answers about turning iMessage on and off and reactivating forwarding to and from the device and changing the Apple ID password it STILL didn't work.


What I have discovered is that this was ONLY doing this to the numbers in my contacts that didn't have the correct country code in front of them ie. 0400 400 450 didn't send in iMessage but as soon as I changed it to +61 400 400 450 (for example), it worked perfectly.


I've just gone into my contact list (which I share also via iCloud through all my devices and my iMessage is working perfectly now for all my contacts. I wish I had known this sooner rather than wasting over 2 days on this problem. I only discovered the solution by accident because the messages that weren't going through were the ones that didn't have the country code in front of them.


Thankfully fixed now. Found it easier to log into iCloud and update all my numbers from there 😉

May 6, 2017 8:08 PM

Question marked as Helpful

Nov 18, 2016 12:06 PM in response to Jarodmader In response to Jarodmader

I had the same problem until I watched this Youtube video https://youtu.be/ADqLorgbtj0

The problem is a configuration issue with your service provider. I followed the recommendations on the video and did the following: dial **5005*7672*+insert service provider's message centre number. Use the international "+" dialing code. you should be able to get the message centre number from your service provider. I hope this helps.

Nov 18, 2016 12:06 PM

Question marked as Helpful

Aug 22, 2017 7:19 PM in response to Rhys1998 In response to Rhys1998

I had exactly the problem, my iphone 7plus would send and receive iMessages but not SMS/MMS. After trying hard reset, network reset, bad language and general phone abuse, I decided to swap SIM cards with my iPad mini to see if was my phone or I needed to call my carrier.

I'm not sure exactly how it happened, only that all I did was swap the SIMs, did couple of a test messages and swapped them back and ABRACADAPPLE the problem was resolved!

I hope this might help some other desperate person.

Aug 22, 2017 7:19 PM

There’s more to the conversation

Read all replies
Question marked as Helpful

Dec 31, 2014 8:47 AM in response to Rhys1998 In response to Rhys1998

Hi Rhys1998,

Happy New Year! If you are not able to send SMS messages to a non-Apple phone, try these troubleshooting steps:



If you can't send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

http://support.apple.com/en-us/HT204065


Check your device settings

  1. Make sure that you’re connected to a cellular data or Wi-Fi network.
  2. Go to Settings > Messages and make sure that iMessage, Send as SMS, or MMS Messaging is turned on (whichever method you're trying to use). Learn about the different types of messages you can send.
    User uploaded file

Check the recipient's contact info

  1. Make sure that you're using the right phone number or email address.
  2. Go to Settings > Messages > Blocked and make sure that they're not on your block list.

Restart your device and check for updates

  1. Restart your device.
  2. Check for a carrier settings update.
  3. Check for an iOS software update.

Check the system status for iMessage

Go to the Apple Services System Status page and check iMessage.

Turn iMessage off and back on

Go to Settings > Messages and turn iMessage off, then back on.

Sign out and back in to iMessage and FaceTime

  1. Go to Settings > Messages > Send & Receive, tap your Apple ID, then tap Sign Out.
  2. Go to Settings > FaceTime, tap your Apple ID, then tap Sign Out.
  3. On your iPhone first, sign back in to iMessage and Facetime.
  4. Sign back in to iMessage and Facetime on your other devices.

Reset your network settings

Tap Settings > General > Reset > Reset Network Settings.

Back up and restore your device

Use iTunes or iCloud to back up your content, then restore your device.



Send messages with your iPhone, iPad, or iPod touch - Apple Support
http://support.apple.com/en-us/HT201287

What's the difference between SMS/MMS and iMessage?

SMS/MMS lets you send text messages and photos to other cellular phones or devices. iMessage lets you send text messages and photos to another iOS device over Wi-Fi, without worrying about text-messaging charges (cellular data charges may apply).


What do I need to use SMS/MMS and iMessage?

Here's what you need to use SMS/MMS and iMessage:

  • SMS/MMS: A text-messaging plan. Contact your carrier for more information.
  • iMessage: An iPhone, iPad, or iPod touch with iOS 5 or later.


Can’t get text messages from an iPhone - Apple Support
http://support.apple.com/en-us/TS5185


You can't send SMS or text messages to a non-Apple phone (such as an Android, Windows, or BlackBerry phone), because the messages are sent as iMessage


This can happen if you used iMessage on your iPhone and then transferred your SIM card or phone number to a non-Apple phone. If you didn't turn off or deactivate iMessage before switching to a non-Apple phone, other iOS devices will still try to use iMessage to send text messages to your phone number. Follow the appropriate steps below to resolve the issue. Likewise, if you can't send someone a text who used to have an iPhone, having them follow these steps should resolve the issue.

If you still have your iPhone

  1. Put the SIM card you transferred from your iPhone back into your iPhone.
  2. Make sure that you're connected to a cellular data network (such as 3G or LTE).
  3. Tap Settings > Messages and turn iMessage off.

If you don't have your iPhone or if you can't turn off iMessage

Use the deregister iMessage webpage. For more information, see Deregister iMessage: Frequently Asked Questions.

These steps won't deregister your phone number with iMessage

  • Logging in to My Support Profile and changing your password or removing your phone number
  • Texting STOP to 48369
  • Resetting your network settings
  • Changing your Apple ID password
Last Modified:



I hope this information helps ....


- Judy

Dec 31, 2014 8:47 AM

Reply Helpful (48)
Question marked as Helpful

Nov 14, 2016 12:09 PM in response to Rhys1998 In response to Rhys1998

I'm getting an "undelivered" message beneath this one text in a group thread that has one or more non-iOS user(s). I tried the sign out of iMessage and FaceTime then sign back in thing --I even rebooted the phone after signing out -- but to no avail whatever. I have never had this problem before, and it's really rubbing me the wrong way. That green bubble is just disgusting. I guess I need to call AT&T.

Nov 14, 2016 12:09 PM

Reply Helpful (150)
Question marked as Helpful

Nov 18, 2016 12:06 PM in response to Jarodmader In response to Jarodmader

I had the same problem until I watched this Youtube video https://youtu.be/ADqLorgbtj0

The problem is a configuration issue with your service provider. I followed the recommendations on the video and did the following: dial **5005*7672*+insert service provider's message centre number. Use the international "+" dialing code. you should be able to get the message centre number from your service provider. I hope this helps.

Nov 18, 2016 12:06 PM

Reply Helpful (24)
Question marked as Helpful

Mar 6, 2017 6:15 PM in response to Rhys1998 In response to Rhys1998

I have the same problem. My work around is to say "hey Siri, text John Doe" then it pulls the number from my contacts. But if I type "John Doe" in the To: box it only pulls up emails unless all I have in my contacts is a phone number.

Mar 6, 2017 6:15 PM

Reply Helpful (36)
Question marked as Helpful

May 6, 2017 8:08 PM in response to Rhys1998 In response to Rhys1998

May 2017 Update, Fix, Solution,: This started happening to me recently where iMessage on MacBook Pro and iMac wouldn't send unless the contact had iMessage and won't send to the mobile number.


After reading all answers about turning iMessage on and off and reactivating forwarding to and from the device and changing the Apple ID password it STILL didn't work.


What I have discovered is that this was ONLY doing this to the numbers in my contacts that didn't have the correct country code in front of them ie. 0400 400 450 didn't send in iMessage but as soon as I changed it to +61 400 400 450 (for example), it worked perfectly.


I've just gone into my contact list (which I share also via iCloud through all my devices and my iMessage is working perfectly now for all my contacts. I wish I had known this sooner rather than wasting over 2 days on this problem. I only discovered the solution by accident because the messages that weren't going through were the ones that didn't have the country code in front of them.


Thankfully fixed now. Found it easier to log into iCloud and update all my numbers from there 😉

May 6, 2017 8:08 PM

Reply Helpful (25)

May 27, 2017 6:51 PM in response to Rhys1998 In response to Rhys1998

At first it sounds like its not connected to data, but it still can send sms. Did you buy the phone brsnd new from apple? Try reseting the mesage settings too. If it is a used ohone, it could also be carrier settings, that you may have to go to the carrier, some carrier settings cant be changed directly from the phone

May 27, 2017 6:51 PM

Reply Helpful
Question marked as Helpful

Aug 22, 2017 7:19 PM in response to Rhys1998 In response to Rhys1998

I had exactly the problem, my iphone 7plus would send and receive iMessages but not SMS/MMS. After trying hard reset, network reset, bad language and general phone abuse, I decided to swap SIM cards with my iPad mini to see if was my phone or I needed to call my carrier.

I'm not sure exactly how it happened, only that all I did was swap the SIMs, did couple of a test messages and swapped them back and ABRACADAPPLE the problem was resolved!

I hope this might help some other desperate person.

Aug 22, 2017 7:19 PM

Reply Helpful (13)
User profile for user: Rhys1998

Question: iPhone won't send texts to Android phones