Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: WIFI Problem 10.10.3

After updating to 10.10.3 my Mac Mini 2014 is having Problem with WIFI, its connecting but after a couple of minutes the Internet Connection goes off!! Have to disconnect WIFI and switch on again and it works again for a couple of minutes!!


Anybody elase having the same Problem??

Mac mini, OS X Yosemite (10.10.3), 2014

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I took my WiFi IO80211Family.kext from my Time Machine 10.10.2 backup (this one was working with mx mac mini) and now Wireless is up and running since 2 hours.....

Posted on

Question marked as Helpful

Apr 9, 2015 1:43 PM in response to werner-theo69 In response to werner-theo69

Please test after taking each of the following steps that you haven't already tried. Stop when the problem is resolved. Back up all data before making any changes.

Step 1

Take the applicable steps in this support article. The Wireless Diagnostics program generates a large file of information about your system, which would be used by Apple Engineering in case of a support incident. Don't post the contents here.

Be sure to test on more than one Wi-Fi network, if at all possible. A desktop computer can be tested with a mobile hotspot, such as the hotspot created by a cell phone. If the problem only exists on one network, then the access point of that network should be the focus of your attention, not the computer.

Step 2

Disconnect all USB 3 devices. If you don't know which are USB 3, disconnect all USB devices except keyboard and mouse.

Step 3

If you're not using a wireless keyboard or trackpad, disable Bluetooth by selecting Turn Bluetooth Off from the menu with the Bluetooth icon. If you don't have that menu, open the Bluetooth preference pane in System Preferences and check the box marked Show Bluetooth in menu bar. Test. If you find that Wi-Fi works better with Bluetooth disabled, you should use the 5 GHz Wi-Fi band. Your router may not support it; in that case, you need a new router.

Step 4

Open the Energy Saver pane in System Preferences and unlock the settings, if necessary. Select the Power Adapter tab, if there is one. Uncheck the box marked

Wake for Wi-Fi network access

if it's checked.

Step 5

Open the Network pane in System Preferences and make a note of your settings in the Wi-Fi service. It may be helpful to take screenshots of the various tabs in the preference pane. If the preference pane is locked, unlock it by clicking the padlock icon and entering your administrator password. Delete Wi-Fi from the service list on the left by selecting it and clicking the minus-sign button at the bottom. Then recreate the service by clicking the plus-sign button and following the prompts.

Step 6

In the Wi-Fi settings, select

Advanced... TCP/IP Configure IPv6: Link-local only

Click OK and then Apply.

Step 7

Reset the System Management Controller.

Step 8

Reset the PRAM.

Step 9

Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first. Turn Wi-Fi off and then back on. You'll be prompted for the password when you reconnect. Save it in the keychain.

Step 10

Make a "Genius" appointment at an Apple Store, or go to another authorized service center.

There’s more to the conversation

Read all replies

Page content loaded

Apr 9, 2015 10:54 AM in response to werner-theo69 In response to werner-theo69

My wifi network is useless after updating to OSX 10.10.3. Evidently, the update corrupted the wireless network itself since my mobile devices are unable to access the network also. I recreated my wifi network from scratch but this failed to resolve the problem. Even when I connected to my Apple router via Ethernet, I was unable to connect to the Internet. Ultimately, I had to connect directly to my ISP's provided modem/router via Ethernet to access the Internet.

Apr 9, 2015 10:54 AM

Reply Helpful
Question marked as Helpful

Apr 9, 2015 1:43 PM in response to werner-theo69 In response to werner-theo69

Please test after taking each of the following steps that you haven't already tried. Stop when the problem is resolved. Back up all data before making any changes.

Step 1

Take the applicable steps in this support article. The Wireless Diagnostics program generates a large file of information about your system, which would be used by Apple Engineering in case of a support incident. Don't post the contents here.

Be sure to test on more than one Wi-Fi network, if at all possible. A desktop computer can be tested with a mobile hotspot, such as the hotspot created by a cell phone. If the problem only exists on one network, then the access point of that network should be the focus of your attention, not the computer.

Step 2

Disconnect all USB 3 devices. If you don't know which are USB 3, disconnect all USB devices except keyboard and mouse.

Step 3

If you're not using a wireless keyboard or trackpad, disable Bluetooth by selecting Turn Bluetooth Off from the menu with the Bluetooth icon. If you don't have that menu, open the Bluetooth preference pane in System Preferences and check the box marked Show Bluetooth in menu bar. Test. If you find that Wi-Fi works better with Bluetooth disabled, you should use the 5 GHz Wi-Fi band. Your router may not support it; in that case, you need a new router.

Step 4

Open the Energy Saver pane in System Preferences and unlock the settings, if necessary. Select the Power Adapter tab, if there is one. Uncheck the box marked

Wake for Wi-Fi network access

if it's checked.

Step 5

Open the Network pane in System Preferences and make a note of your settings in the Wi-Fi service. It may be helpful to take screenshots of the various tabs in the preference pane. If the preference pane is locked, unlock it by clicking the padlock icon and entering your administrator password. Delete Wi-Fi from the service list on the left by selecting it and clicking the minus-sign button at the bottom. Then recreate the service by clicking the plus-sign button and following the prompts.

Step 6

In the Wi-Fi settings, select

Advanced... TCP/IP Configure IPv6: Link-local only

Click OK and then Apply.

Step 7

Reset the System Management Controller.

Step 8

Reset the PRAM.

Step 9

Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first. Turn Wi-Fi off and then back on. You'll be prompted for the password when you reconnect. Save it in the keychain.

Step 10

Make a "Genius" appointment at an Apple Store, or go to another authorized service center.

Apr 9, 2015 1:43 PM

Reply Helpful (12)

Apr 9, 2015 1:27 PM in response to werner-theo69 In response to werner-theo69

I have the same problem here! New Mac Mini, bought 2 weeks ago. After a few minutes connected over WIFI, the wifi connection drop me off. Need to reconnect and the game starts new. WIFI is after the latest Yosemite update useless. This also happen now when i´m in a 5Ghz network.


My old Mavericks MacBook dont have any problems.

Apr 9, 2015 1:27 PM

Reply Helpful

Apr 9, 2015 1:44 PM in response to werner-theo69 In response to werner-theo69

looks like the Problem is gone, rebooted the Router and removed all connection and reconnected, now it seem to work 🙂 Fingers crossed...

Apr 9, 2015 1:44 PM

Reply Helpful

Apr 9, 2015 2:11 PM in response to skadoo In response to skadoo

Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.


Feedback




Or you can use your Apple ID to register with this site and go the Apple BugReporter. Supposedly you will get an answer if you submit feedback.


Feedback via Apple Developer

Apr 9, 2015 2:11 PM

Reply Helpful

Apr 9, 2015 5:49 PM in response to wifiguru In response to wifiguru

You nailed it brother! I didn't delete the entire SystemConfiguration folder however. I only deleted the .plist(s) that had Airport in their name. I rebooted my Mac and reset my router to its factory default settings. Then I recreated my wifi network. For extra insurance, I named the new network differently. It restored my wifi connectivity to all my devices after I logged into the new wifi network on each device. THANK YOU

Apr 9, 2015 5:49 PM

Reply Helpful

Apr 10, 2015 1:30 AM in response to werner-theo69 In response to werner-theo69

This helped me (at least for now):

  • Go to the  Apple menu and System Preferences, then choose the “Network” preference panel
  • Select Wi-Fi from the sidebar, then in the Location menu choose “Edit Locations”
  • Click the [+] plus button to add a new location, name it something obvious like “OS X 10.10.2 Wi-Fi Fix” then choose “Done”
  • Join your wi-fi network as usual by selecting it from the Network Name menu
  • Now click the “Advanced” button
  • Choose the “DNS” tab and manually add DNS servers that are appropriate for your location, these can the DNS from your ISP, or something like Google DNS service: 8.8.8.8
  • Choose “OK” then click “Apply” to confirm the changes made
  • Back at the  Apple menu, choose ‘Restart…’ and reboot the Mac

Apr 10, 2015 1:30 AM

Reply Helpful

Apr 10, 2015 2:28 AM in response to werner-theo69 In response to werner-theo69

Same issue here on 2013 macbook air 13", 10.10.3. Had wifi issue since 10.10.1. Definitely a software issue. I installed windows via bootcamp and Wifi is working perfectly fine. Guess i have to stick with windows on my macbook air for a little longer. Hope Apple is taking this issue seriously, no fix after 2 updates?!

Apr 10, 2015 2:28 AM

Reply Helpful
User profile for user: werner-theo69

Question: WIFI Problem 10.10.3