Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mac VNC not working after Security Update 2016-002

After the Security Update 2016-002, I am unable to VNC into any Mac Machine that was updated.


Error: The user account you selected isn't available



User uploaded file

Posted on

Reply
Question marked as Solved
Answer:
Answer:

before this updates, the scenario here was:

- 1 iMac with Yosemite

- 1 person working directly on iMac

- 2 guys connecting to iMac from Windows using VNC

- The iMac must be logged for the others 2 connect on separate session.

- If the Mac was on users selection and someone connect on Mac with VNC, this user control all the Mac, and the screen will be mirrored for all, every user won't get a separate session. To get right, all users must be disconnected including the iMac, and then connect first on iMac and then the others can connect.


after the update "Remote Desktop client update" and "safari update" we couldn't connect to Mac anymore, the "securit update 2016-002" wasn't installed yet.

if the iMac is on the users selection screen, I'm be able to connect on Mac, but the screen will be mirrored, but we won't be able to connect on separate sessions anymore.


Now we are updating the Mac to El Capitan.

When the installation finish, we will test and get you noticed.

Posted on

Page content loaded

Mar 22, 2016 11:58 AM in response to areynolds55 In response to areynolds55

😊 I do not have the Security Update 2016-002 installed. 😊


Thanks for the heads up. I better backup my machine before doing the update.



I'm remoted to my mac running 10.10.5. I found the apple solution too slow for my needs. I use both the client and server software from realvnc. The client is free. The server is free for a month. Could get you going while you sort out the problem.


User uploaded file

Mar 22, 2016 11:58 AM

Reply Helpful

Mar 22, 2016 1:31 PM in response to amexhotmail In response to amexhotmail

Yes it is with Yosemite, not El Capitan. Also I can use any 3rd Party VNC Server/Client (RealVNC, TightVNC, etc.) and they work. These updates broke the native Mac VNC function. The update included Security Update 2016-002, and Remote Desktop update. Since they were updated together, and I did not want to jack up another one of my Macs, I did not go back and try to update them separately to see if the Remote Desktop update broke it, or the Security Update broke it. I am leaning more towards the Remote Desktop update.


Thanks everyone for your reply, I was really just checking to see if anyone else was having to issue, and to warn anybody that have not applied the updates, that you may want to hold off.

Mar 22, 2016 1:31 PM

Reply Helpful

Mar 22, 2016 3:32 PM in response to areynolds55 In response to areynolds55

I have a MacMini with Yosemite hooked up to my TV. It has the "Remote Desktop Update" installed but NOT "the 2016-002 Security Update". Both Chicken of the Sea and RealVNC fail with "The user account you selected isn't available".


I am still able to connect to it via "Share Screen..." once I have a remote volume mounted. It seems to be a pain and a half trying to get "write control" using this method without having a mouse hooked up to the Mini which kind of defeats the purpose.

Mar 22, 2016 3:32 PM

Reply Helpful

Mar 22, 2016 3:33 PM in response to rccharles In response to rccharles

I also am deeply screwed. Thank god I got taxes out of the way, first. But my worklife is crushed.

I have iMac 27 inch, circa 2012, didn't update to El Capitan, as other software was not compatible.

Tried to download and install updates starting 3/20, and multiple times on 3/21, after reboot. It hangs every time,

and now still compromised. Spinning ball of death mid install. Now spinning ball on every cursor click


Have used Macs since 1989. Am working on MacBook Pro, to try to salvage issues. But afraid to do more Yosemite updates

to avoid total disaster

rccharles wrote:


I've updated & realvnc is still working.


User uploaded file

Mar 22, 2016 3:33 PM

Reply Helpful

Mar 22, 2016 4:12 PM in response to GemaireIT In response to GemaireIT

I'm able to SSH into my mini and by running this command


sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -privs -all -allowAccessFor -allUsers -clientopts -vnclegacy no -restart -agent -console -menu


(understand all the options of this command before you run it, as it gives wide permissions!) I was able to remote terminal with RealVNC.


Chicken of the Sea was using the legacy VNC to connect and that seems to be what is now borked by the update.

Mar 22, 2016 4:12 PM

Reply Helpful

Mar 22, 2016 4:30 PM in response to c17r_ In response to c17r_

You need to turn off apple's vnc to use realvnc server.


Here are my setting.


User uploaded file


Please note:

-- I am running realvnc server and realvnc client to improve vnc performance.

-- I'm running on a home network behind two routers. I do not do any port forwarding on my routers.

-- in security and privacy, I turned off the firewall. There is a way of opening the ports. I did this at one time.

-- I've turned off encryption on the server.

-- I've turned off authentication on the server. There is an option to save your password on the client. I was doing this.

Mar 22, 2016 4:30 PM

Reply Helpful

Mar 22, 2016 4:24 PM in response to rccharles In response to rccharles

If you are using a 3rd party RealVNC server and not the built in "Remote Management" feature, then your "works for me" isn't really relevant! 😁


But using the kickstart command I posted above does allow me to use the RealVNC viewer with the OSX built-in "Remote Management" process, even after the borked update.

Mar 22, 2016 4:24 PM

Reply Helpful
User profile for user: areynolds55

Question: Mac VNC not working after Security Update 2016-002