Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Google links don't work after iOS 9.3

After update to iOS 9.3 on my iPhone 6 Plus I can no longer click on search links from Google anymore. Tried both in Safari and Chrome. Works well with Bing.com.


If I hold down on the link and choose to open in new tab it works.


restarted apps -> same result

Rebooted iPhone twice -> same result.


suggestions?

iPhone 6 Plus, iOS 9.3

Posted on

Reply

There’s more to the conversation

Read all replies
Question marked as Helpful

Mar 26, 2016 8:02 AM in response to OriginalName022 In response to OriginalName022

I turned javascript off as others suggested but other links and links in mail still don't work!! Sooooo frustrating I hope this gets fixed soon. Basically can't use my phone except to talk.

Mar 26, 2016 8:02 AM

Reply Helpful (6)

Mar 26, 2016 1:35 PM in response to Agathorn In response to Agathorn

The same thing happened to me after 8.3 was released, even though I didn't upgrade. I tried upgrading the problem didn't go away. I tried wiping and restoring from backup, the problem still didn't go away. In the end wiping the entire phone and not restoring from backup, fixed the problem even on 8.3, but it's ridiculous to have to go through such lengths, just to be able to click on a link.

Mar 26, 2016 1:35 PM

Reply Helpful

Mar 26, 2016 5:08 PM in response to Agathorn In response to Agathorn

I have the same problem.... i have the 9.1 firmware on Iphone 6 and i actualize it to 9.2 then i start my problems with links on safari and whatsapp, emails....all links get frezee (I m spanish...sorry for the write mistakes) , i go to apple store and they restablize my iphone but i loose all things... because they configure it as a new iphone.

The problem desapear....

but today i update to 9.3 firmware and the problem come back....

I think is a problem only on iphone 6 because my iphone 5 no have this problem when i update the firmware.

Please solve quiqly the problemm !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Mar 26, 2016 5:08 PM

Reply Helpful (2)

Mar 26, 2016 5:50 PM in response to Agathorn In response to Agathorn

I was frustrated enough to try to go back to 9.2.1. No Go...ran into the "Software too old" message in iTunes (Windows) when I try to restore the phone after I do the downgrade to 9.2.1. Frustrating to say the least.


I'm (kid you not) 6 hours into restoring my iphone 6+ (128Gb) to 9.3 from the backup. End result will be still having the broken links problem. :-/


I'm trying to remember the number of times I've told folks not to immediately upgrade to the new release. Should have been a little more suspect of a new release that's timed with a somewhat big announcement by Apple.


Live and learn...not sure if anyone has the magic process to downgrade from 9.3 that actually works. I know that Apple is still signing the 9.2.1 IPSW file, but not sure how to get around the "Software too old message). More curious really, after the restore back to 9.3, will just wait until fix for 9.3 comes out. Which like everyone else...I hope is SOON.


Good luck.

Mar 26, 2016 5:50 PM

Reply Helpful (3)

Mar 26, 2016 7:35 PM in response to Agathorn In response to Agathorn

Same problem (links in safari do not work) and I have spent SO much time on this including chats, phone calls with Apple and a trip to the Genius Bar where we thought he fixed it. It does not work even though we erased my phone and reset, etc....... SO frustrating and my phone is not smart anymore. I wish I had not upgraded to 9.3 so quickly as well and waited until I heard more about it. My husband has a 6s and his did fine. Mine is a 6plus.

Mar 26, 2016 7:35 PM

Reply Helpful (2)
User profile for user: Agathorn

Question: Google links don't work after iOS 9.3