Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: how do I get rid of "6H4HRTU5E3.com.avast.passwords.Agent" and "com.google.keystone.agent.plist"

These items keep showing up on my EtreCheck report. I did an uninstall of Avast and this Launch Agent still shows up. What is the com.google.keystone.agent.plist and do I need it?

I have tried searching for both from Spotlight and the Finder Search and cannot find them. I also checked Hidden Files in the Finder Search.

iMac, macOS Sierra (10.12.1), iMac (21.5-inch, Mid 2011)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

The header above each section indicates where the files are located.

System Launch Agents or Daemons are in the System Library in the respective folder.

Launch Agents and Daemons are in the "All User" Library

User Launch Agents are in the user Library.

Posted on

Page content loaded

Nov 12, 2017 6:16 PM in response to Gary Davison In response to Gary Davison

Etrecheck tells you exactly where they are located. No need to search at all.

They are either in your user/Library/LaunchAgents or in /Library/LaunchAgents.

If your user Library is hidden, hold down the Option key and select Library from the Go menu in Finder.


The Keystone Agent is Google's auto-update mechanism. Some info here:

http://applehelpwriter.com/2014/07/13/how-to-remove-googles-secret-update-softwa re-from-your-mac/

However, there is no need to go through the process to remove it as described in the Link. John Galt has posted a link to the official uninstall instructions.

Nov 12, 2017 6:16 PM

Reply Helpful

Nov 12, 2017 6:10 PM in response to Gary Davison In response to Gary Davison

The "keystone" agent invokes Google's automatic updating service. Get rid of Google by following its uninstallation instructions, here: Uninstall Google Chrome - Computer - Google Chrome Help. As far as I know those instructions will remove the agent effectively.


"Avast!" can be completely removed by using its uninstaller app. It is completely effective. If you used some other means of eradicating it, you might need to download and install it all over again, for the sole purpose of uninstalling it correctly. Follow their instructions: Official Avast Support | Uninstalling Avast Security from Mac.


As it states,


IMPORTANT: Deleting or moving Avast Security to the Trash does not uninstall the program.

Nov 12, 2017 6:10 PM

Reply Helpful

Nov 12, 2017 6:34 PM in response to Barney-15E In response to Barney-15E

Hi Barney, thank you for the reply. Please tell me where EtreCheck tell me where the files are located. Here is a copy of my report


EtreCheck version: 3.4.6 (460)

Report generated 2017-11-12 19:23:13

Download EtreCheck from https://etrecheck.com

Runtime: 3:27

Performance: Good


Click the [Lookup] links for more information from Apple Support Communities.

Click the [Details] links for more information about that line.


Problem: Beachballing

Description:

this shows up a lot


Hardware Information:

iMac (21.5-inch, Mid 2011)

[Technical Specifications] - [User Guide] - [Warranty & Service]

iMac - model: iMac12,1

1 2.5 GHz Intel Core i5 (i5-2400S) CPU: 4-core

4 GB RAM Upgradeable - [Instructions]

BANK 0/DIMM0

2 GB DDR3 1333 MHz ok

BANK 1/DIMM0

2 GB DDR3 1333 MHz ok

BANK 0/DIMM1

Empty

BANK 1/DIMM1

Empty

Handoff/Airdrop2: not supported

Wireless: en1: 802.11 a/b/g/n


Video Information:

AMD Radeon HD 6750M - VRAM: 512 MB

iMac 1920 x 1080


Disk Information:

WDC WD5000AAKS-402AA0 disk0: (500.11 GB) (Rotational)

[Show SMART report]

EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

Macintosh HD (disk0s2 - Journaled HFS+) / [Startup]: 499.25 GB (348.72 GB free)

Recovery HD (disk0s3 - Journaled HFS+) /Volumes/Recovery HD [Recovery]: 650 MB (81 MB free)


OPTIARC DVD RW AD-5690H ()


USB Information:

USB20Bus

Apple Inc. FaceTime HD Camera (Built-in)

hub_device

USB2.0 Hub

Canon MG5100 series

USB2.0 Hub

Apple Inc. BRCM2046 Hub

Apple Inc. Bluetooth USB Host Controller

USB20Bus

hub_device

Mitsumi Electric Hub in Apple Extended USB Keyboard

Mitsumi Electric Apple Extended USB Keyboard

ioSafe ioSafe G3

G3 disk1: (2 TB)

EFI (disk1s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

Solo Time Machine (disk1s2 - Journaled HFS+) /Volumes/Solo Time Machine : 2.00 TB (1.29 TB free)

Apple Computer, Inc. IR Receiver

Apple Card Reader


Thunderbolt Information:

Apple Inc. thunderbolt_bus


System Software:

macOS Sierra 10.12.6 (16G1108) - Time since boot: about 2 days


Configuration files:

/etc/sysctl.conf - File exists but not expected


Gatekeeper:

Mac App Store and identified developers


Kernel Extensions:

/Library/Application Support/ESET/esets/PlugIns/kext

[not loaded] com.eset.kext.esets_kac (6.0.14) [Lookup]

[not loaded] com.eset.kext.esets_pfw (6.0.14) [Lookup]


/System/Library/Extensions

[not loaded] com.MCCI.SLAB_USBtoUART (V1.02.2) [Lookup]

[not loaded] com.mice.driver.Wireless360Controller (1.0.0d11) [Lookup]

[not loaded] com.mice.driver.WirelessGamingReceiver (1.0.0d11) [Lookup]

[not loaded] com.mice.driver.Xbox360Controller (1.0.0d11) [Lookup]


/System/Library/Extensions/AppleAC97Audio.kext/Contents/PlugIns

[not loaded] maxxuss.driver.AC97AudioES137x (0.1.0) [Lookup]


System Launch Agents:

[not loaded] 7 Apple tasks

[loaded] 165 Apple tasks

[running] 106 Apple tasks

[killed] 7 Apple tasks

7 processes killed due to insufficient RAM


System Launch Daemons:

[not loaded] 41 Apple tasks

[loaded] 167 Apple tasks

[running] 98 Apple tasks

[killed] 13 Apple tasks

13 processes killed due to insufficient RAM


Launch Agents:

[running] 6H4HRTU5E3.com.avast.passwords.Agent.plist (AVAST Software a.s. - installed 2017-02-27) [Lookup]

[failed] com.google.keystone.agent.plist (? 7cf33771 18df9f53 - installed 2015-11-21) [Lookup]

[loaded] com.oracle.java.Java-Updater.plist (? e341ad36 be93c7fb - installed 2017-04-25) [Lookup]

[running] com.rosettastone.rosettastonedaemon.plist (Rosetta Stone Ltd. - installed 2015-01-28) [Lookup]


Launch Daemons:

[loaded] com.adobe.fpsaud.plist (? 2afb3af7 564efddb - installed 2017-10-20) [Lookup]

[loaded] com.google.keystone.daemon.plist (Google Inc. - installed 2015-11-21) [Lookup]

[loaded] com.malwarebytes.HelperTool.plist (Malwarebytes Corporation - installed 2017-02-03) [Lookup]

[loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-10-11) [Lookup]

[loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e 442fdde9 - installed 2011-03-10) [Lookup]

[loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2017-09-02) [Lookup]

[loaded] com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2017-03-15) [Lookup]

[loaded] com.teamviewer.Helper.plist (TeamViewer GmbH - installed 2016-09-19) [Lookup]


User Launch Agents:

[not loaded] com.adobe.ARM.[...].plist (? c8cc50de 6f08ab03 - installed 2017-01-12) [Lookup]

[running] com.amazon.music.plist (? 7c73c27a 804d536f - installed 2017-05-05) [Lookup]

[loaded] com.valvesoftware.steamclean.plist (? 70fe1d62 f03ac3b1 - installed 2017-07-08) [Lookup]


User Login Items:

iTunesHelper Application - Hidden (Apple, Inc. - installed 2017-10-31)

(/Applications/iTunes.app/Contents/MacOS/iTunesHelper.app)

MacGameStore Helper Application

(~/Library/Application Support/MacGameStore.com/Helper/MacGameStore Helper.app)

ConnectService Application

(/Library/Application Support/ArcSoft/Connect Service/ConnectService.app)


Internet Plug-ins:

o1dbrowserplugin: 5.41.3.0 (installed 2015-12-11) [Lookup]

AmazonMP3DownloaderPlugin1017277: AmazonMP3DownloaderPlugin 1.0.17 (installed 2012-10-06) [Lookup]

SkyCaddiePlugIn: 1.02 (installed 2012-08-19) [Lookup]

Google Earth Web Plug-in: 7.1 (installed 2015-11-21) [Lookup]

Flip4Mac WMV Plugin: 3.2.0.16 (installed 2013-05-03) [Lookup]

AdobePDFViewerNPAPI: 11.0.19 (installed 2017-01-12) [Lookup]

FlashPlayer-10.6: 27.0.0.183 (installed 2017-10-31) [Lookup]

Silverlight: 5.1.50901.0 (installed 2016-10-28) [Lookup]

QuickTime Plugin: 7.7.3 (installed 2017-11-09)

Flash Player: 27.0.0.183 (installed 2017-10-31) [Lookup]

googletalkbrowserplugin: 5.41.3.0 (installed 2015-12-11) [Lookup]

iPhotoPhotocast: 6.0 (installed 2005-12-23)

AdobePDFViewer: 11.0.19 (installed 2017-01-12) [Lookup]

CouponPrinter-FireFox_v2: Version 1.1.9 (installed 2012-11-14) [Lookup]

GarminGpsControl: 4.2.0.0 (installed 2014-03-31) [Lookup]

EPPEX Plugin: 10.0 (installed 2013-11-04) [Lookup]

SharePointBrowserPlugin: 14.7.7 (installed 2017-09-12) [Lookup]

JavaAppletPlugin: Java 8 Update 131 build 11 (installed 2017-04-25) Check version


Safari Extensions:

[disabled] Add To Amazon Wish List - Amazon.com - https://www.amazon.com/wishlist?ref=cm_wl_saf_ext (installed 2013-01-19)

[not loaded] Avast Online Security - AVAST Software - http://www.avast.com (installed 2015-03-04)


3rd Party Preference Panes:

Flash Player (installed 2017-10-20) [Lookup]

Flip4Mac WMV (installed 2013-05-03) [Lookup]

GoToMyPC Preferences (installed 2010-07-26) [Lookup]

Java (installed 2017-04-25) [Lookup]


Time Machine:

Skip System Files: NO

Mobile backups: OFF

Auto backup: YES

Volumes being backed up:

Macintosh HD: Disk size: 499.25 GB Disk used: 150.53 GB

Destinations:

Solo Time Machine [Local]

Total size: 2.00 TB

Total number of backups: 124

Oldest backup: 5/31/15, 12:27 AM

Last backup: 11/12/17, 6:50 PM

Size of backup disk: Excellent

Backup size 2.00 TB > (Disk size 499.25 GB X 3)


Top Processes by CPU:

22% mdworker

9% backupd

5% mdworker

5% mdworker

5% kernel_task


Top Processes by Memory:

648 MB kernel_task

235 MB Microsoft Excel

170 MB HelpViewer

131 MB sandboxd

126 MB Microsoft Word


Top Processes by Network Use:

Input Output Process name

488 KB 196 KB mDNSResponder

71 KB 163 KB apsd

6 KB 6 KB ntpd

6 KB 4 KB netbiosd

7 KB 1 KB com.apple.Safari.SafeBrowsing.Service


Top Processes by Energy Use:

8.86 backupd

4.78 mds

4.36 WindowServer

2.44 mds_stores


Virtual Memory Information:

792 MB Available RAM

19 MB Free RAM

3.23 GB Used RAM

773 MB Cached files

322 MB Swap Used


Software installs (last 30 days):

Adobe Flash Player: (installed 2017-10-31)

Microsoft Outlook for Mac: (installed 2017-11-06)

Microsoft PowerPoint for Mac: (installed 2017-11-06)

Microsoft Excel for Mac: (installed 2017-11-06)

Microsoft Word for Mac: (installed 2017-11-06)

Malwarebytes for Mac: (installed 2017-11-09)

Microsoft OneNote for Mac: (installed 2017-11-09)

"Malwarebytes for Mac Uninstaller": (installed 2017-11-10)

DoodleCAD: 1.6.16 (installed 2017-11-12)


Install information may not be complete.


Diagnostics Events (last 3 days for minor events):

2017-11-12 19:08:02 GoogleSoftwareUpdateAgent.app Crash [Open]

Cause: *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'KSPersistentTicketStore requires a store path.'

2017-11-11 21:23:47 WindowServer High CPU use [Open] [Details]

2017-11-11 20:50:26 Microsoft Outlook.app Crash [Open]

Cause: abort() called

terminating with uncaught exception of type std::__1::system_error: mutex lock failed: Invalid argument

2017-11-11 12:35:32 Microsoft Excel.app High CPU use [Open] [Details]


Files deleted by EtreCheck:

2017-11-10 00:23:34 - ~/Library/LaunchAgents/com.amazon.cloud-player.plist - Unknown

2017-11-10 00:23:34 - ~/Library/LaunchAgents/com.vladalexa.MagicPrefs.plist - Unknown

2017-11-10 00:23:56 - /Library/LaunchAgents/com.teamviewer.teamviewer.plist - Unknown

2017-11-10 00:23:56 - /Library/LaunchAgents/com.teamviewer.teamviewer_desktop.plist - Unknown

2017-11-10 00:23:56 - /Library/LaunchDaemons/com.eset.esets_daemon.plist - Unknown

2017-11-10 00:23:56 - /Library/LaunchDaemons/com.teamviewer.teamviewer_service.plist - Unknown

Nov 12, 2017 6:34 PM

Reply Helpful
Question marked as Solved

Nov 12, 2017 6:51 PM in response to Gary Davison In response to Gary Davison

The header above each section indicates where the files are located.

System Launch Agents or Daemons are in the System Library in the respective folder.

Launch Agents and Daemons are in the "All User" Library

User Launch Agents are in the user Library.

Nov 12, 2017 6:51 PM

Reply Helpful
User profile for user: Gary Davison

Question: how do I get rid of "6H4HRTU5E3.com.avast.passwords.Agent" and "com.google.keystone.agent.plist"