Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Photoshop CC crashes on save when using High Sierra

I am using an iMac 21.5 inch 2.9 GHz Intel Core i5 processor 16 GB memory

macOS High Sierra 10.13.1

I organize my photos in iPhoto. For editing I use Photoshop CC. I have these versions installed: Photoshop CC 2015, 2015.5, and 2018.

My problem is that no matter which version of Photoshop CC I use, it crashes every time I've finished editing a photo and click save. Just clicking save causes Photoshop to crash and I'm back to square one with the original photo with no edits.

I have contacted apple support but I got lost in the instructions of creating a new user on my computer (test) and could never get back to the support person. I also tried adobe support with no luck.

Please provide a fix to this problem. I have seen many compatibility issues with Photoshop CC and High Sierra mentioned online but none of them has involved saving and crashing. I wish I had never upgraded.

Thanks for any help to solve the problem. I'm hoping to find something soon because Christmas is right around the corner and I'm wanting to work with lots of photos. As of now, I'm in a standstill.

iMac

Posted on

Reply

Page content loaded

Nov 14, 2017 7:51 AM in response to cpeptex In response to cpeptex

cpeptex wrote:

....

Please provide a fix to this problem. ....

Apple is not responsible for 3rd party app compatibility issues.

Send your dismay to Adobe for not taking the time to properly

test and update their software to be compatible.


FWIW, I had no issues with Photoshop CC 2018 and 10.13.1.

Nov 14, 2017 7:51 AM

Reply Helpful

Nov 14, 2017 8:02 AM in response to cpeptex In response to cpeptex

I'm supporting about a dozen systems on 10.13.1 and PS CC 2018 - (multiple clients saving over a server - which if there could be a potential problem this is!) and not having this happen

what device are you saving to?


you should not have all of that installed and you most defiantly should not be running more than one instance at a time. If you are running 10.13.x the only CC that should be installed is 2018


if you have not done so already create a new administrative account and use that account to test. If that works let me know


in the mean time you may post an etrecheck report for further analysis

www.etrecheck.com


as said, not apple horse, this is entirely up to adobe to sort out if it is adobe. in the mean time if you call Adobe support they will tell you - uninstall and reinstall the whole package.

Nov 14, 2017 8:02 AM

Reply Helpful

Nov 14, 2017 10:40 AM in response to cpeptex In response to cpeptex

I had exactly the same problem with CS6 (DVD version, one of the last!) after upgrading to Sierra. I found a workaround that might help but it might not suit you. So, instead of having “free-floating files” (standard setting) in the main Photoshop window they have to be “anchored” in their own tab by making sure the following preference is checked. (At this point I must apologise for the fact that I live in Germany and use CS6 in German, so the 2 enclosed screenshots show CS6 in German, but the layout should be the same in English and I´m sure the necessary checkbox will be in the same place!)


Go to Preferences, and under what´s probably called “User interface” make sure this box which I think is called “Open documents in Tabs” or similar is checked, quit and restart Photoshop.

User uploaded file

You now get each file or files opened with their own tab, like in, say, Safari!

User uploaded file

You can have as many files open at the same time as you like, and closing one or all will hopefully no longer crash Photoshop. I´ve actually found this way of working with files to be better, but that´s just my opinion, and I´m not a graphics pro! Hope this helps you out!! Otherwise I´ve found that my CS6 still works fine under High Sierra. And as JimmyCMPIT has posted you should only have one version of Photoshop installed! Cheers, Ian (sorry the screenshots are a bit small)

Nov 14, 2017 10:40 AM

Reply Helpful

Nov 14, 2017 11:39 AM in response to cpeptex In response to cpeptex

Download and run Etrecheck. Copy and paste the results into your reply. Etrecheck is a diagnostic tool that was developed by one of the most respected users here in the ASC and recommended by Apple Support to provide a snapshot of the system and help identify the more obvious culprits that can adversely affect a Mac's performance.

User uploaded file

Nov 14, 2017 11:39 AM

Reply Helpful

Nov 14, 2017 11:47 AM in response to Ian Leckie In response to Ian Leckie

Ian,

I tried your suggestion. There is in interface as you mentioned but I found the "anchoring" under "workspace".The box for "open documents as tabs" was already checked. So I went to the next box which was also checked--"Enable floating document window docking" and unchecked it. Tried editing a photo. Still got the crash on save. Then I went back and rechecked the "enable floating document window docking" to the original setting. Each time I quit Photoshop CC and restarted. I am not a graphics person either and do not know what 3/4 of the preference settings mean.

Nov 14, 2017 11:47 AM

Reply Helpful

Nov 14, 2017 11:53 AM in response to JimmyCMPIT In response to JimmyCMPIT

I have called apple support and adobe support and nothing anyone did fixed the problem. I just tried Ian's suggestion about "anchoring" documents. Still crashing. When I click save after editing the crash comes immediately. I don't even get to choose file size, quality, or where to save. Currently I am saving in a photos file on my computer hard drive.

Everything worked fine--Photoshop CC 215 and 2015.5 until I upgraded to High Sierra. No problems whatsoever until the upgrade. Right now I'm thinking about trying to restore my former operating system from time machine.

Nov 14, 2017 11:53 AM

Reply Helpful

Nov 14, 2017 11:56 AM in response to cpeptex In response to cpeptex

Close out of PS, then go to the dock, right click PS and go to Show in FinderUser uploaded file



Select (but don't open) the actual Photoshop icon in the window that just opened (e.g. not the shortcut anywhere else on the computer) and hold down SHIFT+CTRL+ALT+CMD and THEN click to open the App. When prompted to delete the prefs file, this will create a new "default" one, except when I do this I now get prompted to reinstall the App - ok, seriously; someone at Adobe need a good swift kick in the pants.

If this works for you however its a good starting point to remove any possible corruption in that file which can get corrupted from time to time and cause grief.

Nov 14, 2017 11:56 AM

Reply Helpful

Nov 14, 2017 12:11 PM in response to Old Toad In response to Old Toad

EtreCheck version: 3.4.6 (460)

Report generated 2017-11-14 14:00:10

Download EtreCheck from https://etrecheck.com

Runtime: 2:26

Performance: Excellent


Click the [Lookup] links for more information from Apple Support Communities.

Click the [Details] links for more information about that line.

Click the [Remove/Report] links to remove adware or update the whitelist of legitimate software.


Problem: Apps are crashing

Description:

Photoshop CC 2015 and 2018 crash on save when using High Sierra 10.13.1


Hardware Information:

iMac (21.5-inch, Late 2013)

[Technical Specifications] - [User Guide] - [Warranty & Service]

iMac - model: iMac14,3

1 2.9 GHz Intel Core i5 (i5-4570S) CPU: 4-core

16 GB RAM Upgradeable - [Instructions]

BANK 0/DIMM0

8 GB DDR3 1600 MHz ok

BANK 1/DIMM0

8 GB DDR3 1600 MHz ok

Handoff/Airdrop2: supported

Wireless: en1: 802.11 a/b/g/n/ac

Proxy: ProxyAutoConfig

Proxy: ProxyAutoDiscovery

iCloud Quota: 424 MB available


Video Information:

NVIDIA GeForce GT 750M - VRAM: 1 GB

iMac 1920 x 1080


Disk Information:

APPLE SSD SD0128F disk0: (121.33 GB) (Solid State - TRIM: Yes)

[Show SMART report]

EFI (disk0s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

(disk0s2) <not mounted> [CoreStorage Container]: 120.99 GB

(disk0s3) <not mounted> [Boot]: 134 MB


APPLE HDD HTS541010A9E662 disk1: (1 TB) (Rotational)

[Show SMART report]

EFI (disk1s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

(disk1s2) <not mounted> [CoreStorage Container]: 999.35 GB

Recovery HD (disk1s3 - HFS+) <not mounted> [Recovery]: 650 MB


USB Information:

USB30Bus

Seagate Backup+ Desk

Backup+ Desk disk3: (5 TB)

(disk3s1) <not mounted> [EFI]: 315 MB

Seagate Backup Plus (disk3s2 - Journaled HFS+) /Volumes/Seagate Backup Plus : 5.00 TB (2.88 TB free)

Apple Inc. BRCM20702 Hub

Apple Inc. Bluetooth USB Host Controller

Apple Inc. FaceTime HD Camera (Built-in)

X-Rite, Inc. ColorMunki Display

Mitsumi Electric Apple Optical USB Mouse


Firewire Information:

G-TECH OEM ATA Device 00 800mbit - 800mbit max

EFI (disk4s1 - MS-DOS FAT32) <not mounted> [EFI]: 210 MB

External HD (disk4s2 - Journaled HFS+) /Volumes/External HD : 2.00 TB (42 MB free)


Thunderbolt Information:

Apple Inc. thunderbolt_bus

Apple Inc. Thunderbolt to FireWire Adapter


Virtual disks:

Macintosh HD (disk2 - Journaled HFS+) / [Startup]: 1.11 TB (708.89 GB free)

Physical disk: disk0s2 120.99 GB Online

Physical disk: disk1s2 999.35 GB Online


System Software:

macOS High Sierra 10.13.1 (17B48) - Time since boot: about 9 hours


Gatekeeper:

Mac App Store and identified developers


Possible adware:

Adware: ~/Library/Caches/com.apple.Safari/Extensions/Amazon Shopping Assistant.safariextension

Adware: ~/Library/Caches/com.apple.Safari/Extensions/Slick Savings.safariextension

Adware: ~/Library/Safari/Extensions/Slick Savings.safariextz

3 possible adware files found. [Remove/Report]


Kernel Extensions:

/Library/Application Support/WDSmartWare

[not loaded] com.wdc.driver.1394HP (1.0.7) [Lookup]

[not loaded] com.wdc.driver.USBHP (1.0.5) [Lookup]


/Library/Extensions

[loaded] com.paragon-software.filesystems.ntfs (14.2.288 - SDK 10.5) [Lookup]

[loaded] com.seagate.driver.PowSecDriverCore (5.2.7 (26995) - SDK 10.4) [Lookup]


/Library/Extensions/Seagate Storage Driver.kext/Contents/PlugIns

[not loaded] com.seagate.driver.PowSecLeafDriver_10_4 (5.2.7 (26995) - SDK 10.4) [Lookup]

[loaded] com.seagate.driver.PowSecLeafDriver_10_5 (5.2.7 (26995) - SDK 10.5) [Lookup]

[not loaded] com.seagate.driver.SeagateDriveIcons (5.2.7 (26995) - SDK 10.4) [Lookup]


Startup Items:

ProTec6b: Path: /Library/StartupItems/ProTec6b

Startup items no longer function in OS X Yosemite or later


System Launch Agents:

[not loaded] 8 Apple tasks

[loaded] 170 Apple tasks

[running] 110 Apple tasks


System Launch Daemons:

[not loaded] 35 Apple tasks

[loaded] 178 Apple tasks

[running] 117 Apple tasks


Launch Agents:

[not loaded] com.adobe.AAM.Updater-1.0.plist (Adobe Systems, Inc. - installed 2017-04-12) [Lookup]

[running] com.adobe.AdobeCreativeCloud.plist (Adobe Systems, Inc. - installed 2017-11-09) [Lookup]

[loaded] com.adobe.CS4ServiceManager.plist (? 70f708f7 8f8a5aa2 - installed 2012-07-23) [Lookup]

[loaded] com.google.keystone.agent.plist (Google, Inc. - installed 2017-09-27) [Lookup]

[loaded] com.oracle.java.Java-Updater.plist (? d1d2deb4 72ac4dde - installed 2017-10-06) [Lookup]

[running] com.paragon-software.NTFS.fsnotify.agent.plist (? dcda45f4 848b1897 - installed 2017-05-04) [Lookup]

[loaded] com.paragon-software.facebook.agent.plist (? 95fb0bd4 e9648c48 - installed 2017-05-04) [Lookup]


Launch Daemons:

[loaded] com.adobe.acc.installer.plist (Adobe Systems, Inc. - installed 2017-11-09) [Lookup]

[running] com.adobe.agsservice.plist (Adobe Systems, Inc. - installed 2017-09-27) [Lookup]

[loaded] com.adobe.fpsaud.plist (? 2afb3af7 defea098 - installed 2017-10-25) [Lookup]

[not loaded] com.apple.installer.cleanupinstaller.plist (? 1963bf56 0 - installed 2017-10-05)

[loaded] com.bombich.ccchelper.plist (Bombich Software, Inc. - installed 2015-10-06) [Lookup]

[loaded] com.google.keystone.daemon.plist (Google, Inc. - installed 2017-10-12) [Lookup]

[loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2017-10-10) [Lookup]

[loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e 7ca9944 - installed 2015-06-04) [Lookup]

[loaded] com.microsoft.office.licensingV2.helper.plist (Microsoft Corporation - installed 2016-11-15) [Lookup]

[loaded] com.oracle.java.Helper-Tool.plist (Shell Script e3fefdd2 - installed 2017-07-22) [Lookup]

[running] com.paragon-software.NTFS.fsnotify.daemon.plist (? 66744841 b1cb5590 - installed 2016-08-29) [Lookup]

[loaded] com.paragon.NTFS.launch.plist (Apple, Inc. - installed 2017-10-25)

[running] com.seagate.TBDecorator.plist (? 595582c 212092b1 - installed 2015-11-02) [Lookup]

[running] com.xrite.device.xrdd.plist (? 247330c8 20eab0ec - installed 2014-02-20) [Lookup]


User Launch Agents:

[loaded] com.adobe.AAM.Updater-1.0.plist (Adobe Systems, Inc. - installed 2017-01-18) [Lookup]

[loaded] com.apple.SafariBookmarksSyncer.plist (? ? ? - installed 2009-02-09)

[loaded] com.dropbox.DropboxMacUpdate.agent.plist (Dropbox, Inc. - installed 2017-08-10) [Lookup]

[running] com.microsoft.LaunchAgent.SyncServicesAgent.plist (? 5fe0fad6 844ec710 - installed 2017-11-14) [Lookup]

[running] com.seagate.dashboard.plist (Seagate Technologies LLC - installed 2017-11-01) [Lookup]


Internet Plug-ins:

Flip4Mac WMV Plugin: 2.3.4.1 (installed 2010-06-15) [Lookup]

FlashPlayer-10.6: 27.0.0.187 (installed 2017-11-14) [Lookup]

QuickTime Plugin: 7.7.3 (installed 2017-10-03)

Flash Player: 27.0.0.187 (installed 2017-11-14) [Lookup]

AdobeAAMDetect: 3.0.0.0 (installed 2017-11-09) [Lookup]

JavaAppletPlugin: Java 8 Update 144 build 01 (installed 2017-10-06) Check version

OfficeLiveBrowserPlugin: 12.3.6 (installed 2014-11-21) [Lookup]

Google Earth Web Plug-in: 7.1 (installed 2015-06-09) [Lookup]

SharePointBrowserPlugin: 14.7.7 (installed 2017-10-10) [Lookup]

Silverlight: 5.1.30514.0 (installed 2014-09-08) [Lookup]

iPhotoPhotocast: 7.0 (installed 2010-04-16)


User internet Plug-ins:

Picasa: 1.0 (installed 2009-01-06) [Lookup]


Safari Extensions:

[enabled] AdBlock - BetaFish, Inc. - https://getadblock.com (installed 2017-08-06)

[disabled] Slick Savings - Spigot, Inc. (installed 2014-05-09) Adware! [Remove/Report]

[disabled] Twitter for Safari - Twitter, Inc. - http://twitter.com (installed 2011-11-12)

[not loaded] Amazon Shopping Assistant - Spigot, Inc. - http://www.spigot.com/ (cache only) (installed 2017-10-05) Adware! [Remove/Report]


3rd Party Preference Panes:

Flash Player (installed 2017-10-25) [Lookup]

Flip4Mac WMV (installed 2010-06-15) [Lookup]

Java (installed 2017-10-06) [Lookup]

Paragon NTFS for Mac® (installed 2017-05-04) [Lookup]

Seagate Dashboard for Mac OSX (installed 2017-11-01) [Lookup]


Time Machine:

Skip System Files: NO

Mobile backups: OFF

Auto backup: YES

Volumes being backed up:

External HD: Disk size: 2.00 TB Disk used: 2.00 TB

Macintosh HD: Disk size: 1.11 TB Disk used: 402.93 GB

Destinations:

Seagate Backup Plus [Local]

Total size: 5.00 TB

Total number of backups: 70

Oldest backup: 3/31/17, 11:17 AM

Last backup: 11/14/17, 1:30 PM

Size of backup disk: Too small

Backup size 5.00 TB < (Disk used 2.40 TB X 3)


Top Processes by CPU:

7% mdworker

6% mdworker

5% WindowServer

4% kernel_task

3% Microsoft Outlook


Top Processes by Memory:

1.19 GB kernel_task

733 MB Finder

645 MB softwareupdated

545 MB Safari

507 MB Microsoft Outlook


Top Processes by Network Use:

Input Output Process name

760 KB 246 KB mDNSResponder

36 KB 9 KB netbiosd

5 KB 6 KB apsd

7 KB 2 KB cloudd

6 KB 2 KB com.apple.WebKit.Networking


Top Processes by Energy Use:

6.68 WindowServer

1.12 launchd

0.78 Adobe CEF Helper

0.44 Creative Cloud


Virtual Memory Information:

7.93 GB Available RAM

1.79 GB Free RAM

8.07 GB Used RAM

6.15 GB Cached files

0 B Swap Used


Software installs (last 30 days):

Adobe Flash Player: (installed 2017-10-16)

Adobe Flash Player: (installed 2017-10-25)

Seagate Dashboard: (installed 2017-11-01)

Adobe Flash Player: (installed 2017-11-14)


Install information may not be complete.


Diagnostics Events (last 3 days for minor events):

2017-11-13 17:28:51 Finder.app Crash [Open]

2017-11-13 14:41:49 bomgar-scc-20171113-144103.app Crash [Open]

2017-11-12 10:14:39 Microsoft Outlook.app High CPU use [Open] [Details]

Nov 14, 2017 12:11 PM

Reply Helpful

Nov 14, 2017 12:21 PM in response to cpeptex In response to cpeptex

I'm going to guess you are trying to save to an NTFS drive and the software you used to make that "Windows Next Tech File System" volume accessible to your mac fried with 10.13 was installed


you also do not need and should not use the drive's built in software package.


If you do not need to use this drive with a Windows computer then copy the files to another drive, format that NTFS one to Mac Extended and use it for Mac with full benefits.


I could be wrong but from what's installed and what you are saying is happening that's where I would start guessing this went down.


if you select the drive, then right click and go to GET INFO you can see the format

User uploaded file

if you see Format:NTFS (or less possible ExFAT or FAT32)

then that is very likely the crash


in the mean time run malwarebytes for mac and clean out the malware

malwarebytes.com

Nov 14, 2017 12:21 PM

Reply Helpful

Nov 14, 2017 12:18 PM in response to cpeptex In response to cpeptex

You have a number of adware installed. Rerun Etrecheck and click on the [Remove/Report] link wherever you find them in the report.


Don't know if they contributed to Photoshop crashing but they are not good for the system. If the crashing stops after removing them we'll know they were part of the problem.


Also it appears that ProTec6b is not compatible with your system. Uninstall it or upgrade to a version that is compatible.

Nov 14, 2017 12:18 PM

Reply Helpful

Nov 14, 2017 2:14 PM in response to Old Toad In response to Old Toad

Old Toad,

Thanks for all your help! I have clicked on the remove/report and completed that task. Have no idea what the ProTec6b is and I will uninstall or upgrade when I find out.


I have just discovered the problem with the crashing!!!!! It was the NIK collection plug ins for Photoshop! I went online to look for fixes, etc. and discovered that if I go into each plug in of the collection to "settings" then to "after clicking OK" then choose "apply the filtered effect to the current layer" that the problem is solved. I have done this with each of the plug ins (Analogue, Color Effex Pro, Define, Silver Efex pro, Sharpener Pro, Viveza, etc.) and so far I have been able to save all the test edited photos. I cannot tell you and the others on this thread how much I appreciate your effort to help me. It appears that there are other items I need to address that were a result of the Entre check that I would never have known about. 🙂

Nov 14, 2017 2:14 PM

Reply Helpful
User profile for user: cpeptex

Question: Photoshop CC crashes on save when using High Sierra