Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: updating the operating system

I've downloaded an app and it requires version 11 of iOS. My iPad is at 9.5 and it says it is current. Does that mean it's too old to support anything higher?

Posted on

Reply

Page content loaded

User profile for user: kenw100

Question: updating the operating system