Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Cannot invite family members to HomeKit

Hi all,



Since yesterday I have a problem with our HomeKit system. My wife and son cannot use the HomeKit from the Home app on their iPhones anymore.



We are using my ipad as the HomeKit hub. In their Home app they got a message that they are not connected to the HomeKit system.



I tried everything without success, and therefore finally I removed my house and started from scratch.



Now however a have a new problem. Activation goes OK and I can add all accessories without problems.



When I however try to invite my wife and son in the Home app, I get a message that their AppleID is not registered at iCloud. Very strange because their iPhones are logged to iCloud and work without problems. I tried to login to iCloud using their credentials - also no problem.



Do you maybe have (or had) similar problems and know how to solve it?



Thanks in advance for your help!



Greetings,



Irek

iPhone 8, iOS 11.2

Posted on

Reply

Dec 10, 2017 11:47 PM in response to irekfromrotterdam In response to irekfromrotterdam

From what I've read elsewhere. In the new OS11.2 update, Apple discovered a security issue. So they "turned off" access for anyone you "invite" to your "homekit" home. They are supposed to release another update with the fix in the next week or so.

It's frustrating. I have a email address for my home and have HomeKit setup using that and a apple tv 4 as the hub. Then I add people and authorize them to have access. But it's really only myself and my wife. Now we can't use the homekit app. I like it because it's faster than waiting to open any other app to access the various devices like Lutron, ecobee, iDevices, August and Onelink. HomeKit is like a One Stop Shop for all our devices and the various apps.

Dec 10, 2017 11:47 PM

Reply Helpful (3)

Dec 11, 2017 10:37 AM in response to irekfromrotterdam In response to irekfromrotterdam

I have the same issue. Spent an hour with Apple Support yesterday - unresolved and escalated to engineering. I am rethinking my dedication to HomeKit - this is being swept under the rug - but it is a major issue when folks lose the ability to control their home devices!

Dec 11, 2017 10:37 AM

Reply Helpful (2)

Dec 12, 2017 11:27 AM in response to macscamper In response to macscamper

Yeah, this is a huge problem. I just purchased my first Homekit accessories and I was trying to invite my partner for an hour, and looking up information about it. This is completely frustrating, I got into Homekit so all the people in my house could use it and control from their phones or remotely if needed, but I am the only one after investing 100's of dollars into it! It would be nice if Apple would give you a notification at least stating there is a security issue, but instead I get that the emails I'm putting in are not associated with an Apple ID, which isn't true.


Apple! What is happening to you?! Nothing just works anymore...

Dec 12, 2017 11:27 AM

Reply Helpful (3)

Dec 13, 2017 3:31 PM in response to FF-Joe In response to FF-Joe

I’m curious what this means for user who are still using an iDevice that’s not upgradable to iOS 11.

I have an iPhone 5 and iPad 4 that I was originally started with using it a different iCloud account setup for the house.

I have family sharing setup with that account being shared with wife and I.

I also granted the wife and I access from the houses iCloud account for the HomeKit. Till recently.

Since this security issue came up with the iOS 11.2 update, I re did my HomeKit setup on my iCloud account now. And today the iOS 11.2.1 came out.

So I have installed the new update on my iPhone 6s and Apple TV 4. I’m now eagerly waiting to be able to try and add another user. But once Apple flips that switch back on, how will it affect iDevices that are stuck in iOS 10 world?

Dec 13, 2017 3:31 PM

Reply Helpful (1)

Dec 14, 2017 4:10 PM in response to irekfromrotterdam In response to irekfromrotterdam

I tried to add my family members and friends to share my Home app accessories, but the I get the message “Invitation failed ...Apple ID is not registered with iCloud”. I have verified that I am indeed using their iCloud emails. So far I have tried removing and re-adding all homesharing members, deleting and reinstalling the home app, logging out of and deleting all my other smart home apps, resetting all HomeKit accessories, repeating with wife’s phone, using her phone to invite me to a whole new home account and disabling two factor Authentication. Interestingly, I was able to send an invite to her actual @iCloud.com email account to homesharing although nothing at all is associated with that email (ie it is not used for her Apple ID account and she doesn’t even use it for email but it does exist )

Dec 14, 2017 4:10 PM

Reply Helpful

Dec 15, 2017 1:36 AM in response to macscamper In response to macscamper

I'm still having the issue. So it appears to be a bit hit and miss whether it works or not.


I've updated both phones and the Apple TV. I've not updated the iPads though. I wonder if all of a user's devices need to be on 11.2.1 before the invite will work. It would be good to have some guidance from Apple. Say in the release notes for the update for example.

Dec 15, 2017 1:36 AM

Reply Helpful

Dec 15, 2017 2:04 AM in response to Michael Sheppard In response to Michael Sheppard

After chatting with Apple I signed my iPhone out from iCloud and back in. I am the owner of the Home.


Once I'd done this, and force quit the Home App, I was able to invite from the Home App again.

Dec 15, 2017 2:04 AM

Reply Helpful
User profile for user: irekfromrotterdam

Question: Cannot invite family members to HomeKit