Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iPhone 6S - GPS + Cellular Doesn't work together

Since iOS 11.2.4, my phone doesn't work with GPS like it used to.


So starting an app like Strava, Waze, Apple Maps works to locate me. As soon as I start using GPS exclusively (start a navigation route, start recording a bike ride), about 20 seconds later, GPS stops working, the phone can no longer locate my location, and the cellular no longer has service "no service".


When this occurs, if I enable airplane mode, and turn it off. The phone immediately has 4 bars of service, navigation starts back up for about 20 seconds before the same thing happens again. This is consistent and happens any time GPS is used with cellular data. On Wifi, it works fine.


I have tried reseting, hard reset, and even a factory reset.


I need suggestions please.

iPhone 6s, iOS 11.2.6

Posted on

Reply

Feb 28, 2018 7:58 AM in response to rallyrabbit In response to rallyrabbit

Hi there, rallyrabbit!
Thanks for reaching out to the Apple Support Communities! It sounds like you are having an issue using GPS while on cellular data and I am happy to help! You have tried excellent steps so far and based on what you are describing happening, I would recommend taking a look at this article to Get help with Maps and this article About privacy and Location Services in iOS 8 and later. The first article will give you additional steps to try and the second will advise you how to reset your Location Services to see if those steps help.
Since you are seeing “No Service” when the issue occurs, it might be a good idea to also check out this article with steps to follow If you see No Service or Searching on your iPhone or iPad.
Let me know the results and have a great day!

Feb 28, 2018 7:58 AM

Reply Helpful

Feb 28, 2018 10:37 AM in response to jameson.h In response to jameson.h

Sir, thank you for the reply.


Location is NC, USA in an urban area with no obstructions.


So, I reset network settings and locations settings. I unseated and reseated the SIM card. Followed all the directions in the links. I tried turning LTE off and enabling LTE.


Using Strava, Waze and Maps. I re-enabled access to location. In these cases, it looks like GPS works. 5 minutes in, cell service drops, GPS stops and will not come back. If I go airplane mode on, 20 seconds, then off, it starts working again. if I kill the GPS using apps, cell service comes back.


I tried another option. I downloaded offline maps. I turned airplane mode on and left location services in. In this case, GPS is never found. It is my understand that GPS should still be found in this scenario.


In my opinion, there seems to be a problem with location services. It seems like it is determining location solely off cellular tower information and not of GPS as a whole.

Feb 28, 2018 10:37 AM

Reply Helpful (1)
User profile for user: rallyrabbit

Question: iPhone 6S - GPS + Cellular Doesn't work together