Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Adding tracks on iMac is also downloading them.

Recently the + within All Apple Music has begun behaving differently in iTunes on my iMac. While it previously added the track to my Apple Music Library without physically downloading it (that required a second click on the cloud) it is now skipping right to the download. Three dots and 'add to library' is doing the same thing. In order to add a track to my Apple Music Library without downloading it I have to add it and then go back into the track within my library and remove the download.

iMac, macOS High Sierra (10.13.1)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hi there, Forcefour.


It appears that, iTunes on your iMac, isn't working as expected. When you add a song from Apple Music, it automatically downloads it. Good job in figuring out how to remove it, and I'm happy to help.

Please check to see if you have automatic downloads turned on.
Turn on Automatic Downloads for iTunes Store, App Store, and iBooks Store purchases

iTunes

1. Open iTunes. If you haven't authorized your computer, choose Store > Authorize This Computer from the menu bar at the top of your computer screen.
2. Mac: From the menu bar at the top of your computer screen, choose iTunes > Preferences.
Windows: From the menu bar at the top of the iTunes window, choose Edit > Preferences.
3. Click the Downloads tab, then select the content that you want to automatically download.
User uploaded file
4. Click OK.

If Music is checked, uncheck it, click OK and then try to add another song to your library.

Let me know how that goes.


Take care!

Posted on

Page content loaded

Question marked as Solved

Mar 21, 2018 10:47 AM in response to Forcefour In response to Forcefour

Hi there, Forcefour.


It appears that, iTunes on your iMac, isn't working as expected. When you add a song from Apple Music, it automatically downloads it. Good job in figuring out how to remove it, and I'm happy to help.

Please check to see if you have automatic downloads turned on.
Turn on Automatic Downloads for iTunes Store, App Store, and iBooks Store purchases

iTunes

1. Open iTunes. If you haven't authorized your computer, choose Store > Authorize This Computer from the menu bar at the top of your computer screen.
2. Mac: From the menu bar at the top of your computer screen, choose iTunes > Preferences.
Windows: From the menu bar at the top of the iTunes window, choose Edit > Preferences.
3. Click the Downloads tab, then select the content that you want to automatically download.
User uploaded file
4. Click OK.

If Music is checked, uncheck it, click OK and then try to add another song to your library.

Let me know how that goes.


Take care!

Mar 21, 2018 10:47 AM

Reply Helpful (1)
User profile for user: Forcefour

Question: Adding tracks on iMac is also downloading them.