Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: date and time formatting in numbers won't work

I want to format a cell so that when I choose "insert Date and Time" it is formatted as "12 mar 2018".

I select the cell, choose "date and time" in the format sidebar, select the appropriate date format, but if I then fill the cell with Date & Time from the Insert menu, it is not formatted. I use the latest version (4.3.1) of Numbers on MacOS High Sierra. What did I do wrong or forget?


thanks

Wim

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Hi Wim,


You did nothing wrong, and you didn't forget anything.


The Insert > Date and Time menu item inserts a Date and Time value and a specific format.

A click on the cell immediately after inserting brings up a menu of format choices, whih may include the one you want. If it doesn't, you'll need to open the format inspector > Cell and choose the D&T format you want there.


Requests to Apple to change this behaviour may be sent via the feedback channel.

In Numbers, go to the Numbers menu, choose Provide Numbers Feedback, then make a Feature enhancement request.


Regards,

Barry

Posted on

Page content loaded

Question marked as Solved

Mar 11, 2018 4:31 PM in response to wimverbe In response to wimverbe

Hi Wim,


You did nothing wrong, and you didn't forget anything.


The Insert > Date and Time menu item inserts a Date and Time value and a specific format.

A click on the cell immediately after inserting brings up a menu of format choices, whih may include the one you want. If it doesn't, you'll need to open the format inspector > Cell and choose the D&T format you want there.


Requests to Apple to change this behaviour may be sent via the feedback channel.

In Numbers, go to the Numbers menu, choose Provide Numbers Feedback, then make a Feature enhancement request.


Regards,

Barry

Mar 11, 2018 4:31 PM

Reply Helpful

Mar 12, 2018 7:50 AM in response to Barry In response to Barry

Hi Barry,

thanks for your reply! it looks like I will have to live with it. It used to be the way I liked, but I installed the latest version yesterday and I am kind of disorientated now, there are more things which Apple changed and making invoices now isn't as user friendly as it used to be. (e.g. cmd D for duplicating a sheet, the need to double click a field for editing, etc)

Also I can't seem to disable the autocorrect in cells with pop-up menu for which I want to insert a list (jan is corrected to January and I find no way to disable that). I will try to install the old version again, this is troublesome...


thanks again!

wim

Mar 12, 2018 7:50 AM

Reply Helpful

Mar 12, 2018 6:09 PM in response to wimverbe In response to wimverbe

Hi wim,


Don't give up yet, after just one day! You'll get used to things. In general I find the new versions bring improvements (along with the occasional disappointment).


If you don't like the way Numbers keeps suggesting values as you type in a column, you can easily turn that off. Go to Numbers > Preferences > General and uncheck 'Show suggestions when editing table cells'.


User uploaded file


SG

Mar 12, 2018 6:09 PM

Reply Helpful

Mar 12, 2018 6:18 PM in response to wimverbe In response to wimverbe

"Also I can't seem to disable the autocorrect in cells with pop-up menu for which I want to insert a list (jan is corrected to January and I find no way to disable that)"


Can you clarify "in cells with pop-up menu for which I want to insert a list"?


Is "jan" an item in the pop-up menu?

What "list" ar you trying to "insert"?

Where are you trying to "insert" the list?


Regards,

Barry

Mar 12, 2018 6:18 PM

Reply Helpful
User profile for user: wimverbe

Question: date and time formatting in numbers won't work