Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: 10.13.3 - RAID Can Read but Ejects when Trying to Write

Hi All

So I'm in a bit of a conundrum...I have a brand new iMac Pro (whoohoo!) that I can't use ($%@%) because of a real head scratching RAID issue.


I have a 12TB ProAvio RAID enclosure set to RAID 0. 10TB out of 12TB used. USB 2 connection and FW 800. All current firmware and updates.


Works flawlessly and has for 2+yrs on my Mac Pro 10.12.4.


Now, on the iMac Pro 10.13.3 it works...but not really. I can read all day from it no matter what connection, USB-USB, FW800/TB2adapter/USBCadapter or USB/USBC adapter....BUT....Trying to write USB-USB ejects the RAID and I have to power cycle the array...Here's what I have found broken down by connection.


USB-USB

Here's the worst part. I really need the speed of USB2. On my MacPro I was USB-USB and getting a read/write speed of 240MB/Sec. On the iMacPro, as I said above, I can read as much as I want, try to write and it knocks the RAID offline. I have a BlackMagicDesign disc speed test and when I run it with the USB-USB connection, I get 250MB/sec for maybe 2 seconds then it knocks the RAID offline. If I try to write any file to the RAID...it gets knocked offline and I have to power cycle to get it to connect again.


USB-USBC adapter

This connection works. With a small USB/USB-C adapter I can read and write. BUT when I run a speed test I get maybe 30MB/s. Far below what it should be getting and in video editing...there's no way this will work.

Firewire800-TB2-USB-C Adapter

This connection works as well. Granted it's through two adapters to step up from FW800. BUT according to speed test I'm in the 30-40MB/s range again.


I'm seriously confused as to why it's not working at all to "kinda" working in other situations...and the fact that it even starts by saying it's 250MB/s before getting knocked offline with the standard USB connection.


Apple has told me they don't support it...but the fact that it works fine on my Mac Pro and not with my new $8000 iMac, leads me to believe it has to be something with the change from Sierra to High Sierra.


Does anyone have any suggestions or ideas? Thanks so much!!



**note - I DO have the "put hard drives to sleep" etc etc turned off.

iMac Pro, macOS High Sierra (10.13.3)

Posted on

Reply

Page content loaded

Mar 14, 2018 9:16 AM in response to jeremy@CoH In response to jeremy@CoH

And as a quick follow up....


All of my external drives are underperforming when compared to what they were testing at on my Mac Pro.


My drives that were reading 80/90MB/s are down in the 40's and my thunderbolt drives (granted through an official Apple adapter) are down from 220MB/s to 180 or so.


This is seriously frustrating and has forced me to move back to my Mac Pro. As a Pro video editor this is absolutely unacceptable.

Mar 14, 2018 9:16 AM

Reply Helpful

Mar 14, 2018 1:34 PM in response to majortom1967 In response to majortom1967

What's interesting is ...well a couple things. I got it to finally read/write at 220+MB/s with a "apple approved" USB to USB-C adapter. Switched back to USB...and it ejected it. So something points me to a real problem with Apple's USB and 10.13.3. Maybe because it's a hardware RAID...I dunno


And not fueling conspiracy theories, after Apple tech support dropping me yesterday while on hold after talking with them for over an hour, I called back today to follow up. I spoke with the rep about my case # from yesterday and that I got "disconnected" We discussed my issue again and she then said I would have to follow up with my Case # owner who was "Steve" and here is his direct line... I called that direct line and got a "no longer valid" msg.


I feel like I may have touched a nerve and got banished to the "dead letters" office

Mar 14, 2018 1:34 PM

Reply Helpful

Mar 14, 2018 1:46 PM in response to jeremy@CoH In response to jeremy@CoH

I believe, since 1998, that Apple's USB drivers are the worst on the market. But doesn' t mean the problem is there. I have slow performance since High Sierra (on USB 3 - USB 3).

IMHO Apple should adopt a different way of releasing Mac OS: not every year as a commercial matter. People work with it. It must be reliable and stable. Stop with major and minor releases. A "kaizen" method (continuous small improvements) shoul be adopdet or at least a tic-toc Intel's-style on processors as was made with Leopard and Snow Leopard. Therefore a major release (for "pioneer" users) followed by an only-refinement release (for mass users)

Mar 14, 2018 1:46 PM

Reply Helpful (1)
User profile for user: jeremy@CoH

Question: 10.13.3 - RAID Can Read but Ejects when Trying to Write