Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Mac Model not Showing in Devices

Hi. I recently purchased a new Macbook Pro 2017. Under iCloud settings, its model is showing to be only "Mac". However, my previous devices are showing complete models such as "Macbook Pro 13'" and "iMac 21.5' 4K". Why is that?


User uploaded file


User uploaded file


User uploaded file

Posted on

Reply

Page content loaded

Mar 14, 2018 4:54 PM in response to kashif789us In response to kashif789us

Hi,


I think I have exactly same problem, my "About This Mac" says MacBook Pro (15-inch, 2017), my model identifier is MacBookPro14,3.


The only place I get the information correct is in iCloud Web-Cleint Settings, everywhere else, like System Preferences - iCloud and on my Apple ID web page I have exactly what you are saying, just only "Mac" with no exact model identification and device icon is also wrong, it shows logo of macOS Sierra 10.12 not the proper device picture.


I'm also trying to find an answer to this, if I get it eventually I'll post here. Bye.


There is one quite stupid idea, that maybe device is so new, that it's not yet recognized by iCloud Device feature properly. Because for me also, all my older models are ok.

Mar 14, 2018 4:54 PM

Reply Helpful

Mar 15, 2018 2:33 AM in response to kashif789us In response to kashif789us

Is your Mac 'Standard' or CTO (Custom Configuration)? I have seen more times people having this problem with CTOs. But looks like there's nothing you can do about it, it's Apple's turn to solve this issue. (You can rise bug report, I'm doing the same.)

Mar 15, 2018 2:33 AM

Reply Helpful
User profile for user: kashif789us

Question: Mac Model not Showing in Devices