Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: iMessage Account inactive

Hi! I recently got a brand new MacBook Air and am having troubles getting my iMessages to connect with my phone. When in input my Apple ID, an error message pops up and says that my account is inactive. I have tried several things and nothing seems to work. Any suggestions?

MacBook Air, iOS 10.3.3

Posted on

Reply

Mar 14, 2018 1:47 PM in response to anniefromhartsville In response to anniefromhartsville

Hi,


Lets check that both devices are in order first.


On the Mac in Messages > Preferences > Accounts and the iMessages account you should have entered your iCloud valid Apple ID.

That is to say it can be different to the one in iTunes or System Preferences > iCloud.

For most people it is the same, it's just that it can be a different ID.


That ID should then register and show in the Receive At list.

You might need to make sure the "Enable This Account" box is ticked.


On the iPhone the Messages app needs to slid to Green.

It will report "Verifying" until the iPhone Number is registered.


At this point each device can send from the ID is use on that device.


Testing

On the Mac version start a New Message and enter the iPhone Number with County Code on the "To" Spot.

Don't rely on the Contacts App to show you your My Card by typing in your name as you as not expected to call yourself.

Send an iMessage.


If the iPhone gets it then both are logged in to the iMessages server.

If you don't get the message on the iPhone report back what you do get.

Screen grabs are good (CMD + Shift + 4 to draw round a rectangle). These can be dragged into the reply box.


If it does work then the Apple ID can be added to the iPhone in Settings > Messages > Send and Receive.

This should cause a pop up on the mac saying that the iPhone is using both Apple ID and iPhone Number

Accepting it puts it in the Receive At list with an active tick on the Mac.


That should be enough to get you going.

There are more steps to get SMS/Text Forwarding working.





User uploaded file

8:47 pm Wednesday; March 14, 2018


 iMac 2.5Ghz i5 2011 (Sierra)
 G4/1GhzDual MDD (Leopard 10.5.8)
 MacBookPro 2Gb (Snow Leopard 10.6.8)
 Mac OS X (10.6.8),
 iPhone 6 iOS 11.x and an iPad (2)

Mar 14, 2018 1:47 PM

Reply Helpful
User profile for user: anniefromhartsville

Question: iMessage Account inactive