Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Fitness Track Issues

My iWatch Series 2 has stopped accurately tracking laps I swim in the pool. I've tried "unpair and repair" but it's still not accurate. Especially when I swim backstroke, it counts more laps than I actually swim. Any solution?

Apple Watch Series 2, iOS 10.2, null

Posted on

Reply

Page content loaded

Apr 28, 2018 2:26 AM in response to bethbuch In response to bethbuch

I have the exact same issue. Well, at least only with backstroke. The only others I do are breaststroke and freestyle and those seem spot on. But backstroke is WAY off adding on additional laps and meters. I don't think this is about calibration (which you can reset) because everything else is fine. I am not sure but I would be curious to hear if anyone out there has success with backstroke on an Apple Watch. It can add on as much as 5 to 10 laps with only one backstroke lap. The pool is set to 25m and I have tried this with open pool swim as well as with a distance goal set; both with the same results. This is consistently inaccurate too. Never has a backstroke added up right with about 6 different workouts.


By the way, I am on a cellular active series 3 at version 4.2. I only started swimming recently so I never saw if this was accurate before or not.

Apr 28, 2018 2:26 AM

Reply Helpful
User profile for user: bethbuch

Question: Fitness Track Issues