Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Trouble connecting to wifi

Hi,


I'm having trouble connecting to wifi on my:


MacBook Pro (17-inch, Mid 2010)

macOS Sierra

version 10.12.6

Processor 2.53 HGz Intel Core i5

Memory 4GB 1067 MHz DDR3


A message "The wifi network requires a WPA2 password" appears after I've entered the password along with the message "invalid password"

All my other devices are connecting to the wifi with no problem.

Any help much appreciated.


Highstreetken

MacBook Pro, Version 10.12.6

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

Thanks Eric,


After running wireless diagnostics I followed advice to turn off router then on again. This combined with moving my mac closer to the router as i connected did the trick. Thank you for your advice, it's much appreciated.

Posted on

Page content loaded

Mar 15, 2018 9:34 AM in response to Highstreetken In response to Highstreetken

What does Wireless Diagnostics show?


Wireless Diagnostics


Wi-FI connection drops


Wi-Fi Problems in OS X Yosemite


Wi-Fi Problems in OS X Yosemite (2)


Wi-Fi Problems in OS X Yosemite (3)


WiFi Potential Temporary fix - Yosemite


Also try turning off Bluetooth.


If your Wi-Fi source is capable of generating a 5 GHz Wi-Fi network, try that to help avoid conflicts with Bluetooth.

Mar 15, 2018 9:34 AM

Reply Helpful

Mar 15, 2018 11:43 AM in response to Highstreetken In response to Highstreetken

Delete all network settings by entering in system preferences - networks and start from beginning .

User uploaded file

User uploaded file

Click on create .

User uploaded file

Type the network name , security as WPA2 personal and then enter your correct network password and click on ok , in DNS settings enter google server settings as 8.8.8.8 and 8.8.4.4 and click on ok . Come to first window and click on apply to join the network .The location is kept as automatic and no proxies are to be set , remember network this computer has joined is to be checked .

See this help also .

User uploaded file


First try this method , if it doesn't work in a very rarest situations by entering into system library > preferences > system configuration > network related files are to be deleted ( but its risky to delete these files ) but taking advice from apple support , the last step is reinstall the os How to reinstall macOS - Apple Support

Mar 15, 2018 11:43 AM

Reply Helpful

Mar 15, 2018 1:11 PM in response to Highstreetken In response to Highstreetken

What is the make & model of your router that is providing the Wi-Fi network? Does your MacBook Pro (MBP) have any issues connecting to other Wi-Fi networks? Does your wireless network use a name (aka, SSID) that is greater than 16-characters or include spaces or special characters in it?


For this network, if you temporarily disable wireless security, can the MBP connect now? If so, try using the following (temporary) password for WPA2 security: 0123456789abcdef0123456789


Can it connect now?

Mar 15, 2018 1:11 PM

Reply Helpful

Mar 16, 2018 7:44 AM in response to Highstreetken In response to Highstreetken

Thanks All for your thorough and speedy responses, much appreciated!


I'm embarrased to report that after taking Eric's advice and running wireless diagnostics, I followed advice to turn off router and then on again. That combined with moving my mac closer to router when I tried to reconnect did the trick!


Thanks again!

Mar 16, 2018 7:44 AM

Reply Helpful
Question marked as Apple Recommended

Mar 16, 2018 7:46 AM in response to Eric Root In response to Eric Root

Thanks Eric,


After running wireless diagnostics I followed advice to turn off router then on again. This combined with moving my mac closer to the router as i connected did the trick. Thank you for your advice, it's much appreciated.

Mar 16, 2018 7:46 AM

Reply Helpful

Mar 16, 2018 4:17 PM in response to Highstreetken In response to Highstreetken

If I enter incorrectly the WPA2 personal settings and password in the router and then restart the router , it never connects to wifi , even the computer is very near to the router ? and it has no connection of turning off then turning on the router .

Mar 16, 2018 4:17 PM

Reply Helpful
User profile for user: Highstreetken

Question: Trouble connecting to wifi