Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Font not working in Motion (v5.4)

As you can see in the screenshot below, I've tried a .tts font and get the exact same results, now I am using a .dFont that is perfectly recognized in any other Mac application just like the .tts, even in the font preview of Motion as seen in the screenshot is perfectly fine, but in the canvas it appears as an Open and Closed Lock Glyph... Why does this happen? How can I fix it?!...


The Font just have the "A" and "B" keys changed, but this is not a problem because it uses default glyphs in the other mappings.


Btw, It works just fine in any other app such as TextEdit, Pages, Numbers, Etc...


Even Copy and Pasting fonts between apps can handle the format, but when pasting those characters in the canvas It just won't work, it pastes the Lock Glyphs...


User uploaded file

User uploaded file

Mac mini, Mac OS X (10.6.8), null

Posted on

Reply

Page content loaded

Mar 16, 2018 12:01 AM in response to Scorge In response to Scorge

There are online resources that will allow you to split up TTCs and DFONTs in to their separate fonts. You could try separating the fonts and installing them individually.


FCPX and Motion are both very sensitive to font problems (like duplicate IDs, etc.). Have you verified your fonts with Font Book?


The problem you're experiencing also happens with fonts created on a PC and "windows encoding"... and if the font author created glyphs in character spaces that are considered "reserved" in Mac encoding (and there are several).

Mar 16, 2018 12:01 AM

Reply Helpful
User profile for user: Scorge

Question: Font not working in Motion (v5.4)