Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Photos crashes on launch

I would appreciate some troubleshooting help with Apple Photos. About 2 weeks ago it started crashing on launch. My Mac freezes and I have to force reboot. All other apps work fine after the reboot. I've tried the following to troubleshoot:

  1. Safe boot- the library opens fine. this seems to be the only way I can view my photos.
  2. Library Repair - I've rebuilt the library after safe booting. On a reboot, it still crashes on launch.
  3. New Library - I created a new library after safe boot. After reboot and trying to sync with my iCloud photos, it crashes again.
  4. iCloud - I can see all my photos on my iPhone and on iCloud.com without a problem.
  5. Extensions - I've disabled all extensions (plug-ins) and still crashes on launch.

My hunch is that there is some corrupt file since I can see my pictures on a safe boot. I've tried deleting photos plist files that I can find but to no avail. My next step is to clone my HD, wipe my macbook pro (2012, 16 gb ram, 500GB SSD), and try reinstalling from iCloud. Any ideas before I do that?

MacBook, macOS High Sierra (10.13.4)

Posted on

Reply

Page content loaded

Apr 20, 2018 10:26 AM in response to DanGreenberg In response to DanGreenberg

My hunch is that there is some corrupt file since I can see my pictures on a safe boot.

You may have installed third party software that added incompatible kernel extensions, if Photos is not crashing in Safe Mode. Safe Mode disables third-party kernel extensions (these are not necessarily the photo editing extensions or plug-ins. It could be older software, like Final Cut or similar, that is installing system extensions).

What does the crash log show?

Apr 20, 2018 10:26 AM

Reply Helpful

Apr 21, 2018 2:29 PM in response to léonie In response to léonie

I do have several photos extensions. Disabling them did not resolve it. Do you know where the files are stored so I can try manually moving them out?


Here's the most recent crash log. I just wiped my HD, reinstalled the os and used migration assistant. Same issue so it's likely something to do with a file in my user directory.

Apr 21, 2018 2:29 PM

Reply Helpful

Apr 21, 2018 2:38 PM in response to LarryHN In response to LarryHN

EtreCheck version: 4.2.1 (4C020)

Report generated: 2018-04-21 16:04:00

Download EtreCheck from https://etrecheck.com

Runtime: 7:36

Performance: Below Average


Problem: Apps are crashing


Major Issues:

Anything that appears on this list needs immediate attention.


Stuck iCloud- This machine has a large number of pending iCloud transfers.

Heavy CPU usage- Some processes are using an unusually high amount of CPU.


Minor Issues:

These issues do not need immediate attention but they may indicate future problems.


Kernel extensions blocked- There are blocked kernel extensions awaiting user approval.

Apps crashing- There have been numerous app crashes.

Clean up- There are orphan files that could be removed.

Unsigned files- There is unsigned software installed. They appear to be legitimate but should be reviewed.

Low performance- EtreCheck report took over 5 minutes to run. This is unusual.

32-bit Apps- This machine has 32-bits apps that may have problems in the future.


Hardware Information:

MacBook Pro (15-inch, Mid 2012)

MacBook Pro Model: MacBookPro9,1

1 2.3 GHz Intel Core i7 (i7-3615QM) CPU: 4-core

16 GB RAMAt maximum

BANK 0/DIMM0 - 8 GB DDR3 1600 ok

BANK 1/DIMM0 - 8 GB DDR3 1600 ok

Battery: Health = Normal - Cycle count = 10


Video Information:

Intel HD Graphics 4000 - VRAM: 1536 MB

Color LCD 1440 x 900

NVIDIA GeForce GT 650M - VRAM: 512 MB


Drives:

disk0 - Samsung SSD 850 EVO 500GB 500.11 GB (Solid State - TRIM: No)

Internal SATA 6 Gigabit Serial ATA

disk0s1 - EFI (MS-DOS FAT32) [EFI] 210 MB

disk0s2 () 499.24 GB

disk1s1 - D***********k (APFS) 499.24 GB (396.92 GB used)

disk1s2 - Preboot (APFS) [APFS Preboot] 499.24 GB (135 MB used)

disk1s3 - Recovery (APFS) [Recovery] 499.24 GB (3.10 GB used)

disk1s4 - VM (APFS) [APFS VM] 499.24 GB (1.07 GB used)

disk0s3 () 655 MB


Mounted Volumes:

disk1s1 - D***********k 499.24 GB (97.87 GB free)

APFS

Mount point: /


disk1s4 - VM [APFS VM] 499.24 GB (97.87 GB free)

APFS

Mount point: /private/var/vm


disk2s2 - T******************s 3.00 TB (842.55 GB free)

Case-Sensitive Journaled HFS+

Mount point: /Volumes/T******************s


Network:

Interface en0: Ethernet

Interface en4: iPhone

Interface fw0: FireWire

Interface en1: Wi-Fi

802.11 a/b/g/n

One IPv4 address

Interface en3: Bluetooth PAN

Interface bridge0: Thunderbolt Bridge

iCloud Quota: 45.73 GB available

iCloud Status: 8067 pending files


System Software:

macOS High Sierra 10.13.4 (17E199)

Time since boot: Less than an hour

System Load: 13.82 (1 min ago) 11.14 (5 min ago) 6.22 (15 min ago)


Security:

System Status
Gatekeeper Mac App Store and identified developers
System Integrity Protection Enabled


Unsigned Files:

Launchd: /Library/LaunchAgents/com.citrix.ServiceRecords.plist

Executable: /usr/local/libexec/ServiceRecords.app/Contents/MacOS/ServiceRecords

Details: Exact match found in the whitelist - probably OK

Launchd: ~/Library/LaunchAgents/net.juniper.SetupClient.plist

Executable: /Users/***/Library/Application Support/Juniper Networks/SetupClient/JuniperSetupClient.app/Contents/MacOS/JuniperSetupClient

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/com.citrix.ReceiverHelper.plist

Executable: /usr/local/libexec/ReceiverHelper.app/Contents/MacOS/ReceiverHelper

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/com.citrix.ctxusbd.plist

Executable: /Library/Application Support/Citrix Receiver/ctxusbd

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/com.oracle.java.Java-Updater.plist

Executable: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Java Updater.app/Contents/MacOS/Java Updater -bgcheck

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/org.virtualbox.startup.plist

Executable: /Library/Application Support/VirtualBox/LaunchDaemons/VirtualBoxStartup.sh restart

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/com.oracle.java.Helper-Tool.plist

Executable: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Resources/Helper-Tool

Details: Exact match found in the whitelist - probably OK

Launchd: ~/Library/LaunchAgents/org.virtualbox.vboxwebsrv.plist

Executable: /Applications/VirtualBox.app/Contents/MacOS/vboxwebsrv

Details: Exact match found in the whitelist - probably OK

Launchd: ~/Library/LaunchAgents/com.dropbox.DropboxMacUpdate.agent.plist

Executable: /Users/***/Library/Dropbox/DropboxMacUpdate.app/Contents/MacOS/DropboxMacUpdate -check periodic

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/com.microsoft.office.licensing.helper.plist

Executable: /Library/PrivilegedHelperTools/com.microsoft.office.licensing.helper

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchAgents/com.citrix.AuthManager_Mac.plist

Executable: /usr/local/libexec/AuthManager_Mac.app/Contents/MacOS/AuthManager_Mac

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/org.wireshark.ChmodBPF.plist

Executable: /Library/Application Support/Wireshark/ChmodBPF/ChmodBPF

Details: Exact match found in the whitelist - probably OK

Launchd: /Library/LaunchDaemons/com.prey.agent.plist

Executable: /usr/local/lib/prey/current/bin/prey

Details: Exact match found in the whitelist - probably OK


32-bit Applications:

66 32-bit apps


Kernel Extensions:

/Applications/Tunnelblick.app

[Not Loaded] tap-signed.kext (20141104 (Tunnelblick build 4921))

[Not Loaded] tun-20111101.kext (20111101 (Tunnelblick build 4921))


/Applications/Viscosity.app

[Not Loaded] tap.kext (SparkLabs Pty Ltd, 1.2)


/Library/Application Support/Citrix Receiver

[Not Loaded] CitrixGUSB.kext (Citrix Systems, Inc., 12.4.0 - SDK 10.9)


/Library/Application Support/VirtualBox

[Blocked] VBoxDrv.kext (Oracle America, Inc., 5.2.8)

[Blocked] VBoxNetAdp.kext (Oracle America, Inc., 5.2.8)

[Blocked] VBoxNetFlt.kext (Oracle America, Inc., 5.2.8)

[Blocked] VBoxUSB.kext (Oracle America, Inc., 5.2.8)


/Library/Extensions

[Blocked] ufsd_NTFS.kext (Paragon Software GmbH, 14.2.288 - SDK 10.5)


System Launch Agents:

[Not Loaded] 6 Apple tasks
[Loaded] 172 Apple tasks
[Running] 114 Apple tasks
[Other] One Apple task


System Launch Daemons:

[Not Loaded] 37 Apple tasks
[Loaded] 177 Apple tasks
[Running] 120 Apple tasks


Launch Agents:

[Loaded] com.microsoft.update.agent.plist (Microsoft Corporation - installed 2018-04-15)
[Loaded] com.trusteer.rapport.rapportd.plist (Trusteer LTD - installed 2018-02-21)
[Running] com.citrix.ServiceRecords.plist (? 8e6543d - installed 2016-11-09)
[Loaded] com.citrix.AuthManager_Mac.plist (? 1ce99fae - installed 2016-11-09)
[Running] com.citrix.ReceiverHelper.plist (? bbfad3f1 - installed 2016-11-09)
[Loaded] com.oracle.java.Java-Updater.plist (? 47baee8 - installed 2018-03-28)


Launch Daemons:

[Other] com.paragon-software.NTFS.fsnotify.daemon.plist (? 66744841 - installed 2016-08-29)
[Running] com.trusteer.rooks.rooksd.plist (Trusteer LTD - installed 2017-06-22)
[Loaded] com.microsoft.autoupdate.helper.plist (Microsoft Corporation - installed 2018-04-15)
[Running] com.bombich.ccchelper.plist (Bombich Software, Inc. - installed 2018-04-06)
[Not Loaded] org.virtualbox.startup.plist (? 700b9385 - installed 2018-03-13)
[Loaded] net.whatroute.whatroute2helper.plist (? d3b0e6b - installed 2016-10-31)
[Other] com.paragon.NTFS.launch.plist (Apple - installed 2018-03-27)
[Loaded] com.sparklabs.ViscosityHelper.plist (SparkLabs Pty Ltd - installed 2017-11-22)
[Running] com.objective-see.ransomwhere.plist (Objective-See, LLC - installed 2017-09-30)
[Loaded] com.microsoft.office.licensing.helper.plist (? 6d8cb30e - installed 2015-06-04)
[Loaded] com.oracle.java.Helper-Tool.plist (? e3fefdd2 - installed 2018-03-28)
[Running] com.backblaze.bzserv.plist (Backblaze - installed 2018-01-30)
[Loaded] com.citrix.ctxusbd.plist (? 44dc9c9f - installed 2016-11-09)
[Loaded] org.wireshark.ChmodBPF.plist (? d4207e05 - installed 2018-01-14)
[Running] com.prey.agent.plist (? 5687e286 - installed 2018-04-10)
[Running] com.nordvpn.NordVPN.Helper.plist (TEFINKOM & CO S.A - installed 2018-03-26)
[Loaded] com.prey.owl.plist (Prey, Inc. - installed 2017-11-25)


User Launch Agents:

[Loaded] net.juniper.SetupClient.plist (? 0 - installed 2016-10-05)
[Other] com.spotify.webhelper.plist (? 0 - installed 2017-05-30)
[Loaded] com.dropbox.DropboxMacUpdate.agent.plist (? 0 - installed 2018-04-15)
[Other] com.valvesoftware.steamclean.plist (? 0 - installed 2017-12-23)
[Other] com.avast.home.userinit.plist (? 0 - installed 2017-12-20)
[Not Loaded] org.virtualbox.vboxwebsrv.plist (? 0 - installed 2018-03-13)
[Running] com.backblaze.bzbmenu.plist (Backblaze - installed 2018-04-21)


User Login Items:

NordVPN Application (TEFINKOM & CO S.A

(/Applications/NordVPN.app)

Itsycal Application (Sanjay Madan

(/Applications/Itsycal.app)

Meteorologist Application (Edward Danley

(/Applications/Meteorologist.app)

CCC User Agent Application (Bombich Software, Inc. - installed 2018-04-02)

(/Applications/Carbon Copy Cloner.app/Contents/Library/LoginItems/CCC User Agent.app)

Paste Application (Mac App Store

(/Applications/Paste.app)

Magnet Application (Mac App Store

(/Applications/Magnet.app)

MenuBar Stats Application (Mac App Store

(/Applications/MenuBar Stats.app)


Internet Plug-ins:

SharePointBrowserPlugin: 14.7.7 (installed 2017-11-04)

CitrixICAClientPlugIn: 12.4.0 (installed 2018-03-15)

QuickTime Plugin: 7.7.3 (installed 2018-03-27)

npATNetscapePlugin: 1.0.3.33 (installed 2017-03-14)

JavaAppletPlugin: Java 8 Update 171 build 11 (installed 2018-04-19)

NP_2020Player_WEB: 5.0.94.0 (installed 2011-10-26)


User Internet Plug-ins:

ZoomUsPlugIn: 4.0.36452.0616 (installed 2017-06-28)


Audio Plug-ins:

BartenderAudioPlugIn: 1.0.0 (installed 2016-09-14)


Safari Extensions:

AutoPagerize.safariextz - swdyh - http://autopagerize.net/(installed 2016-10-01)
Cleaner - for Facebook.safariextz - Graffino - http://apps.graffino.com (installed 2016-10-01)
Amazon Assistant for Safari.safariextz - Amazon - https://www.amazon.com/gp/BIT/AmazonAssistant/TOU(installed 2018-01-12)
Ebates Cash Back.safariextz - Ebates Performance Marketing, Inc. - http://ebates.com/ (installed 2018-04-15)
1Password.safariextz - AgileBits - https://agilebits.com/onepassword (installed 2016-09-26)
Ghostery.safariextz - GHOSTERY, Inc. - https://www.ghostery.com/ (installed 2018-03-31)
AdBlock.safariextz - BetaFish, Inc. - https://getadblock.com (installed 2017-11-16)
The Camelizer - Price Tracker.safariextz - Cosmic Shovel, Inc. - https://camelcamelcamel.com (installed 2017-06-08)
HoverSee.safariextz - SideTree.com - Apps for Mac - http://SideTree.com/extensions.html#HoverSee(installed 2016-10-01)


3rd Party Preference Panes:

AppTrap (installed 2018-03-31)

Backblaze Backup (installed 2018-01-30)

Java (installed 2018-03-28)


Time Machine:

Skip System Files: No

Mobile backups: Yes

Auto backup: Yes

Volumes being backed up:

D***********k: Disk size: 499.24 GB - Disk used: 401.37 GB

Destinations:

3************************e [Network] (Last used)

Total size: 3.00 TB

Total number of backups: 258

Oldest backup: 2017-11-11 00:09:43

Last backup: 2018-04-21 07:07:30


Top Processes by CPU:

Process (count) Source % of CPU
VTDecoderXPCService (2) Apple 230
diagnosticd Apple 108
bird Apple 81
Console Apple 72
bztransmit Backblaze 66


Top Processes by Memory:

Process (count) Source RAM usage
kernel_task Apple 1.39 GB
bztransmit Backblaze 976 MB
mdworker (28) Apple 742 MB
Safari Apple 712 MB
mds_stores Apple 458 MB


Top Processes by Network Use:

Process Source Input Output
kernel_task Apple 751 MB 254 MB
cloudd Apple 19 KB 3 MB
com.apple.WebKit.Networking Apple 229 KB 622 KB
mDNSResponder Apple 181 KB 34 KB
nsurlsessiond Apple 78 KB 46 KB


Top Processes by Energy Use:

Process (count) Source Energy usage (0-100)
VTDecoderXPCService (2) Apple 68
diagnosticd Apple 32
Console Apple 30
bird Apple 28
com.apple.photos.VideoConversionService Apple 19


Virtual Memory Information:

Available RAM 8.79 GB
Free RAM 155 MB
Used RAM 7.21 GB
Cached files 8.64 GB
Swap Used 512 KB


Clean up:

~/Library/LaunchAgents/com.spotify.webhelper.plist

/Users/***/Library/Application Support/Spotify/SpotifyWebHelper

Executable not found

~/Library/LaunchAgents/com.avast.home.userinit.plist

/Users/***/Library/Application Support/Avast/hub/userinit.sh

Executable not found

~/Library/LaunchAgents/com.valvesoftware.steamclean.plist

/Users/***/Library/Application Support/Steam/SteamApps/steamclean

Executable not found

/Library/LaunchDaemons/com.paragon-software.NTFS.fsnotify.daemon.plist

/Library/PreferencePanes/ParagonNTFS.prefPane/Contents/Resources/com.paragon-sof tware.NTFS.fsnotify.daemon

Executable not found


Diagnostics Information (past 7 days):

2018-04-21 15:48:50 Last Shutdown Cause: 3 - Hard shutdown (once)

2018-04-21 14:58:18 WindowServer Crash (2 times)

StartTime:2018-04-21 14:44:23

GPU:IG&NV

MetalDevice for accelerator(0x3277): 0x7fc9cee184f8 (MTLDevice: 0x7fc9d1032200)

MetalDevice for accelerator(0x4907): 0x7fc9ced4bb78 (MTLDevice: 0x7fc9d1042600)

IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P2@1/IOPP/GFX0@0/NVDA,D isplay-A@0/NVDA

Assertion failed: (isReady - DisplayID: 0x4272902

FB RegID: 4294968294, On Glass SurfaceIDs: 1 6, Transactions: [ Active SurfaceID: 0 ] [ Active SurfaceID: 6 ]

), function CoreDisplay_NotReady, file /BuildRoot/Library/Caches/com.apple.xbs/Sources/CoreDisplay/CoreDisplay-97.16/C oreDisplay/Display/Display.cpp, line 1867.

2018-04-20 12:14:27 rapportd.app Crash (21 times)

dyld: launch, loading dependent libraries

2018-04-20 08:13:12 SuperDuper!.app Crash (once)


End of report

Apr 21, 2018 2:38 PM

Reply Helpful

Apr 21, 2018 2:57 PM in response to DanGreenberg In response to DanGreenberg

Also, I don't see any specific crash logs related to photos. I had several related to rapport though. I fully deleted all associated files and all logs. On the next crash, the logs are empty.

Apr 21, 2018 2:57 PM

Reply Helpful

May 7, 2018 5:40 PM in response to DanGreenberg In response to DanGreenberg

I have come to the conclusion that it's hardware related. I did a clean install, didn't set up my iCloud restore and it still crashes on launch with an empty library. The screen doesn't redraw completely in safe boot, though it does in a regular boot, so I suspect that the GPU is going. Oh well, waiting for WWDC.

May 7, 2018 5:40 PM

Reply Helpful

May 30, 2018 12:58 AM in response to DanGreenberg In response to DanGreenberg

Hi Dan, Just to let you know I have a 15" 2011 MacBook Pro that has the same problem - even after a complete clean install and no library imported it crashes with photos. My library is fine on a new replacement Mac book. But the strange thing is how it can easily display photos and videos with quick view and no problems in any other app - So what is it about Photos?!!! Any ideas from Apple?

good luck with it

Andy

May 30, 2018 12:58 AM

Reply Helpful

May 30, 2018 4:57 PM in response to Andy MP In response to Andy MP

I haven't fixed it yet through multiple installs. My latest troubleshooting though indicates that it's related to iCloud's library sync. I've reached that conclusion because when my macbook is plugged in and it tries to sync, it always crashes immediately requiring a force restart. However if my macbook is unplugged, synching is paused by default and I can actually browse my photos. Once I plug it back in, full system crash if Photos is opened.


FYI I've seen no difference between High Sierra and the beta releases.

May 30, 2018 4:57 PM

Reply Helpful (1)
User profile for user: DanGreenberg

Question: Photos crashes on launch