Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: 2010 MacBook Pro won't boot completely

I have a mid-2010 13" MacBook Pro with a strange problem. I cannot get it to fully boot using any method (hard drive, USB, internet recovery). It boots partially but seems to freeze or get stuck (often the mouse can still move but the boot will never complete). I was able to boot the machine into an EFI version of ASD 3S138 and it reports this strange error (with or without the battery connected). Does anyone know what the error means?


User uploaded file


History: I bought the MacBook from a friend - she said there was a problem with the Hard Drive. Here is what I found:


1. Hard Drive Cable was damaged and battery was swelled. Removed battery, replaced hard drive cable, and installed a brand new SSD.

2. I tried to install macOS High Sierra from USB. The install never completed, at one point saying it would take 19 hours. Even after leaving it for 24 hours or more the install would not complete.

3. I tried to install macOS El Capitan from USB. This worked fine, installed in less than an hour.

4. I was able to boot from the hard drive and update El Capitan.

5. I installed a new non-Apple battery purchased of eBay. Seemed to work OK but never fully charges to the point where the charger turns green but otherwise works good. Still able to boot El Capitan fine.

6. I redownloaded the High Sierra installer on another mac and made a new USB installer. Tried booting to USB and installing High Sierra - same result as in point 2.

7. I was still able to boot to El Capitan off the hard drive so I dragged the High Sierra installer from the USB stick to the Applications folder and tried to run it off the hard drive while running El Capitan. Same result as point 2.

8. At some point it stopped booting to El Capitan - just gets part through and then the progress bar stays in one place. Computer is not frozen, can still move the mouse, but it never completely starts up.

9. I tried to boot to recovery mode with cmd-R - same result, never completely starts up.

10. I tried to boot to internet recovery mode. It lets me select my wifi and starts to show the progress bar but never completely starts up.

11. I tried disconnecting the battery and hard drive and booting from USB either ASD 3S138 or one of the macOS install sticks I made. No dice - looks normal until at some point it just stops.

12. Yes I have zapped the PRAM and Yes I have reset the SMC

13. Yes I have swapped out RAM.


Any ideas I can try are welcome as I am at my wits end with this one.

MacBook Pro, OS X El Capitan (10.11.6), ASD 3S138, mid-2010 13"

Posted on

Reply

Page content loaded

Apr 19, 2018 11:06 PM in response to Larry Jorgenson In response to Larry Jorgenson

From what little I know, R_a 0-7 is a battery error, with "value over 2k" implying the test is finding too great a level of resistivity in the battery (perhaps because its not a branded Apple one).


If you could boot it okay into El Cap and the error only appeared when you tried to install High Sierra, that implies the problem is somewhere in relation to the higher specs needed to run High Sierra. Are you certain that yours is a mid 2010 and not an early 2010....as mid 2010 is the cut off point for running High Sierra?

Apr 19, 2018 11:06 PM

Reply Helpful

Apr 20, 2018 7:58 AM in response to LeapUK In response to LeapUK

I am certain it is a mid 2010 MacBook Pro because the AHT screenshot identifies it as such.


I "could" boot it into El Capitan at one time but it will no longer boot into any version OS from anywhere (HD, USB, or Internet Reccovery).

Apr 20, 2018 7:58 AM

Reply Helpful

Apr 20, 2018 9:02 PM in response to Larry Jorgenson In response to Larry Jorgenson

UPDATE: I had forgotten that I had installed a couple of 4GB RAM sticks that I bought used. My guess is they are either the wrong spec or defective. As soon as I reinstalled the original 2 X 2GB sticks the non-boot problems went away. Sorry everyone. I was able to install High Sierra no problem. However, I am just in the process of wiping and reinstalling so I can sell the machine and it is up to it's old tricks again. Booted to recovery, erased the HD (AFPS), and started the install about 1/2 hr ago. Just checked and it says 5 hours + to go. Not happy about that but I'll leave it go and see if it completes.

Apr 20, 2018 9:02 PM

Reply Helpful (1)

Apr 21, 2018 8:44 AM in response to Larry Jorgenson In response to Larry Jorgenson

UPDATE 2: I left it overnight and awoke to find the install had completed. Also, regarding the battery error in the photo - if I run the test without the non-apple battery installed I do not get the error. So, it is likely just that the battery lacks whatever circuitry Apple puts in their battery to report back properly to the AHT and ASD tests.

Apr 21, 2018 8:44 AM

Reply Helpful
User profile for user: Larry Jorgenson

Question: 2010 MacBook Pro won't boot completely