Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: recovering files from iCloud

So I'm on iCloud drive and I can see the folder with my desktop files, but I cannot download them. I went to settings recover files but i cannot see the desktop files. If i can see them on the iCloud drive itself, is there a way to download them back to my computer? thanks jay

iMac, iOS 4.3.2

Posted on

Reply
Question marked as Apple Recommended
Answer:
Answer:

If you are seeing the Desktop & Documents folders in iCloud, then that means that you have that option turned on in iCloud Drive. If you want to turn off that option so that they are put back on your Mac and show in your Finder instead of in iCloud Drive, then you need to follow the instructions below:


Turn off Desktop and Documents

When you turn off Desktop & Documents Folders, your files stay in iCloud Drive and a new Desktop and Documents folder is created on your Mac in the home folder. You can move files from iCloud Drive to your Mac as you need them, or select all of your files and drag them to the place you want to keep them.

  1. From your Mac, go to Apple menu User uploaded file > System Preferences > iCloud.
  2. Next to iCloud Drive, click Options.
  3. Deselect Desktop & Documents Folders.
  4. Click Done.

If you turn off iCloud Drive or sign out of iCloud, you have the option to keep a local copy of your files that are in iCloud Drive. Whether you decide to keep a local copy or not, a new Desktop and Documents folder is created in your home folder. If you choose to keep a local copy, your files in iCloud Drive are copied to a folder called iCloud Drive (Archive) in your home folder. Then you have the option to move any files that were in your iCloud Desktop and Documents, back to your new local Desktop and Documents.

From this support article: Add your Desktop and Documents files to iCloud Drive - Apple Support

Best,

GB

Posted on

Question marked as Helpful

Apr 23, 2018 7:34 AM in response to Jay Rogers1 In response to Jay Rogers1

Notes are sync'd via iCloud. If they aren't showing up on your Mac, then you should check >System Preferences>iCloud>Notes, and make sure that Notes are turned on. If they are, turn them off and then back on to see if you can kickstart the sync.


You can also try signing out of iCloud in System Preferences, and then sign back in again. This can clear up things that are not syncing correctly.


Also, on your Mac, make sure that you have "All iCloud" selected in the Folders on your sidebar. If you have "All on My Mac" selected, then you won't see them.


Best,


GB

There’s more to the conversation

Read all replies

Page content loaded

Question marked as Apple Recommended

Apr 20, 2018 1:45 PM in response to Jay Rogers1 In response to Jay Rogers1

If you are seeing the Desktop & Documents folders in iCloud, then that means that you have that option turned on in iCloud Drive. If you want to turn off that option so that they are put back on your Mac and show in your Finder instead of in iCloud Drive, then you need to follow the instructions below:


Turn off Desktop and Documents

When you turn off Desktop & Documents Folders, your files stay in iCloud Drive and a new Desktop and Documents folder is created on your Mac in the home folder. You can move files from iCloud Drive to your Mac as you need them, or select all of your files and drag them to the place you want to keep them.

  1. From your Mac, go to Apple menu User uploaded file > System Preferences > iCloud.
  2. Next to iCloud Drive, click Options.
  3. Deselect Desktop & Documents Folders.
  4. Click Done.

If you turn off iCloud Drive or sign out of iCloud, you have the option to keep a local copy of your files that are in iCloud Drive. Whether you decide to keep a local copy or not, a new Desktop and Documents folder is created in your home folder. If you choose to keep a local copy, your files in iCloud Drive are copied to a folder called iCloud Drive (Archive) in your home folder. Then you have the option to move any files that were in your iCloud Desktop and Documents, back to your new local Desktop and Documents.

From this support article: Add your Desktop and Documents files to iCloud Drive - Apple Support

Best,

GB

Apr 20, 2018 1:45 PM

Reply Helpful

Apr 22, 2018 8:39 AM in response to gail from maine In response to gail from maine

This doesn't work for me...I checked and desktop and documents is not selected....yet my desktop data disappeared and now my "notes" are gone also...and when i go to iCloud drive there is no download button...only an upload button...Apple must fix this or iCloud is in for a rainy, rainy day...

Apr 22, 2018 8:39 AM

Reply Helpful

Apr 22, 2018 2:42 PM in response to Jay Rogers1 In response to Jay Rogers1

So, you are not saying that your Desktop data appeared in the iCloud Drive folder?


If they are in the folder, as the article I posted indicated, you can retrieve them from an Archive folder on your Mac if you saved them. See the last paragraph that I bolded and italicized.


Notes are not a part iCloud Drive. They are in iCloud. Do you see your Notes in iCloud?


Best,


GB

Apr 22, 2018 2:42 PM

Reply Helpful

Apr 22, 2018 4:43 PM in response to gail from maine In response to gail from maine

Gail,

Yes, I found them in the home drive, but I cannot imagine why they disappeared off the desktop, particularly since I didn't have desktop marked. And yes, I see the notes on iCloud, but that's not where I need them and I fail to see why they were moved from my computer. Do you understand this?

Thanks,

Jay

Apr 22, 2018 4:43 PM

Reply Helpful
Question marked as Helpful

Apr 23, 2018 7:34 AM in response to Jay Rogers1 In response to Jay Rogers1

Notes are sync'd via iCloud. If they aren't showing up on your Mac, then you should check >System Preferences>iCloud>Notes, and make sure that Notes are turned on. If they are, turn them off and then back on to see if you can kickstart the sync.


You can also try signing out of iCloud in System Preferences, and then sign back in again. This can clear up things that are not syncing correctly.


Also, on your Mac, make sure that you have "All iCloud" selected in the Folders on your sidebar. If you have "All on My Mac" selected, then you won't see them.


Best,


GB

Apr 23, 2018 7:34 AM

Reply Helpful (1)
User profile for user: Jay Rogers1

Question: recovering files from iCloud