Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Logic Pro X Piano Roll link mode problems

I'm having the most insanely frustrating problems with link mode in Logic Pro X. Most of the time, when I first try to side-scroll after opening the Piano Roll Editor, it jumps to some ridiculous location, with none of the relevant MIDI data I'm trying to work on... Sometimes it leaps to a location where there isn't even a region!


I've tried both with and without link mode enabled, and it will behave correctly once, but then reverts back to its idiotic ways the next time I open the editor. Does anyone know of an actual fix for this? (Read: Yes, I've read other threads that mention "finding" the link button, or toggling it on/off.)


This been a problem on my system for a long time, but lately it's become completely infuriating... So any remedy would be deeply appreciated.

Logic Pro X, macOS Sierra (10.12.3)

Posted on

Reply

Page content loaded

Apr 22, 2018 10:05 AM in response to wheetabix In response to wheetabix

This really has to be a bug. I've tried with/without "Catch Content by Position..." as well, but no matter what I do, newly opened Piano Roll views will locate to some bizarre position as soon as I scroll. If I then toggle Catch off/on, scrolling works correctly again. (This is the same regardless of whether Catch is on or off, btw.)


One sort of crappy "solution" is to just keep a piano roll open in another space. As long as I don't close it, it seems to behave correctly.


Does anybody know whether there's any sense in re-installing?

Apr 22, 2018 10:05 AM

Reply Helpful
User profile for user: wheetabix

Question: Logic Pro X Piano Roll link mode problems