Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Question:

Question: Can't install the update 10.13.6 Error 602

Hi there,


I got my new MacBook Pro 2018(13 inch) last week and saw the throttling issued from Youtube. I also read about Apple just released a patch to fix the problem. The thing is I can't now install the update properly. I have already tried the safe mode and NVRAM and it still doesn't work. Therefore, I would like to ask if any of you have the same problem and how to solve it. Of course, it would be great if Apple will response to my request.


Regards

MacBook Pro TouchBar and Touch ID, macOS High Sierra (10.13.5)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I have no idea.

Maybe others will know.

Posted on

Page content loaded

Oct 8, 2018 1:18 AM in response to linjie.H In response to linjie.H

Oddly enough, I clicked on this link Download macOS High Sierra 10.13.6 Supplemental Update 2 for MacBook Pro (2018)

and downloaded the pkg file onto my desktop (same MBP that wouldn't allow for the update through the App store) and then when it finished downloading, I simply clicked on the file and voila, it updated the OS.

Oct 8, 2018 1:18 AM

Reply Helpful (1)

Oct 31, 2018 8:23 AM in response to linjie.H In response to linjie.H

The issue you are experiencing could have to do with some sort of proxy that you have installed on your Mac as one of the other comments in response to your thread indicates. In that respondents case, his company was routing all his traffic through a proxy, and thus when s/he left the office and went to a Starbucks, where the proxy wasn't present, s/he was able to install the patch. My case was a little different, but also related to proxying software.


I have a corporate issue MacBook Pro 15" running High Sierra 10.13.6. Whenever attempting to use the Mac Store app to apply the 10.13.6 supplemental updates (including iTunes 12.8, Safari 12.0.1, and Security Update 2018-002 10.13.6) it would fail during the installation phase with "An error has occurred. An error occurred installing the update. (602)". It has been very difficult to find any concrete answers to this question online, and I ultimately used the Console app on the Mac to provide me with some clues as to what might be happening. This row from my Console log shows the failure, and the primary clue for me was that NetworkRequired = true.


Operations failed with error: Error Domain=BOSErrorDomain Code=204 "An error occurred during preflight." UserInfo={NSLocalizedDescription=An error occurred during preflight., NSUnderlyingError=0x7fb369224b50 {Error Domain=BridgeOSSoftwareUpdateError Code=19 "MSU - 2 (Failed to personalize with options.);MSU - 2 (Could not personalize boot/firmware bundle.);AMAI - 3099 (AMAuthInstallBundlePersonalize() failed: );" UserInfo={NSLocalizedDescription=MSU - 2 (Failed to personalize with options.);MSU - 2 (Could not personalize boot/firmware bundle.);AMAI - 3099 (AMAuthInstallBundlePersonalize() failed: );, MSUErrorCode=2, AMAuthInstallErrorCode=3099, MSUErrorDescription=Failed to personalize with options., NetworkRequired=true}}}


Additionally, I saw a number of other rows above this one in my console log from a bosUpdateProxy process that was brokering TLS handling (managing data encryption). The big "ah hah" for me was that I had proxy interference, further substantiated by the Starbucks respondent, so I started digging around on my Mac for proxying software, and came upon a new app/service that my company uses called Zscaler.


I was thankfully and with great relief able to solve the issue by setting the Connectivity Status of the installed Zscaler application on my Mac from "On" to "Off" (I did not uninstall it -- just turned it off) and then trying the install through the Mac Store App again. Once it was "Off" I was able to install the supplemental update software successfully to my Mac.


I hope this helps you or someone else suffering from the same problem.

Oct 31, 2018 8:23 AM

Reply Helpful
User profile for user: linjie.H

Question: Can't install the update 10.13.6 Error 602