Question:

Question: iOS 12 and Instant Hotspot Not Working

I'm wondering if this is a problem for anyone else. and maybe offer a suggestion how to fix it.


Here's what I have:

iPhone 6s Plus - iOS 12

iPad Pro 9.5 - iOS 12

MacBook Pro - MacOS Mojave 10.14

All using the same iCloud account


When I try to use my iPhone hotspot, my iPad refuses to connect. I can see the iPhone available on iPad under Personal Hotspot, but when I try to connect to the hotspot it tries for a bit then returns an error "Unable to start personal hotspot "Brian's iPhone". I have tried starting with spot off and on.


Note: before the iOS 12 upgrade, I was able to connect, but it usually took more than one attempt.


Also note: earlier today when I tried connecting to the iPhone with my MacBook I successful.


My research has lead me to try the following multiple times (with no success):

Log out/in of iCloud on iPhone and iPad

Reset network settings on both iPhone and iPad

Reset all settings (factory reset) on iPhone and iPad


Is there some trick to get this to work?

Is there something anyone can suggest I may have not tried?


Any advice and suggestions are welcome and appreciated.


Thanks in advanced.

Brian

MacBook Pro with Retina display, macOS Mojave (10.14)

Posted on

Reply
Question marked as Apple recommended
Answer:
Answer:

This worked for me too.


What did the trick for me was:

- disable personal hotspot on iPad

- sign out from iCloud on iPad

- restart iPad

- sign in to iCloud

- enable personal hotspot


Using cellular iPad to get data onto the iPhone when abroad.

Posted on

Question marked as Helpful

Oct 15, 2018 10:24 AM in response to BrianInBS In response to BrianInBS

What worked for me was to delete a lot of old hotspot passwords that had accumulated over the years in my iCloud account.


I did the following on my Mac and now my phone appears at the top of the Wifi list (not sure which of these steps was the one that actually fixed it):


On a Mac that has iCloud Keychain enabled (so that passwords sync with iCloud):

-Open Network Preferences->Wifi>Advanced..., then delete all old Wifi Hotspot entries (iPhone, XXX's iPhone,...)

-Open the Keychain Access app and delete all iPhone HotSpot passwords from iCloud. (An easy way to do this is to enter iPhone using the search field, but don't just delete everything indiscriminately--you are looking for entries like "XXX's iPhone 6s" which are listed as "Application Password" in the System or iCloud Keychain). It can also be helpful to search on the "Date Modified" column so you can easily see which entries may be ancient.


After I cleared all of these stored passwords, my phone immediately appeared at the top of the Wifi connection list. I don't have an iPad, but I suspect that deleting these passwords from iCloud could help with your situation too.

There’s more to the conversation

Read all replies

Oct 1, 2018 4:13 PM in response to singh49asda In response to singh49asda

Thanks for your reply. However, I am aware how it is supposed to work. But, it does not.


As I stated in my original post, it worked before the upgrade to iOS 12, now it does not.


Again, Instant Hotspot does not work, neither can I connect to the iPhone when the switch the hotspot on manually.

Oct 1, 2018 4:13 PM

Reply Helpful (2)

Oct 1, 2018 4:18 PM in response to JKingsnorth In response to JKingsnorth

Thank you for your reply. It's actually good to know I am not alone with this problem.


I spent 3 hours with the genius bar yesterday. What a treat that was. I spent the first 50 minutes educating the technician how it was supposed to work.


the technician did everything I had already done. Reset network setting. Reset all settings, downloaded and installed iOS 12 again. this was on both devices. Nothing solved the issue.


Their only suggestion was to contact phone support so that a bug can be logged. Not helpful.


I am currently attempting to install iOS 11 back to the iPad to prove or disprove the issue lies with iOS 12.


I should say, I am not having much luck downgrading.

Oct 1, 2018 4:18 PM

Reply Helpful

Oct 2, 2018 11:25 AM in response to BrianInBS In response to BrianInBS

Sorry if it was not clear. Yes, Wi-Fi and Bluetooth are indeed on

.

I have read the page you point to, I understand how hand off is supposed to work. I have also read Apple's troubleshooting document regarding the operation of the hotspot.


I spent 3 hours with a Genius Bar technician on Sunday. He too was unable to find the cause of or to fix the problem.


I have since called Apple support. They, as well as the Genius Bar technician have confirmed I have done everything correctly and taken all the steps possible to resolve this issue.


The phone support technician has confirmed, there is a known issue with iOS 12 where some devices are unable to connect to an iPhone hotspot.

Oct 2, 2018 11:25 AM

Reply Helpful (1)

Oct 3, 2018 4:27 PM in response to BrianInBS In response to BrianInBS

Same here.


iPhone SE - IOS12

iPad Pro 9.5 - IOS12

iMac - High Sierra


for testing purposes additionally:

2nd iPhone SE - IOS12

iPad mini 2 Cellular - IOS12

iPad Air - IOS12


Handoff and Universal clipboard are working in every combination on every device. So the basic bluetooth/wifi/icloud magic works.


All devices except the iPad Pro 9.5 can activate the hotspots on the iphones and the ipad mini.

The iPad Pro 9.5 constantly says "Unable to start personal hotspot..."

If I activate the hotspot manually and disable bluetooth on the iPad, so that the hotspot is seen as wifi device it can connect (but thats not what we want....)


I tried the same as you, multiple times. icloud logoff/network reset/factory reset with and without backup. With iphone and ipad. No success.


Matt

Oct 3, 2018 4:27 PM

Reply Helpful

Oct 8, 2018 5:16 AM in response to BrianInBS In response to BrianInBS

What did the trick for me was:

- disable personal hotspot on iPhone

- sign out from iCloud on iPhone

- restart iPhone

- sign in to iCloud

- enable personal hotspot


Signing in/out of iCloud is a bit of a pain.


I'm really, really getting tired of having to sort stuff out on my Apple devices. The reason I chose Apple was to have uncluttered stuff that just works, it has not been the case for years.

Oct 8, 2018 5:16 AM

Reply Helpful (3)
Question marked as Apple recommended

Oct 9, 2018 3:02 AM in response to BillyNelson In response to BillyNelson

This worked for me too.


What did the trick for me was:

- disable personal hotspot on iPad

- sign out from iCloud on iPad

- restart iPad

- sign in to iCloud

- enable personal hotspot


Using cellular iPad to get data onto the iPhone when abroad.

Oct 9, 2018 3:02 AM

Reply Helpful (4)
Question marked as Helpful

Oct 15, 2018 10:24 AM in response to BrianInBS In response to BrianInBS

What worked for me was to delete a lot of old hotspot passwords that had accumulated over the years in my iCloud account.


I did the following on my Mac and now my phone appears at the top of the Wifi list (not sure which of these steps was the one that actually fixed it):


On a Mac that has iCloud Keychain enabled (so that passwords sync with iCloud):

-Open Network Preferences->Wifi>Advanced..., then delete all old Wifi Hotspot entries (iPhone, XXX's iPhone,...)

-Open the Keychain Access app and delete all iPhone HotSpot passwords from iCloud. (An easy way to do this is to enter iPhone using the search field, but don't just delete everything indiscriminately--you are looking for entries like "XXX's iPhone 6s" which are listed as "Application Password" in the System or iCloud Keychain). It can also be helpful to search on the "Date Modified" column so you can easily see which entries may be ancient.


After I cleared all of these stored passwords, my phone immediately appeared at the top of the Wifi connection list. I don't have an iPad, but I suspect that deleting these passwords from iCloud could help with your situation too.

Oct 15, 2018 10:24 AM

Reply Helpful (6)
User profile for user: BrianInBS

Question: iOS 12 and Instant Hotspot Not Working