Announcement: Upgrade to macOS Mojave

With features like Dark Mode, Stacks, and four new built-in apps, macOS Mojave helps you get more out of every click. 
Find out how to upgrade to macOS Mojave > https://support.apple.com/macos/mojave

Question:

Question: "Time Machine Backup Failed" since upgrading to Mojave

I am using Time Machine (TM) to back up to a 2 TB partition on a 4 TB external LaCie Porsche HD.


On Monday (9/24/2018) I upgraded to Mojave (Mac OS 10.14). On Tuesday, I got a message that my external HD didn't have enough space and TM wanted to erase an old backup from 3 years ago to make space. I gave it permission to do so, and all proceeded as normal.


It appears when looking in the Backups folder that there were 7 more backups that went well UNTIL the 26th and I started getting "Time Machine Backup Failed" messages. I've run Disk First Aid on the disk twice. By way of the Finder, I have removed 7 or 8 backups from 3 years ago. (Strangely, it says that I have freed up 600 GB. Which doesn't seem right since there are scores more backups still on the drive than the 8 that I deleted!) I restarted my Mac each time after I deleted and emptied the trash with the old backups.


Now the old drive was formatted as Mac OS X Extended (Journaled). Is that in conflict with the new APFS that Mojave uses? Do I have to reformat the partition of my external HD so that the backups will work normally? Will have to erase ALL of the partitions of my external HD!? (I don't want to do that since I have other important stuff on the other partitions.)


If anyone has any answers, please let me know ASAP.


Thanks.

iMac, macOS Mojave (10.14), 16 GB RAM, 1 TB HD

Posted on

Reply
Question marked as Solved
Answer:
Answer:

Try this - Link to post by Natemo80

It worked for me.

Posted on

Page content loaded

Oct 4, 2018 2:42 PM in response to Green Lantern In response to Green Lantern

In doing more research into this problem, I found an interesting point on a web site dated July, 2015. It said that the backup drive's partition must be the same format as the Mac.


So I'm guessing that this rule still applies today? Since Mojave changes the Mac's format to APFS, and my backup drive's partition is still in Mac OS Extended (Journaled) format, it seems that the only solution (unless Apple fixes this somehow) is to reformat my backup partition (which would mean losing 3 years of backups!) to the new APFS format.


This is NOT good. (I really don't want to lose 3 years with of backups.)


Does anyone else have any better ideas?

Oct 4, 2018 2:42 PM

Reply Helpful (1)

Oct 4, 2018 4:47 PM in response to Green Lantern In response to Green Lantern

Sono un nuovo utente (italiano) della Comunità Apple e, purtroppo, devo scrivere in lingua italiana.

Green Lantern, la tua affermazione riguardo ai formati APFS e Mac OS Extended (Journaled) è corretta.

Anche io ho inizializzato il disco, riservato esclusivamente per i backup, nel formato APFS (quello cioè che utilizza macOS Mojave), ma quando ho avviato Time Machine, questo mi ha subito segnalato che il formato che avevo scelto non era compatibile con TM. Ho dovuto necessariamente inizializzare ancora nell'unico formato che Time Machine accetta: e cioè Mac OS Extended (Journaled).

Fatto questo, ho avviato Time Machine, che è partito regolarmente, ma dopo aver effettuato un backup di 18.56 GB su un totale di circa 50 GB (cioè tutto il disco SSD esterno sul quale ho installato Mojave), Time Machine si è bloccato dando un messaggio di errore che diceva che ci sono dei problemi con la copia dei file e consigliava di usare Utility disco per la eventuale riparazione.

Ho ripetuto almeno tre volte l'operazione di backup con TM, dopo regolare inizializzazione del disco di backup, ma inutilmente.

A questo punto non so come procedere... attendo fiducioso che Apple possa provvedere a sistemare il "Blocco" di Time Machine con il rilascio della prima release di aggiornamento di Mojave.

Oct 4, 2018 4:47 PM

Reply Helpful

Oct 4, 2018 4:51 PM in response to Alberto.Italy In response to Alberto.Italy

Translated:

I am a new user (Italian) of the Apple Community and, unfortunately, I have to write in Italian.

Green Lantern, your statement about the APFS and Mac OS Extended (Journaled) formats is correct.

I also initialized the disk, reserved exclusively for backups, in the APFS format (the one that uses MacOS Mojave), but when I started Time Machine, it immediately signaled to me that the format I had chosen was not compatible with TM. I had to necessarily initialize again in the only format that Time Machine accepts: that is Mac OS Extended (Journaled).

That done, I started Time Machine, which started regularly, but after having made a backup of 18.56 GB on a total of about 50 GB (ie all the external SSD disk on which I installed Mojave), Time Machine crashed giving a error message saying that there are problems with copying files and advised to use Disk Utility for any repairs.

I have repeated at least three times the backup operation with TM, after regular initialization of the backup disk, but to no avail.

At this point I do not know how to proceed ... I am confident that Apple can provide to fix the "Block" of Time Machine with the release of the first release of Mojave update.

Oct 4, 2018 4:51 PM

Reply Helpful

Oct 6, 2018 8:24 PM in response to Green Lantern In response to Green Lantern

I received an e-mail today with a link to a discussion going on here in the Apple Support Communities which is regarding this same topic. There was a link to a suggestion by "Natemo80", and another more detailed procedure by "Pathfineroz," to remove the App Cleaner & Uninstall app (Re: Mojave Time Machine Backups Fail). I followed the directions to do a thorough removal of the application. (You can find the directions to do a thorough and proper removal of the App Cleaner app on the developer's web site. Here's the link: https://nektony.com/mac-app-cleaner/how-to-uninstall-app-cleaner-from-mac)


I followed the directions, restarted my Mac, and then tried doing a Time Machine backup AND IT WORKED! This is the first complete and successful Time Machine backup that I've had in 10 days since upgrading to Mojave!


If you have the "App Cleaner & Uninstall" app by Nektony on your Mac, and you haven't been able to do a Time Machine backup since upgrading to Mojave (Mac OS 10.14), then you may want to try this solution.


If you don't have App Cleaner & Uninstall on your Mac, then you will have to find a different solution.


I hope this helps you.

Oct 6, 2018 8:24 PM

Reply Helpful (1)

Oct 14, 2018 7:39 PM in response to Green Lantern In response to Green Lantern

TOTALLY HELFUL!! IT WORKED!!


Seeing much more value of my backup app over App Cleaner, I not only deleted the Library file as noted, but also deleted the app, App Cleaner. Trying to backup immediately failed, but after a system restart my backups are back to normal. Great post and many thanks!!

Oct 14, 2018 7:39 PM

Reply Helpful
User profile for user: Green Lantern

Question: "Time Machine Backup Failed" since upgrading to Mojave