Previous 1 2 3 4 5 Next 67 Replies Latest reply: Mar 23, 2008 12:10 AM by skicolorado1718 Go to original post
  • BernieTheEvilF1Ruler Level 1 (0 points)
    My experience is that the iPod touch doesn't cope with WPA encryption.

    Since I got the iPod in October - I have had it successfully working on a network (Dlink DL 614+) with 128 bit WEP encryption.

    Having been recently advised about just how easy WEP is to hack - I changed my encryption to WPA - PSK. Other laptops and computers in the house in the house connected fine.

    The ipod connects - but it only every connects the first time. (eg: Load one page) - every subsequent attempt to access the web (Mail weather - another browser page) hangs - even though it thinks it has a valid Wifi connection.

    I find the only solution is to make it forget the wifi location - then redetect it again. But it does the same old thing - connects and only works once.
    Even the first successful load seems slower than it normally would - maybe the ipod lacks the grunt for the encryption?

    I'll change it back and see if it behaves again
  • Hibbsy Level 1 (30 points)
    Hi everyone,

    I have been having the same problems over the last few days. My ipod was showing an ip address starting 162.

    Just spoken to Apple and gone through the steps people mentioned here again and it didn’t work. An additional step is to switch off you router and switch back on, then reset the wireless settings on your ipod.

    This worked first time for me and now able to access the everything ok.

    Hope this helps you out!

  • Federico Consiglio Level 1 (35 points)
    a question ?

    how to connect to a wifi network with ipod touch with wep key #2 instead of #1. how can i choose key 2?
  • TonyTedesco Level 1 (0 points)
    dakota369 wrote:
    FYI - I have an older D-Link router and it does not support 128 bit WEP encryption and from what I have been told the iTouch (Apple) only supports the 128 bit WEP encryption. Resolution for me would be to update my hardware. This may answer some of the questions asked.

    REALLY? Is this new? Because I was using 64bit WEP encryption and the touch was connecting just fine, until a few weeks ago. Then it suddenly refused to connect. I tried changing to WPA-PSK and that didn't work. Then I went ahead and updated router firmware, changed several settings, put them back and nothing seems to work. Restored Ipod, etc etc etc. I need help.
  • SFJenn Level 1 (55 points)
    If you can connect to your network but safari cannot open a page as it can't find the server then do the following:

    Home - settings - wifi - choose the network with the checkmark next to it - you'll see a router ip address and a DNS ip address, if they are not the same exact address then x out the entire DNS address and input the ip address found in the router field as your new DNS ip address. If it doesn't work right away try turning iPod off then back on again.

    good luck

    Well I found an unlocked wi-fi spot, but it only has a DNS address.
    What can I do to have the itouch find the server?
  • faser dan u Level 1 (0 points)
    Thank you everyone that respoded to this page my touch said it was connected, it had the check mark, but it would not let me use any of the internet features. All i had to do was unplug my +Microsoft Broadband Networkig+ *Wireless-G Base Station MN-700*, for 15 seconds and i was good to go! Thank again everyone!
  • PurestDJ Level 1 (0 points)
    I've been having this trouble with my iPod Touch as well, and tried messing around with the IP/DNS business to no success...still getting full reception but no access via safari.
    I had been using the passkey on the back of the router but then tried the passkey from my MacBook Pro that can be found under System Preferrences/Network/Airport (you may need to change 'By Default Join' from 'Automatic' to 'Preferred Networks') then find your router, select it and click 'edit' then check the 'Show Password' box and use this password to access your router on your may seem obvious to some but it wasn't to me and it worked! I'm very happy.

  • skicolorado1718 Level 1 (0 points)
    I had the same problem. I have a Linksys wireless router model WRT54G version 6. installing the latest firmware fixed the problem.
Previous 1 2 3 4 5 Next