Previous 1 8 9 10 11 12 Next 167 Replies Latest reply: Jan 14, 2011 2:13 PM by lanahannah Go to original post
  • tclarkmd Level 1 Level 1 (0 points)
    For Windows, Validator can be a problem. See my other post above.
    Instead, validate your XML file with the free trial of Stylus Studio 2008 XML Editor:
    basic overview: http://www.stylusstudio.com/openxsdvalidation.html
    download: http://www.stylusstudio.com/xml_download.html

    Someone else above mentioned Cooktop http://www.xmlcooktop.com/ but I haven't tried that. It seems more complex than the stand alone Stylus Studio Editor at first glance.
  • Sergei Orlov Level 2 Level 2 (315 points)
    It works! All of a sudden it started working by itself, I did nothing. All I can think of is that I recently installed h.264 quicktime update, that's the only change I did to the computer. Perhaps, Apple did something to their servers. Too bad I had to delete so many songs with "non-compliant" names.
  • erickgrau Level 1 Level 1 (0 points)
    I have over 3TB of data and I've been trying since the Genius feature was released. It has never successfully completed. I've tried cleaning tag, weird characters in titles, reimporting music, etc.

    From the looks of it on this Apple forum, Apple developers have no clue or idea or else they would have said something....

    There is a plugin that is similar, but connects to Amazon Music library.. maybe I'll try that.

    SIGH

    Erick
  • Spencer Lewis Level 1 Level 1 (20 points)
    Having the same problem - I know Apple is aware of it - I received a call from them in September about it. They're silence on this is annoying especially since there have been two updates that haven't addressed the problem.

    Has anyone had any luck fixing?
  • Alphadad2 Level 1 Level 1 (0 points)
    I am not getting the 4010 error code but Genius is stopping in the first level gathering information. I suspect I have an xml file problem, but I can't find the library file on my XP computer. Can anyone tell me how to find the file and clean up my library characters so that it will be accepted by Genius? I have tried off and on for several days and it has never come close to working. I have about 950 tunes on a 3g iPhone. Thanks!
  • Stephen Barrante Level 1 Level 1 (105 points)
    I'm having this problem as well. I'm running iTunes 8.2 (23), and have yet to successfully setup the Genius feature. It gets by "Step 1", and on "Step 2", bails at the point where it says "Waiting for Apple to deliver your results"... and kicks up an error message:

    "Genius results can't be updated right now. An unknown error occurred (4010). Please tr again later."

    I tried getting some phone support from Apple, but they've totally given me the shaft and expect me to pay to fix their problems. It's one thing if I spill coffee on my keyboard, but it's bs if they think I'm going to give them $50 to troubleshoot buggy software. Just fix the problem, I'll post a solution, and get other people out of their hair. I'm pretty sure the $600 I've spent on iPhones in the past 2 years qualifies me for some level of "thank you for being a great customer" support. Jerks.
  • Spencer Lewis Level 1 Level 1 (20 points)
    Finally found an answer:

    Turns out there was an overriding issue with dead tracks for me. I suggest for anyone having this issue:

    - Turn Genius off - this will delete the genius results.
    - Download the iTunes script Super Remove Dead Tracks http://dougscripts.com/itunes/scripts/ss.php?sp=removedeadsuper
    - Install and run according to directions
    - Turn genius on

    Hopefully this fixes the issues. It did so immediately for me.
  • George Orthwein Level 1 Level 1 (80 points)
    Thanks, dead tracks were the problem for me too.

    I tried validating the xml but no problems were found. After I removed the 5 dead tracks I found, I had success.
  • Mike Wylde Level 1 Level 1 (0 points)
    Same problem in iTunes 9.0 except no dead tracks were found. Resolved by installing iTunes 9.0.1, though I never saw Apple acknowledge the issue in the bug fixes.
  • user_invalid Level 1 Level 1 (0 points)
    I've got the same problem in iTunes 9.0.2.25. Genius used to work a long time ago but not any more for some reason. I've tried validating my Library xml file but it was already valid. I've also removed all my dead tracks.

    Still I get the same problem. Has anyone found a fix for this yet? Genius was one of the main reasons I used iTunes
  • Jama22 Level 1 Level 1 (0 points)
    Okay, so I've gotten into the same problem as most people on this forum. I have a solid internet connection, I can access the iTunes etc., and I had trouble updating my Genius up until a day ago. I got the similar error message which said something like there was a network problem, the iTunes store is busy, etc. I've followed a few of the recommended tricks described on the posts here but none of them work, I would always get that error message at step 2.

    Well, after a few days of debugging, I finally figured it out. The error message is a complete lie, its probably a general error message to handle certain kinds of errors. There's nothing wrong with the internet connection, or your connection to the database.

    In fact, there's something wrong with the naming of your songs (and yes, I checked to make sure I had a "valid" iTunes Library XML beforehand, and that didn't work). I found out that one of the new songs that I added a few days ago was shortened so that it had only one '\[' inside it without a closing '\]' to match it. I removed the '[' from the song and tried to update my Genius again and it worked!

    Maybe this will help some of you guys who are in similar situations. If you have a gigantic library, well, you could try doing what I did. Clear out your library, and manually re-add your mp3s in small chunks, doing a Genius update after each. This is really time consuming but it'll definitely help you discover the problem mp3s

    That or someone could whip up a python script looking for all song titles containing the character '['

    Anyways, good luck guys, I know its a frustrating defect!

    Message was edited by: Jama22
  • user_invalid Level 1 Level 1 (0 points)
    Excellent Jama22, its nice to know whats causing this! Unfortunately for me my library is over 450GB so if anyone does find time to write some sort of script or fix (windows compatible) I would be forever in your debt.
  • Fake Kiwi Level 1 Level 1 (0 points)
    Just chiming in to say that I am also having the stupid 4010 error. I've tried validating my XML, zapping gremlins in text wrangler on my mac, I've closed all my ['s I've rebuilt my library multiple times, which is an absolute pain as my library is moderately big (125GB) I've uninstalled and reinstalled iTunes and nothing works on the PC or Mac, it would be great if apple would actually acknowledge the problem and make some sort of progress as I've been without genius for like 8 months now.
  • user_invalid Level 1 Level 1 (0 points)
    Still no fix to this?
  • cfrye Level 1 Level 1 (0 points)
    *I fixed the error in my library. Hopefully this will help you do the same*

    The day I was able to fix this was one of the greatest moments of my life. Ok, not really but it felt REALLY good.

    I have 30GB of music and now I can finally enjoy Genius playlists. Here's how I did it:

    I removed all files from my library and then ran "Update Genius". Then I started adding all of those the files to my Library in batches. After adding each batch, I would run "Update Genius". This worked flawlessly until I added one batch in particular and then I received that miserable error message.

    Then I removed all files from my library and sub-divided that problem batch into smaller groups. Then I re-ran Update Genius and started adding the sub-batches one-by-one then running "Update Genius" until I caused the error.

    *The root cause of my error was a special character in a Composer Name field for just one of my files.*

    Once I had this process, it took me about an hour to go through my 30GB of files and fix, but I had already spent 10 hours trying to diagnose the problem.

    What a pain!