Previous 1 2 3 4 5 Next 60 Replies Latest reply: Jul 26, 2009 1:40 PM by luvlabs Go to original post
  • simonsopinion Level 1 Level 1 (0 points)
    DO NOT, I repeat DO NOT update to 2.2 yet.

    I got a 2nd gen Ipod touch for Christmas, played with it all day yesterday and today...everything was working fine until I decided to update to 2.2.

    BIG MISTAKE.

    Now I'm stuck and nowhere to go, but wait for Apple to get a fix.

    The upgrade process corrupted my original software. NOw it wants a total restore, but the restore is not working.
  • CODERED23 Level 1 Level 1 (0 points)
    I have been working on getting my to work for a few hours tonight and finally got it to work on WPA. I kept entering my router password but what the iPod is asking for is the passphrase for the WPA. I entered this in and it worked fine. Hope this helps. If you are using WEP I would suggest trying your security key, not the router password.
  • Frostiegurl Level 1 Level 1 (0 points)
    I just bought the 1G touch and was having the same issue with not being about to connect to my home router. I went ahead and entered in the WEP security Key after trying everything else I can to connect. It worked perfectly and instantly. Thanks for the suggestion Codered.
  • slax03 Level 1 Level 1 (0 points)
    i found a soultion that worked for me after working on this issue for a long time. i turned off both my router and wifi on my ipod touch. i then went into general settings, then to network. the ipod at this point would not recognize my wireless signal in my house because the router was still off. i then turned on the wifi on the ipod. i then went into 'other' for connections, and basically retyped in my wireless account name and wpa2 password but did not connect it... it just left it there with the information on the screen. i then turned my router back on. once the router was sending a strong signal i then attempted to connect with the name and password i already had on the screen. and it worked... after hours of looking for an answer. hope this helps.
  • Timbo907 Level 1 Level 1 (0 points)
    i have the same problem with my 2g ipod touch running 2.2. my computer can connect to the internet but my ipod cant even find it sometimes! this really *****! please apple come up with a fix!
  • LadyAD Level 1 Level 1 (0 points)
    I need help...my wi-fi shows like it is connected, but I cannot access You Tube, Safari, etc., HELP PLEASE
  • simonsopinion Level 1 Level 1 (0 points)
    Reset your network as follows:

    Settings > General > Reset > Reset Network Settings

    This fixed my problem, hope it fixes yours.
  • cframes1 Level 1 Level 1 (0 points)
    I just called apple care and they informed me that 64 bit encryption will NOT work with the 2nd gen 2.2 software. Only 128 bit encryption is compatible with the new ipod touch. I have my doubts. has anyone else had any luck using 128 bit with the 2.2 software?
  • h1044 Level 1 Level 1 (0 points)
    I can not connect to a network that is set up with its wep key set up on wep key 2 how can I set up my Itouch to connect to this type of network orwill the wep key have to be set on key 1
  • h1044 Level 1 Level 1 (0 points)
    the I touch will connect on wep key 2 but you cant use the internet
  • luvlabs Level 4 Level 4 (3,610 points)
    cframes/h1044,

    If you can use WPA or WPA2 encryption with your router, use that. It's easier to implement and more secure.

    As to your connection or inability to use the internet...

    Go to Settings and open WiFi, tap on the blue arrow next to the network name and look at the settings. You should see your IP, the router's IP, the subnet mask, and the DNS settings. If you don't, try these in order:

    Turn Wifi off, wait a few seconds and turn it back on.

    Go back into the network information and tap DHCP, scroll down and tap Renew Lease.

    If you are still having problems, Settings > General > Reset > Reset Network Settings.

    If still not working, write back.
  • KendallAA Level 1 Level 1 (0 points)
    I'm having the same problem with my ipod gen 2 software 2.2 connecting to my 128 bit wep key router. Is there a specific format for entering the hex digits in to the ipod. Dollar sign or no dollar sign? All caps or no caps? hex numbers separated by a colon? I'm just reaching for straws. I've beat my head against the wall working on this. I can connect to wpa2 routers no problem and my older belkin "b" router will connect with out wep but the moment i turn on wep the connection dies. I have not seen any definitive comments about the format of the string. Could this be an issue?
  • JerseyMike78 Level 1 Level 1 (0 points)
    I have a 16G 2GEN Touch running ver. 2.2.
    Well I see lots of problems here. How bout this one? I can connect fine to my home network.
    But when I am out I cannot connect to open signals. I actually get a strong signal indicator.
    I get an ip address and subnet mask but no router numbers appear. So when I go into Safari I get
    "Cannot connect to the internet". Anyone have this problem? BTW this is my second Touch, I had worse problems with my first one and had exchanged it for this one. Also my sons 1GEN 8GB Touch connects fine to outside open networks.
  • adelaideviewer Level 1 Level 1 (0 points)
    Just one suggestion for everyone - I read this somewhere else.
    Please ensure that if you are trying to connect to a hidden network (ie: a secure SSID) that you type the name of your network exactly using the correct capitals and lower case lettering. I couldn't get mine to connect at all until I realised that my network name does start with a CAPITAL letter (the rest in lowercase).
    Once I entered it that way, everything was fine.
  • luvlabs Level 4 Level 4 (3,610 points)
    I don't use WEP but the HEX keys are usually in the format of XX:01:A1:...

    I would make sure you use capital letters and colons - just like it appears on your router settings.