Previous 1 8 9 10 11 12 Next 236 Replies Latest reply: May 24, 2015 4:09 PM by ShannynMurray Go to original post
  • Rob O\' Brien Level 1 Level 1 (15 points)

    for what its worth, i had same issue and managed to fit it. i say fix it but i didnt do much and it might be just in my case... hopefully this might work for some people before theyve gone and bought a new battery!

     

    my thing said "not charging", and the charger little light was staying green. but the i knew the laptop had 0% charge so it was purely green as it was just not charging.

     

    so, i shut down the machine, left the charger in it, showing the green light and left it a few hours. when i came back, the light was orange!!!! i think it was in some state of complete battery death that was hard to recover from.

     

    then once the orange light was on i could reboot and its back working fine now again.

     

    hope this works for some people at least.

  • markfromct Level 1 Level 1 (0 points)

    SIMILAR PROBLEM

     

    My MacBook will not run off the battery - or charge

     

    I replaced the battery. Now when the machine boots the battery icon indicates that it is calculating for a few minutes and then displays an X in the icon.

     

    I click on the icon at get the message that NO BATTERIES AVAILABLE.

     

    The battery is charged and I have reset the SMC, downloaded the updates, etc. - NO RESULTS

     

    From all of the disussion groups this appears to be a common problem.

     

    IS THERE A SOLUTION?

  • RC-CA Level 1 Level 1 (0 points)

    Hopefully this will work for you (I read this tip from someone on Amazon's reviews - thank you, George O!!):

     

    Make sure your power adapter is plugged in to your macbook and that you are logged in. Turn the macbook over and take the battery out. Insert battery in again. I did not put the mac to sleep or anything like that. It seems to be working for me

     

    Good luck!!

     

    P.S. I have a Macbook from early 2009 - have already installed the battery update 1.4 and I am running 10.5 because it seems that 10.6 Snow Leopard requires more hardware power and the battery's fan went crazy when I had Snow Leopard installed.

  • winterrose Level 1 Level 1 (0 points)

    I was definitely having this problem. I don't know for some of you, but the fix for me was very simple...

     

    I just ran a software update.

     

    Now everything is fine. No idea what happened, but I'm glad my battery is okay now.

  • John Gruver Level 1 Level 1 (35 points)

    Well, mine is a 2006 2.33GHz 17" MBP. Same problem with a few adders. With a NewerTech battery (original died with several hundred cycles) that has 68 cycles on it. My battery menu shows power connected and (Not Charging). If I disconnect the power cord the MBP shuts off. The battery is being seen by the MBP... it shows it has 86% charge.

    Even more troubling to me than the loss of the battery use is that I seem to have lost the continuity from one session to the next. Icons disapper to be replaced with grey question marks. Mail opens every restart despit deselecting the Lion "Reopen windows when logging back in" radio button. Access to manipulate documents and folders is denied to me (the only user and admin) without entering my admin password despite their permissions being correct. Some documents and folders have an "extra" everyone user in the Sharing & Permissions window. The extra is on the top of the list, has "Custom" Privelege, and cannot be modified or deleted... Grrrrrrrr....

    Oh, I've tried every suggestion here, no joy.

     

    Manufacturer:          NewerTech

      Device Name:          ASMB014

      Pack Lot Code:          8641

      PCB Lot Code:          1a20

      Firmware Version:          ff14

      Hardware Revision:          000c

      Cell Revision:          00c8

      Charge Information:

      Charge Remaining (mAh):          5119

      Fully Charged:          No

      Charging:          No

      Full Charge Capacity (mAh):          5952

      Health Information:

      Cycle Count:          68

      Condition:          Normal

      Battery Installed:          Yes

      Amperage (mA):          0

      Voltage (mV):          12178

  • muralha Level 1 Level 1 (0 points)

    Sharing my recent experience...

     

    I was having the same problem with the Replace battery/0% charging issue on Lion, so no battery updates to fix it...

     

    I've tried steps 2, 3 and 4 ("Before Resetting the SMC") from http://support.apple.com/kb/ht3964

    1. go to sleep mode and wake up ... no luck
    2. restart the Mac ... no luck
    3. Shutdown...

     

    • Shutdown the MacBook, see the battery lights... it's charging (it had 2-3 light on the battery in "bugged" mode)

     

    So I've decided to try booting up with only the battery...

     

    • Removed the MagSafe power connector
    • Waited until the charging lights on the battery, disappeared
    • Clicked on the battery button to see the number of lights (I don't recall if the battery light numbers were 4-5, but...)
    • While the battery lights were on or off (I don't recall it, probably off)...
    • I've started the MacBook, without the MagSafe connector
    • Clicked the battery button and ... 4-5 lights on the battery, like I had before! Sweet!!!
    • After boot up... 90% battery!! Perfect!

     

    Right now, I'm charging the battery on Lion.

    ... Green Light on the connector! :-)

     

    I'll post if anything changes in the next days.

  • ibby786 Level 1 Level 1 (0 points)

    I have the same problem. I left it for about 2 weeks, after that, it didn't work.

  • jcnwillemsen Level 1 Level 1 (0 points)

    Went on a holiday for 5 days, so my batery probaly drained. Now " not charging" + no lights on the battery.

     

      Model Name:          MacBook

      Model Identifier:          MacBook2,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2 GHz

      Number Of Processors:          1

      Total Number Of Cores:          2

      L2 Cache:          4 MB

      Memory:          2 GB

      Bus Speed:          667 MHz

      Boot ROM Version:          MB21.00A5.B07

      SMC Version (system):          1.17f0

     

    Coconut:

    age of your mac: 52 months

    load cycles: 1223

    current load/max load :-1 mAH

     

    Any tips? tried the sms reset ( btw do you see anything if it is succesfull? any message?) with no result. Is the battery gone? ( I guess im lucky with 1000< cycles?

    Thanks a bunch!

  • Britvox Level 1 Level 1 (0 points)

    I've had this problem constantly since I bought my MacBook in 2007. I'm now on my 5th or 6th replacement battery. The Genius Bar people have been good about this. They've replaced the dead batteries without question The last time they finally decided that the problem must lie elsewhere and so replaced the battery and the motherboard for no charge. However, after only 83 cycles the battery had again died. Off to the Genius Bar again next week. It'll be interesting to see what they say this time.

     

      Model Information:

      Serial Number:          SMP-ASMB016-3d2f-39d

      Manufacturer:          SMP

      Device name:          ASMB016

      Pack Lot Code:          0000

      PCB Lot Code:          0000

      Firmware Version:          0110

      Hardware Revision:          0200

      Cell Revision:          0102

      Charge Information:

      Charge remaining (mAh):          0

      Fully charged:          No

      Charging:          No

      Full charge capacity (mAh):          4870

      Health Information:

      Cycle count:          83

      Condition:          Good

      Battery Installed:          Yes

      Amperage (mA):          0

      Voltage (mV):          8875

  • LexSchellings Level 5 Level 5 (6,890 points)

    Hi Willemsen, your battery is way over its life expectancy!!! 1223 cycles is more than the 600 expected for your mac. I am afraid that you have to buy a new battery. And I advice you to buy an original Apple battery, because some third party batteries are no good.

    Lex

  • Ahrum Pilendiram Level 1 Level 1 (0 points)

    Macbook Pro 2.66GHz Intel Core 2 Duo (13" Mid 2010 model)

    10.6.4

     

    Icon showing "not charging" with MagSafe led permanently on green

     

    My 'fix' was as follows:

     

    Whilst fiddling about changing the Battery Icon 'Show' setting (right click on the battery icon) I unplugged the MagSafe connector. This in turn shut the laptop down as there was no charge in the battery. On plugging the magsafe back in and hitting the power button the machine rebooted. I had expected the machine to be in the sleep mode that it goes into when the battery runs out rather than actually shutdown. On starting up this time the MagSafe led was on amber and baterry icon now showing charging as normal.

     

    I had previously tried many things suggested in this thread and I am fairly sure this 'fix' was pure luck but it might be worth trying.

     

    Good luck.

  • zale74 Level 1 Level 1 (0 points)

    Unbelievable!  This just worked for me too. 

     

    After attempting to use my MacBook today, after a 3 week break, the Magsafe adapter had green light on but wasn't charging.  Fiddled as you did with the battery icons, pulled out the adapter, MacBook turned off immediately.  Then when I plugged the magsafe back in and hit the power button, hey presto the light went orange and it is now charging! 

     

    It says 11:09 hours till full charge - fingers crossed it actually charges.  The hours are now dropping off the charge time and it's down to about 2 hours.  I'll be keeping a very close eye on it to see if the % of charge actually goes up or if it's just messing with me.

     

    Thanks for the help

  • pamelyn Level 1 Level 1 (10 points)

    John I'm having the exact problem you are... Same Computer Model, same year... replaced with Newer Tech battery 10 mos ago. Have NOT had the continuity issues. But I'm using Snow Leopard. Don't have much loaded on the computer. I got a new MBP recently and gave this to my husband so he can log onto his work computer and he uses windows. Just erased the entire drive reloaded fresh system then used boot camp to install windows. All was well till yesterday when the "not charging" message showed in the Menu Bar. I've tried all the fixes listed here, (and then some) too. Where are you now in your search? Any fixes?

     

     

    Battery Information:

     

      Model Information:

      Manufacturer:          Newer Tech

      Device name:          ASMB014

      Pack Lot Code:          0001

      PCB Lot Code:          0021

      Firmware Version:          0010

      Hardware Revision:          001f

      Cell Revision:          7a3e

      Charge Information:

      Charge remaining (mAh):          2663

      Fully charged:          No

      Charging:          No

      Full charge capacity (mAh):          5946

      Health Information:

      Cycle count:          51

      Condition:          Normal

      Battery Installed:          Yes

      Amperage (mA):          0

      Voltage (mV):          11437

  • Robfrombc Level 1 Level 1 (0 points)

    My old battery stopped working a while ago and I just bought a new one but it wont charge either.  I may get the battery charging indicator for a bit then it turns off and I get the x over the battery.

    Battery Information:

     

      Model Information:

      Serial Number:          XXXX-YYYY-0-0

      Charge Information:

      Charge remaining (mAh):          0

      Fully charged:          No

      Charging:          Yes

      Full charge capacity (mAh):          0

      Health Information:

      Cycle count:          0

      Condition:          Good

      Battery Installed:          Yes

      Amperage (mA):          0

      Voltage (mV):          0

     

    System Power Settings:

     

      AC Power:

      System Sleep Timer (Minutes):          10

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          5

      Automatic Restart On Power Loss:          No

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Wake On LAN:          Yes

      Display Sleep Uses Dim:          Yes

      Battery Power:

      System Sleep Timer (Minutes):          5

      Disk Sleep Timer (Minutes):          10

      Display Sleep Timer (Minutes):          1

      Wake On AC Change:          No

      Wake On Clamshell Open:          Yes

      Display Sleep Uses Dim:          Yes

      Reduce Brightness:          Yes

     

    Hardware Configuration:

     

      UPS Installed:          No

     

    AC Charger Information:

     

      Connected:          Yes

      Charging:          Yes

  • kkimmel30 Level 1 Level 1 (0 points)

    Have similar problem. My Macbook battery wont charge. I have to keep it plugged in to run. I tried to use a known battery that works from my other Macbook which is the same. I get the same problem. I have to keep it plugged in to start & run. Once i unplug it. The Macbook shuts off. Any suggestions or solutions please let me know. Thanks.

Previous 1 8 9 10 11 12 Next