Previous 1 2 3 4 5 6 Next 86 Replies Latest reply: Jun 18, 2010 12:03 AM by Maurice Kennedy1 Go to original post
  • switcher98223 Level 1 (15 points)
    I am seeing the same issue. It appears to be limited to my 20" iMac (model from June 2007).
  • Terence Devlin Level 10 (136,700 points)
    Some folks have had success dealing with the issue by deleting the following plist files,

    From your HD/ Users / Your Name / Library / Preferences folder.

    (Remember you'll need to reset your User options afterwards. These include minor settings like the window colour and so on. Note: If you've moved your library you'll need to point iPhoto at it again.)


  • switcher98223 Level 1 (15 points)
    Nope. No help here.
  • brandgoose Level 1 (0 points)
    Same problems. Just removed the prefs. Is a little bit better now. Glad I'm not alone. Waiting for an update.
  • Phil Knight @ work Level 1 (0 points)
    I have had the same experience, with some further remarkable features.

    The "red Eye" and the "retouch" tools are really random effect generators. Click on one of them and the photo might zoom, or it might be truncated to 2/3 its size, or it might rotate 180 degrees, or it might disappear, or it might do any combination of the above.

    And while it is at it, it may or may not correct the red eye or effect the re-touch, with about equal probability.

    As a casino game, it might be fun; as a device to expose my photos to, it is way too risky.

    Why is it that every time Apple 'upgrades' iPhoto, it results in less reliable performance?

    OK, When I installed Snow Leopard, iPhoto (from ilife 09) immediately became a nightmare, turning into the slowest application I have experienced since my first mac in 1984. And it crashed my iMac about 30 times in one evening - not just iPhoto, the whole shebang - I got the grey window shade screen of doom.

    Someone advised me to search and remove every copy of any iPhoto library I had ever had, except the current one. I did that, backing them up to an external drive, and erasing them from my computer.

    That significantly improved iPhoto's behaviour.

    Until I tried to remove some red eye from a photo.

    So, I ran a test - exporting two of the problem photos to a brand new MacBook Pro, importing them to iPhoto and trying again.

    iPhoto in that configuration has the same propensity to please gamblers, and disappoint anyone who values predictability and certainty of result.
  • Old Toad Level 10 (133,360 points)
    Welcome to the Apple Discussions. Did you try an of the fixes previously suggested in this topic? That is delete the iPhoto preference file and rebuild the library?

    Are you able to create a new library, import some photos and edit normally? If so then it's a damaged library. If that's the case and a normal rebuild doesn't help use iPhoto Library Manager to rebuild the library as follows:

    Using iPhoto Library Manager to Rebuild Your iPhoto Library

    1 -Download iPhoto Library Manager and launch.

    2 -Click on the Add Library button, navigate to your User/Pictures folder and select your iPhoto Library folder.

    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File->Rebuild Library menu option

    4 - In the next window name the new library and select the location you want it to be placed.

    5 - Click on the Create button.

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be untouched for further attempts at fixing or in case the rebuilt library is not satisfactory .
  • hoyhoy Level 1 (0 points)
    I'm seeing weird issues with editting as well on iPhoto 8.1/Snow Leopard. Edits aren't persisting sometimes and if I edit anything any wider than 8000 pixels, the image gets cut off and everything to the right of 8000 pixels is entirely black.
  • Alex Head2 Level 1 (5 points)
    Same issues here- not the distorted pictures, so much as the blank editing box. All else appears normal, but pictures don't show up in the main screen when trying to edit. Happening since upgrade to Snow Leopard.
  • kygol Level 1 (0 points)
    Just updated to the SL 10.6.2 ..... no difference with the iphoto edits unfortunately. Apple becoming the new MS?
  • brandgoose Level 1 (0 points)
    Here too, still the same green and/or red screen.
  • Old Toad Level 10 (133,360 points)
    Have you tried applying yesterday's system update: Mac OS X v10.6.2 Update (Combo)? That may do the trick.

  • brandgoose Level 1 (0 points)
    Not the combo, did it via software-update.
  • Old Toad Level 10 (133,360 points)
    If you went from 10.6 to 10.6.2 I'd download and run the combo installer just to be on the safe side. The combo installer will include all that's in the previous installers for that system version but the standard installer will not.
  • soulmanbdr529 Level 1 (0 points)
    I've got the distortion when editing photos too. I'm rebuilding my library now with iPhoto Library Manager, and downloading the OSX update. And I sent some iPhoto feedback telling Steve Jobs I would throw myself off a building if he didn't get it fixed soonl. Thanks for the tips.

    I've also noticed the green monster distortion in iMovie. Not when editing, sometimes it just shows up on my thumbnails even when I have done nothing to it. The video plays just fine though.
  • Maurice Kennedy1 Level 1 (5 points)
    I just installed the combo update to try and fix this. Guess what? It didnt. I have had my MacBook in at the Genius Bar twice before I saw this discussion and the Genius Bar in Sydney didnt have a clue.
    All they did was reseat the ram twice. I'm going to Thailand next Tuesday intending to take this MacBook to process photos along the way to post online. That will obviously be a waste of time.
    I'm very unhappy with this. Not a very  experience at all.

    I may very well join you in jumping off that building at the moment!