Previous 1 3 4 5 6 7 Next 97 Replies Latest reply: Jun 11, 2014 1:54 PM by Billsid Go to original post
  • Barry McGlashan Level 1 (5 points)
    Sorry for my ignorance Miguel, I don't understand this fix.

    What is a terminal window and how do I open it? I am having the same problem everyone here is describing and it's been going on for days. I can access my email online at Sky but my mac email is effectively useless. I get the 'recovered message' thing constantly and it is stopping all other mail from coming through. As you may have guessed, I'm not very computer literate and I'm looking for help!

    Anyone out there able to help me get this solved? I must admit, I really expect more from a mac, I hope apple fix this problem soon. Thanks, Barry
  • Barry McGlashan Level 1 (5 points)
    Sorry - can anyone give me some pointers on how to fix this problem? I'm the same for 4 days now, repeated recovered messages after I sent an email with 25MB of jpeg attachments. It's stopping all mail coming in so I'm having to use my online mail account but after buying a brand new iMAC I'm disappointed that this doesn't seem to be being addressed by apple. Any help very much appreciated...
  • Ocean Digital Level 1 (0 points)
    Drew Milwaukee wrote:
    I just spoke with Apple and they provided me with a solution that worked.

    In Mail preferences, choose the IMAP account that is having the problem and choose Mailbox Behaviors. Uncheck, Drafts so that they are NOT stored on the server. Save changes to these preferences.

    Problem Solved!

    Thanks Drew. So is this Apple's official fix "don't use Drafts on IMAP"? Personally, I want all my folders on the server, its kind of the whole point of using IMAP.

    Manually clearing a cache seems like B.S to me. is deeply integrated into the OS and since we depend on it we deserve some clarity.

    Message was edited by: Ocean Digital

    BTW, why don't these messages just stay in the Outbox until its delivered properly?
  • RyukSalce Level 1 (0 points)
    I had the same problem, I just removed my account from Mail's preferences, then signed up again. It seems to have stopped recovering, for now...
  • Iron On Ghost Level 1 (0 points)
    yeah I just tried that solution... it doesn't work for every instance of the problem I suppose because it didn't work for me.
  • JimPennnnn Level 1 (0 points)
    OK, Since I couldn't make any of the previously explained fixes work, I started making some changes in Mail>preferences that quickly and easily solved the problem.

    in Mail>Preferences>Accounts>Advanced

    "Keep copies of messages for offline viewing"
    In the dropdown menu choose
    "Don't keep copies of any messages"

    save changes. Quit mail. restart mail. Problem solved.

    That apparently cleares the offline cache. It definitely solved the problem for me. After restarting mail, I rechecked "keep all messages and their attachments" and everything is back to normal, working just as it should be. No more phantom messages or problems of any kind.

  • tswiers Level 1 (0 points)
    I had the same problem and fixed it.

    I had tried to send a 57MB file in Mail and it said it exceeded message size and asked if I wanted to try another server or send later. after that Mail continued to try to send this message and it also duplicated in Recovered messages. I could not Receive mail after this.
    Here is how I fixed it....

    1. I deleted the hidden folder .OfflineCache" at the following path: "~/Library/Mail/IMAP-@domain.tld@imap.domain.tld/.OfflineCache

    2. I deleted the "Recovered Files" Mailbox folder at "~/Library/Mail/Mailboxes/Recovered Messages ([Gmail Account Name]).mbox

    3. restarted Mail and it worked!
  • georgeny Level 1 (5 points)
    Miguel Lira wrote:
    If you're experiencing the "Recovered Messages" issue it may be related to offline processes that are failing when you open iMail. For me the fix was to open a terminal window and delete all the files in the following folder: ~/Library/Mail/

    Hope that helps.

    Miquel, I too had similar program and your fix worked perfectly thank you. The only difference I employed was instead of going through terminal window I simply did it through finder trashing the entire IMAP folder for the offending account. First email through offending account restored IMAP folder and no further problems.

    Thank you
    George in NY
  • jai309 Level 1 (0 points)
    Thank you Ernie, your advice seems to have solved my recovered messages that were propagating in my Mail. I removed the said file in Library/mail and then removed my gmail account and then replaced it. So far so good.
    Jai 309
  • Scott Crawford Level 1 (0 points)
    A friend also had the same problem with New To Do file endless propagating in Mail, meanwhile it stopped downloading mail from his IMAP server. Followed this fix and the Recovered folder no longer appears and mail has resumed downloading normally. Thanks!
  • WiseJD Level 4 (1,630 points)
    OMG, I just tried three of these solutions and it took me about 2 hrs. to get Mail back in sync. between the server and my iMac. My original issue like others related to trying to send a too large of file via email. Then I could not receive mail and the application just kept working and working. I changed my preferences and then watched as all of my saved mail appeared to go away (not a good thing). I then changed my preferences back and it took about two hours to sync. all of the server files and the cache files with my computer.
  • WiseJD Level 4 (1,630 points)
    I have a little more time to explain what actions I did take to get Mail working again. The initial problem with my Mail application was due to my attempting to send an attachment file that was larger than Mail will allow. I received a pop-up message when I depressed "Send" that told me the attachment was too large. I deleted the message and thought that was the end of that. However, then I noticed that the little "activity" indicator shown next to this specific mailbox inbox just kept "working". Then it occurred to me that no new mail was arriving at that inbox. I selected the pulldown menu that showed graphically all of the "activity" in my Mail application and noticed that my Mailbox #2 was behaving normally but that the problem mailbox was stuck trying to do something with the deleted message or cache. Then I started reading these boards and found this thread.

    I read about using a "Terminal Window" to delete the hidden file for deleted cache, however I had no idea how to open a Terminal Window. I opened finder and worked my way through the appropriate folders but I
    couldn't find out how to "Show" the hidden file. As such I couldn't delete it that way. Then I read about going into the Mail Preferences for the specified account and changing the options under the Advanced pull-down. When I changed the option about no longer saving things on the Server, Mail instantly got rid of my Sent mail and my Saved mail. At that point I closed and re-opened Mail and looked at the "Activity" graphical window seeing that it looked like my "stuck" mailbox was fixed.

    I however, was in a panic due to the apparent loss of my Saved Mail. I went back into the Mail Preferences and changed my preferences back the way they had been before all of this. Then I closed and re-opened Mail and spent just under Two Hours watching Mail rebuild my Sent and Saved Mail folders. Just when I thought I was back in business, I did a "Test" email from my now repaired mailbox to my other mailbox and things looked great until I deleted the Test Message. At that point I noticed Mail had to rebuild my Trash folder, which it did.

    As another important note about all this, I did go on another computer and found out that on that computer my Sent and Saved Mail was always OK. That did take the panic down a tad.
  • Harmen Utrecht Level 1 (0 points)
    Problem: Mac mail keeps recovering same messages over and over again.

    Easy Solution:
    Go to Mail Preferences.
    Select the mail account involved.
    Go to tab Advanced.
    Under "Keep copies of messages for offline viewing" select "Don't keep copies of any messages".
    (Don't worry, they are still on the server.)
    Close preferences.
    If needed: Delete the problem messages from the Recovered Message folder.
    Close Mail.

    Problem fixed.

    If you want, go back into Mail Preferences and reset the choice back to "Keep messages for offline viewing".
    Then, everything will be back the way it was, but the problem messages won't come back.
  • Pickles12345 Level 1 (0 points)
    I just wanted to tell you how thankful I am for your help! I've been without mail for days and yours is the only thing that fixed my problem... thank you
  • mskavara Level 1 (0 points)
    Oh God! Thank you guys so much. I've been trying to fix this bug all day!

    Message was edited by: mskavara
Previous 1 3 4 5 6 7 Next