Previous 1 19 20 21 22 23 Next 342 Replies Latest reply: May 16, 2014 12:10 AM by BobAalsma Go to original post
  • Bengt77 Level 1 Level 1

    I have a very similar problem that's driving me nuts. I'm getting mightily desperate, to be honest. I have to solve it for my peace of mind before I can do anything else. And that is while it's a beautiful day outside. Man, this blows. Anyways, here goes...


    In the meter cupboard (if that's even a word) I have an AirPort Extreme base station (simultaneous dual band). In the living room I have an AirPort Express to which an HP Color LaserJet CP1515n is hooked up. Yesterday I decided to move the AirPort Express a little, so that I'd get better reception further back in the house. The USB cable with which the printer was connected to the AirPort Express was a tad too short to reach the new spot, so I used a different, longer cable. I also changed the AirPort Express from extending the b/g network to extending the a/n network. No big deal, I would say.


    But lo and behold!


    Today my printer isn't working anymore. It used to work beautifully before moving the AirPort Express. Yes, I have since tried going back to extending the b/g network. And yes, I have checked the cable. When directly hooked up to my MacBook, the printer works perfectly fine with that same cable. The cable is also fine for reliably connecting external hard drives to my MacBook. Weird, isn't it?


    However, when connected to the AirPort Express the printer fails miserably. It goes into paused mode with the following message: "Unable to write print data: Broken pipe". Extremely annoying! The printer starts flashing its activity light, but nothing happens. I have, on some occasions, seen the printer software not generating this message and still not printing anything, all the while endlessly flashing its activity light. What the heck?


    I'm absolutely flabbergasted that to this day no person seems to have found a universally working solution to this type of problem.


    Where did this issue come from? For me, it was all working beautifully just the other day. I just don't understand! Any help is greatly appreciated.


    For completeness' sake, here are some specifications:

    • Computer: MacBook model 5,1 (2,4GHz C2D / 4GB RAM)

    • Operating System: Mac OS X 10.6.8 (did the update today)

    • Printer: HP Color LaserJet CP1515n

    • Driver Version: 10.4

    • Firmware Version: 20110413

    • PPD File Version: 17.5

    • CUPS Version: 1.4.7 (cups-218.30)

  • jlll Level 1 Level 1

    Thanks longamide, it worked!!

  • Arni Ing Level 1 Level 1

    Hi, I've a problem with another type of HP printer so I wonder if it's ok that I post my problem here because it's seems that here are the solutions.

    Anyway my problem is that I've HP LaserJet P1005 connected to Airport Extreme and the Airport doesn't detect the printer at least it doesn't appear on the printer tap in the Airport Utility for the Airport Extreme. I'm only using PC computers. Can somebody help me with this problem?

  • Hugh Browton Level 1 Level 1

    Hi Andrew –


    Working on the principle that this still hasn't been solved:




    Does My Device Work: Partially - it usually prints only odd numbered pages of a multi-page document, but it always prints any document sent to it - so I send mostly one-page documents to it!


    Product Name:               HP LaserJet 1022nw
    Formatter Number:          JN06GB0
    Product Serial Number:     JN06GB0
    Service ID:                        07088   
    Firmware Datecode:          20050401
    Total Memory:                    8 MBYTES
    Total PCL Memory:          2.5
    Available PCL Memory:     1.8


    Ethernet connected to a 3Com 24-port hub, to a 3Com ADSL router, Macs are running a mixture of OS X 10.4, 5, and 6 (Haven't tried with a 10.7 yet).



  • clevec Level 1 Level 1

    Hi guys,


    I managed to get my HP 1020 printer working using a MBA Mac OS X Lion via network with Time Capsule's Airport.


    Go here and install this latest set of HP Drivers for Mac OS X including Lion:


    Then, go to Print & Scan Utility to add the Printer "HP LaserJet 1022" driver.




    Now, I am trying to get my Windows XP laptop to print to HP 1020 via Time Capsule Airport; to no avail yet.

  • sealone Level 1 Level 1

    HP Mac Arichitect, you may be the only person who can help me as numerous google searches have directed me to multiple solutions from you. I have been at this all day and I'm pulling my hair out!! I have an HP Photosmart C6280. I added it to my Time Capsule (4th Gen) via USB. The first time I added it it actually printed. I then attempted to add an airprint function to it via AirPrintActivator to print on my iOS and that potentially screwed everything up.


    That said I have since deleted everything including all previous HP software in addition to the AirPrintActivator. Everytime I try to print using the Time Capsule my printer times out. I have it connected, the printer says "now printing" but then the que pauses by itself never to successfully print.


    What I have done: open system preferences/print&fax/+(add printer)/HP Photosmart C6200 series bonjour

    I have even added the printer via IP using HP JetDirect - Socket the Time Capsules IP ( etc.

    Uninstalled/Reinstalled HP software currently: HPPrinterDrivers2.8

    Installed Linux based systems: foomatic-rip-     gplgs-8.71.dmg    hpijs-3.10.6.dmg

    Hard reset the Time Capsule etc etc etc..


    I am at a loss. Seems like the solution is very simple as it worked perfectly the first time before I added the AirPrintActivator software. Please help, it would be greatly appreciated.

  • sealone Level 1 Level 1

    I am having the same issue- "broken pipe". ***. I feel your frustration. I have been at this all day. Please let me know if you have found a solution and I'll let you know as soon as I find one as well. Good luck.

  • sealone Level 1 Level 1

    Now my printer is giving me a new message


    "Unable to send 1024 bytes of print data! (USB write error)"


    "Communication Failure: The computer is no longer able to communicate with your printer. Turn the printer off, check your printer connections and check for printer errors, and turn the printer back on."

  • RubaRuben Level 1 Level 1



    If someone has problems with HP Laserjet 1022 this it what I did to fix it ("on hold" status all time...):


    Download and install this driver


    Go to, for example, word office and try to print. When selecting a printer, add a new one and choose Hp laserjet 1022. It is stupid.. But it worked!


    Best regards

  • a brody Level 9 Level 9
    Classic Mac OS

    Sorry to threadjack this thread, but someone desires your help HP Mac Architect in another thread:


  • Moscool Level 1 Level 1

    Got so frustrated with the whole story, including installing *new* drivers that don't work that I literally threw away this awful printer and purchased a Canon replacement.

  • arkling Level 1 Level 1

    I've been getting the error "Unable to write print data: Broken pipe" when I try to print.



    * Mac Mini Server (Mid 2011)

    * OS X 10.7.3 (Lion)



    * HP Color LaserJet 2024DN

    * Connection: Ethernet  (Bonjour / TCP/IP )



    Things I've tried:

    * Resetting Printing System in (Print/Scan System Prefference)

    * Rebooting the computer

    * Reinstalling HP Print Drivers ( )

    * Repair Disk Permissions

    * Killing / restarting the cupsd process



    I'm getting pretty frustrated...does anyone have any thoughts on this?


    Thank you!

  • Ryu01 Level 1 Level 1

    That's really strange: Having the same problems as everyone with my LaserJet 1022 on my Macbook Pro (with Snow Leopard 10.6.8) for about a year, today i found this driver on the hp site:



    And... it seems to work. No errors or crashes, the pages are printed fast and with all the text. But I'm still sceptical about it, so can you guys please try it out and tell me that i'm not dreaming?

  • markus. Level 1 Level 1

    Thank you longamide,



    essentially using your instructions (on Feb 9th, 2011) I was able to get my HP Laserjet 1022 to print in manual duplex mode using Mountain Lion (OS X 10.8.1.):


    1) installed Gutenprint v. 5.2.9. (


    2) installed the HP Two-Sided Printing Software ( &lc=en&dlc=en&cc=us&os=219&product=5038006)


    3) Chose 'two-sided printing' from the 'PDF' pull-down of the printing dialogue, ticked the box for printer training and trained the printer.


    And so far all my documents have printed exactly as I they should. Thank you once more, longamide!

  • apfelowner Level 1 Level 1

    Was frustrated by this one for a couple of years and almost abandoned the entire idea. Recently re-installed SL on my old MB at home and had to get back to this issue (wife's using it and demanded a working printer!).


    I've got SL 10.6.8 on an old 13" MacBook (black plastic body) and HP1022 (Q5912A). I didn't have any luck with either that old HP driver (from 2006) or the very latest shipped with SL updated (1.4.0). My printer would just print the first page and go blinking wild.

    So I've downloaded and installed that HUGE package from


    Version: 2.12

    Post Date: Oct 11, 2012

    Download ID: DL907

    File Size: 439.55 MB


    And then I deleted and added HP1022 back again but with "HP LaserJet CP1022, 2.0.20120620" driver (you can pick it when adding printer from that "Print Using:" drop option list.


    I actually didn't have much hope - but it worked!