Skip navigation

I get "error code 0x80020022" when I try to write to disc.

104554 Views 181 Replies Latest reply: Mar 18, 2014 2:31 PM by krbusby RSS Branched to a new discussion.
  • Brandon P Calculating status...

    Sadly, I have been experiencing this problem with CD-R discs since 2008.  I have had random success with blowing out the drive with compressed air, resetting my SMC controller and using an external drive, but none of this has consistently or permanently fixed the burning issue.

     

    It is depressing that this hasn't been fixed, and doesn't appear that it ever will be.

  • Paul L UK Calculating status...

    Well I've got an update as well, the 2nd new drive I had has after initially working albeit with having to use canned air to clean our regular (as MBP seems to suck in more dust than a vacuum cleaner) has now failed again and funny enough after I upgraded to Lion.

     

    But I can get it to work by using 2x speed and by using DVD-R only discs, if i try with DVD+R or even ones which state DVD-R & DVD+R then usual error. Now this new drive has had very little use and like the previous drives it seems to have a lifespan according to the OS upgrade.

     

    Thing is dust is def. an enemy to this Macbook through its unibody design and not having enough air vents to pull air in other than through the DVD slot adn port slots and if you run performance mode so that the video card fans are pretty much on constant seems to be every month needs a good clean out

     

    Also had problem with my card reader other day saying that it couldn't write to one of my cards, so did trick of canned air and lots of dust blew out and afterwards has been working fine.

     

    I'm not going to bother with getting another one of these drives as rediculas pricing when you can buy an external USB for 1/4 of the price.

     

    So is a combination of something getting pushed either to motherboard firmware or firmware of the drive during upgrade that then bricks it.

     

    I'll still stick with Apple but only as I love OS-X  but I'll be getting an iMac come next upgrade no more portables as they seem to be the weak link. My sister has been running an iMac of similar age to my MBP and not once has her drive (different make) failed or given rubbish error messages even burns the media mine says is incompatable at 16x.

  • .:SiLo:. Calculating status...

    PLEASE PLEASE PLEASE

     

    Try a borrowed external CD/DVD burner on your system before buying one.

    I have posted may times regarding this issue on several threads.

    When upgrading from Tiger to Leopard years ago, I lost the ability to burn.

    This included when booting to another OS (Windows XP) and using external burners.

     

    Read on for an (proposed) explanation as to why this happens.

     

    //////////////////////////////////////////////////////////////////////////////// ///////////

     

    The problem has to do with EFI:

     

    Drastically over-simplified, the EFI is the new version of what BIOS used to do.

    EFI is a part of permanent memory on your mtherboard that is 'booted' before an OS is loaded.

    It is essentially a set of instructions that sets up how your system bus communicates with other parts of hardware.

    In this case - CD/DVD drives.

     

    I am convinced that there is a fundamental problem with how Apple updates the EFI. This could be because there are hundreds, if not thousands of possible hardware configurations and the EFI cannot be written to account for every single one of them. Or, the flashing process is volatile and perhaps corruptions occur (the old EFI table must be patched, I think, and then written to the new EFI table).

     

    At any rate, Apple has not said anything about this for years. They definitely know the problem - there is no question about that. I believe that they are not answering because it would acknowledge a vunerability to their OS upgrade process that is not fixable. That could mean recalls, or free repairs that would be incredily costly. I believe that their strategy at this point is to wait until CD/DVD drives are phased-out (give it 2 more years until all Apple laptops no longer have one) and the problem will simply go away.

  • Paul L UK Level 1 Level 1 (0 points)

    External burner I had tried worked fine, a friend who has official apple one for his mini. Although I'm not going with that as still double the cost, but if the one i get doesn't work then can return within 30 days and exchange/refund policy.

     

    Thing is the external is running over USB, so that could be the key as to why it worked as I suspect if I just replaced the internal then may still get same issues, but previously (2 times) when this has happened a new drive fixed the problem so perhaps it is just the drive firmware, but too expensive to try that theory out.

     

    Agree when DVD is phased out and flash sticks cost the same as dvd media then i too can drop them, but I have to be able to send my artwork to printers and with a DVD I can send it to them and not then worry about getting it back otherwise I would just use SD cards and flash sticks.

  • .:SiLo:. Level 1 Level 1 (0 points)

    Agreed - DVDs should die out, but we are a little more progressive about that than most others!

    Physical (disposable) media should die out in general. SD cards are nice, but still wasteful given that storage space doubles every 6 months or so. Try and sell a 1GB SD card on eBay and you'll see what I mean.

     

    I used to deal with files that were about 5 to 10 MB. Now my files are typically 10 MB to 100 MB. That has happened in the lifespan of my 2008 MacBook Pro 15. I expect that same factor in the next 3 years, where 100 MB will be a small file. I have also gone from 2GB RAM to 8GB RAM and 250GB HD to 1TB HD.

     

    My next laptop - no CD/DVD, and 2 hard drives: 1x 500GB SD drive (System), 1x 1TB HD drive (Data & emergency boot partition); cloud or direct upload for client/supplier data (ie: presentations, printing, etc)

  • Paul L UK Level 1 Level 1 (0 points)

    It's also a very old drive interface as well ATAPI, friends drives in PC/Laptops use SATA DVD drives. Now that would at least then mean we could swap out for cheaper PC hardware and give you an option to swap to 2nd hard drive if you wanted.

     

    Plus the brand Matshita, back in the day of floppy drives never used to like them, perfered Teac or Panasonic, but i suppose the clue is in their name as to what their like .

  • Paul L UK Level 1 Level 1 (0 points)

    Got my drive working again, basically thought before i go out and buy an external drive I'd have nothing to lose to remove and strip down which was very easy and hardest bit is ensuring you don't drop the 2 little screws holding the drive in by the slot as it is fiddly there, but small magnet on screwdriver sorted that.

     

    I used spectacle glass cleaner on a cotton bud, and just rubbed gently over the lens, as lens seems to be spring loaded so goes up and down.

     

    Re-assembled and powered up then immeadiatly burned at 8x and all worked perfecty including reading now is so fast, so it must have been reading at 2x as well only being able to burn 2x.

  • tonyfromhenderson Calculating status...

    Awrighty Then! Here's what I ve successfully learned; the G4 PPC with 10.3.9 has a built-in burning capablility (when Finder FEELS like it) that can burn burn, but it shows up VERY infrequently ... there's no ryme or reason to that but I discovered THAT while accomplishing these steps; ( I can't remember WHICH sites had what I needed, but I'll trace back by program names that got me this far ASAP)

    1. Searched every nook & cranny of the Internet for a 10.3 boot disk download, found one that comes down as an ISO file,

    2. loaded it on my WinXP, used "PowerISO v4.9" to make the *.ISO file into an IMG in a folder on the WinPC desktop,

    3. then used "ImgBurn v2.5.6.0" to burn the Image onto a DVD & then, just to cover my ***, I burned a CD as well; it barely fit the CD ...

    4. Now I had an Emergency Boot - stripped down 10.3 boot Disc DVD & CD.

    5. Booted the G4 & used Disk Util to repair EVERYTHING on the Boot HD & clean out EVERYTHING from all the BS Apps I's already tried that DIDN'T Work!

    6. Re-Booted to 10.3.9 on the Boot HD, started Toast 6, & ...

    7. Still got errors ... BUT! Toast Error Screen suggested using a slower Burn Speed, now that it could FINALLY RECOGNIZE THE FRIGGIN Pioneer DVD/RW-CD/RW 109 ...

    8. Slowed the speed down to 8X, and ... it WORK! Been Burnin' Up STACKS of DVDs getting my Tunes & Files before the S.M.A.R.T. Status changes to Dead In The Water Status ...

     

    In the course of all this I discovered; the STACK of Maxell DVD+R (4.7gb -16X) are useless w/ my setup. Dunno 'bout YOURS ... but useless on mine. Made Strange "Tales From The Crypt" kinda sounds come outta my Ext DVD setup ... I considered giving it a Guinness Bath ... anywho ... Switched to Long Forgotten stash of TDK DVD-R (1-16x / 4.7 gb) & they are Way Compatible with the equip I'm using ... SO! Be picky 'bout bargain basement blank media, slow down the speed AFTER you do maint from a bootleg boot ... CD, even IF it's an external like mine.

     

    Note: When handling Virgin DVDs & CDs, stay away from the center hole area; they read from inside to the outside, & at the point CLOSEST to that center hole is a very narrow strip of info that tells the DVD/CD unit what it is that's spinning in it; like a MAC address in most hardware. Scratch, Smudge that area & the Disk will babble foolish stuff to your machine ...

     

    btw; I'll try my best to post where that site is where I fouind the Boot ISO file to download ... Really HAS WORKED LIKE A CHARM ...

     

    OK, here's where the hate mail starts ... G'Luck ... It's Guinness Time! ... register ... vote ...

     

    WAS Going to put my Sys OS & Hardware Info from Profiler in here so you could compare & all that, but apparently Apple is quakin' in their boots @ The Prospect of allowing the Dreaded "Copy & Paste" Anarchists to invade Cupertino ... No Biggee ...

  • Paul L UK Level 1 Level 1 (0 points)

    Reading through the last post also reminded me of something that also happenned to my Mac on wednesday after post on 11th (although drive still slow afterwards) was I upgraded to windows 7 (bootcamp) but the default 20GB volume boot camp chooses turned out to be woefully to small and needed to increase another 15gb.

     

    So having had grief with the upgrade from XP meaning I had to contact microsoft and spend 40 minutes on the phone  to get a special key from them (but thats another story) didn't then want to delete and re-install I used a disk partition tool which then bascially trashed the MBR for both O/S's.

     

    So I ended up deleting all the partitions inc. the one which I beleive is the EFI (129mb) and then just did mac restore and windows image restore and wondered by deleting the EFI (BIOS) info it then had to create this form new as I can see a new partition again 129mb but ony under windows 7 (hidden under mac) and whether this had an effect on the DVD drive now working but coincidentally the lens was also dirty so thought my problem was just down to that.

     

    But thought I'd mention this as may be usefull to others, if you got backups then may be worth using a windows boot disk to delete all partitions and switch to OS-X to recreate and re-store

  • bbc airport Calculating status...

    Stick with an iMac? I've been getting the same problem for months on my iMac and decided to try and find out what the various error codes were which brought me here.

  • Paul L UK Level 1 Level 1 (0 points)

    what generation / year is your iMac as that's not good as from my sister's experience it has been more stable also what brand of DVD drive you got and did you upgrade from older OS-X?

  • .:SiLo:. Level 1 Level 1 (0 points)

    Just to clarify, EFI is not stored on any drive.

    It is flashed firmware.

  • Paul L UK Level 1 Level 1 (0 points)

    I read some intel doc a long time ago when looking into EFI when i first had prblems with the DVD and people mentioning firmware and came across  an article mentioning EFI can use a partitioned space (EFI system partition) on the HDD to store extended info relating to specific manufaturere hardware.

     

    If that 129mb isn;t to do with EFI then that partition could be a recovery partition that Lions creates, I can reboot MBP undocked and do the ALT. at boot see if I get a Recovery drive.

     

    but either way I'm happy again as drive has been working flawlessly since I cleaned lens and suspect then that was the issue this time, also the drive internally was dust free to the human eye but lens must have been dirty

     

     

    UPDATE: Rebooted MBP and there is no recovery partition, so just did a search and both windows and OS-X creates a 128MB space for UEFI and it also mentioned OS-X uses this space for staging firmware updates when in flash mode, so EFI isn't just contrained to being firmware on a chip it can also reside on HDD [edit]

1 ... 6 7 8 9 10 ... 13 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (4)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.