Previous 1 8 9 10 11 12 13 Next 192 Replies Latest reply: Jul 29, 2015 3:36 AM by StephenCPhotog Go to original post Branched to a new discussion.
  • humgoo Level 1 Level 1 (0 points)

    I am using an older intel 24" 2.16 GHz Core 2 Duo iMac running OSX 4.11. I have had a Snow Leopard update disk sitting here on the desk for the past 3 years but honestly, I really haven't needed it because the computer works exceptionally well just the way it is ... mostly as a TVPVR.  I use PCs with Win7 for most things.

     

    Anyways. I have gone through quite a few good quality dvdR+ disks lately while attempting to burn files and was seeing 2 error codes, both saying that there was a communication error with the optical drive.

     

    I googled my problem and discovered this thread. I first tried the "deleting the p-list" solution but it didn't work.  I then blew out the drive with compressed air and that totally fixed it.

     

    Fluff on the lens was the problem.

  • humgoo Level 1 Level 1 (0 points)

    This is the next morning .. problem came back.  I had written yesterday's post about blowing out the dust from my Super drive and it worked, I successfully burned 2 dvdr+ disks and they verified.

     

    I rebooted and tried another disk (Verbatim) and got the "error 0X80020022 because communication to the disc drive failed".  I sprayed the inside of the superdrive again with compressed air and tried two more times. Each time the burning began and then failed after different duration of the burn. The last session I tried, the disk burned but then failed to verify.  The only way out of the situation each instance was to hard boot the computer.  I repaired my permissions after each hard boot.

     

    I tried a Sony dvdr+ disk and it immediately failed.  I know the Verbatim disks are OK because I am using them on the PC with no troubles (as well as the Sony), and the two successful disks I burned on the Mac were  from the same Verbatim spindle.

     

    Driving me nuts as I have been burning disks on this computer for years without problems.

     

    It must be really, really dusty in there or there definitely is something to a software issue.  I have another Superdrive from my old G5 iMac, the one that has the bursting capacitors on the logic board which is another Apple horror story.  I may try and salvage that one and swap it but if the issue is more to do with OSX itself then it's probably a waste of time.

     

    I will try and clean the lens with a lens cleaner first if I can find one.

  • humgoo Level 1 Level 1 (0 points)

    Today I bought an "Allsop Lens Cleaner" and put it in the drive which started i-Tunes to run the audio instructions.  It began cleaning the lens and then the drive froze up and started clicking. I had to Force Stop i-Tunes to get the cleaner disk out.  I did that 3 times to make sure the lens was cleaned off.

     

    When it came out of the slot, the Allsop Disc Cleaner had a lot of fine dust around it's little brushes so it definately cleaned the lens.  I got the same  "error 0X80020022" when I tried to burn a DVD+R.

     

    I went out and bought a spindle of Memorex DVD-R disks (they were on sale).  I haven't used DVD-Rs for years.

     

    It worked.  I am burning my third disk right now at full speed with no troubles at any part of the process.  I hope that using DVD-Rs instead of DVD+Rs was the solution.  I guess time will tell.

  • OS1 Level 1 Level 1 (0 points)

    Toast did the trick for me, but on a second DVD, so I can't be sure where the problem was. I have Macs for 21 years and the CDs/DVDs were always problematic.

  • Marc-O-dré Level 1 Level 1 (0 points)

    I my cast I found this forum section when i get the error 0x80020022 from my burning DVD test. But few minute later I was able to burn a DVD whit Toast Titanium 9 at a speed of 4X.

     

    Hope it can help some of you

  • yelnats126 Level 1 Level 1 (0 points)

    It does seem that the type of DVD along with the combination of the OS causes this type of error message.

    I was unable to burn files to a Memorex 8.5G DVD+R disc three times.


    I tried a Memorex DVD+R DL and it burnt successfully.

     

    It's a hit or miss with the DVDs so good luck with them!

  • Adcruz Level 1 Level 1 (0 points)

    This might sound stupid. but it works.

    Between burning each disc, delete the 'Untitled DVD' folder on the desktop and relaunch finder as many times as you want, then wait 4-5 minutes. I've burned 11 DVDs in a row this way, and I've had the occasional 'Can not verify' errors. But upon proof checking I found that the contents seemed to be intact.

  • Jottle Level 1 Level 1 (70 points)

    Some say this is a software error (dvd drive firmware issue), some say this is just a hardware error. In my case, I had the this error pop up for only dl-dvd burns. My drive would burn regular dvd's and cd with no issue.  The console log was showing all sorts of disc read and laser tracking errors whenever I tried to burn dl-dvd's only. I tried every single solution listed in this thread and others (throwing out preference files, cleaning the lens of the disc drive with air or a cc card wrapped in a microfiber cloth, using a lens cleaning disc, among other suggestions). Ultimately, in my case, the drive had just failed and I had it replaced under applecare warranty. The new drive burns dl-dvd's like a champ. So it may be a hardware error in other people's cases as well. Of course, only way to know for sure is to replace the superdrive, which can be a pricey option.

  • ujayank Level 1 Level 1 (0 points)

    When I burn Memorex DVD+R DL in Toast it says it can't communicate with the burner due to a "MAC OS error". I think it's definitely an Apple issue. I get this same issue using Finder and both my stock MacPro drive and the Pioneer BD I had installed.

  • ujayank Level 1 Level 1 (0 points)

    Hopefully Mountain Lion contains this fix.

  • ujayank Level 1 Level 1 (0 points)

    Toast now gives me:

     

    "The drive reported an error:

    Sense Key = ILLEGAL REQUEST

    Sense Code = 0x24

    INVALID FIELD IN CDB"

  • ujayank Level 1 Level 1 (0 points)

    True. I am having success in my Pioneer BluRay drive burning discs other than DL (DVD and BD). Haven't tried the SuperDrive yet.

  • humgoo Level 1 Level 1 (0 points)

    Just a follow up post.  I have had no trouble at all burning dozens of DVD-R disks in the past couple of months.  They all burned and verified so my problem is resolved to my satisfaction.

    I cannot use DVD+R disks in my iMac, just DVD-R disks.

  • Chimerian Level 1 Level 1 (0 points)

    I don't think this is a solution for everyone, but I was having problems until I freed up space on my hard drive... I was running within 3-4 gigs of being full... I have not had any problems since giving myself a 30 gig buffer. :-)

  • mindpotion Level 1 Level 1 (0 points)

    NOT stupid at all it actually works!!!!