Previous 1 10 11 12 13 14 Next 196 Replies Latest reply: Dec 22, 2015 3:03 PM by Brad Voorhies Go to original post Branched to a new discussion.
  • F3rnando Level 1 Level 1

    Same error for me in new OS (Maverick). What I tried so far:

    —Repair permissions

    —Reset PRAM and SMC

    —Reinstall Maverick

    —Try burning with Toast

    —Try burning via Terminal

    —Cleaning lens with credit card plus glasses rag!

    —Try burning with different DVD brands: Memorex, TDK and Sony

    —Burning via disk utility and via Finder

    Nothing of the above work for me

  • beekayApple Level 1 Level 1

    Have you tried to use Read/Writable disk?.  Those seem to work for me.  But I never have consistently gotten my DVD to burn to -/+R disks.

  • F3rnando Level 1 Level 1

    Yes, I´ve tried RW DVD's, plus DVD+R and DVD-R. Today an Apple technician suggested me to make a clean installation of my OS, but I don´t think this work either.

  • beekayApple Level 1 Level 1

    Try to turn off the energy saver.  I was reading that something might be "falling asleep" while a long burn is happening. 

  • supportamit Level 1 Level 1

    lower the BURN SPEED.....

  • Mark Flood Level 1 Level 1

    Although I have gotten the same error message(0x80020022), I am able to burn DVD's on my imac and MacBook Pro by using Memorex double sided DVD+R or Verbatim single sided DVD-R. I couldn't get any other discs to work. Don't ask me why, I'm not a techie.

  • Hypnoctopus Level 1 Level 1

    I see this thread is literally years old without being solved. Sad. I'll share my experience, and I hope some may find it useful.


    I'm running 10.6.7 on a 2009 Macbook Pro, and I use OSX's built in disc burning software.


    Burning DVDs does not work when I use TDK or Memorex DVD+R Dual Layer, 8.5 GB discs.


    Burning DVDs does work when I use Memorex DVD+R Single Layer, 4.7 GB discs.


    I have not tried any other brands or types of discs.

  • kostby Level 4 Level 4

    Welcome to Apple Support Communities.


    It's a very old thread, but it's nice to revisit some of these and perhaps offer some new insights.


    The original report began this thread with Snow Leopard OS X 10.6.4. Other OS versions have been mentioned, but in this thread at least, 10.6 seemed to be the prime culprit.


    I think everyone in this thread (me included) has overlooked two critical factors up to this point:




    in addition to what's required for the data to be burned to a new DVD.


    I don't burn many DVD's (a few a month), and no DL's that I can recall, mostly a few single layer discs for backups (programs downloads to RW and photos archived to +R) these days,


    NEW INSIGHT: I've found that most of my burn failures (as well as other App 'freezes', 'hangs', or 'beachballs' in OS X 10.6 Snow Leopard) are because OS X simply "runs out of" Free RAM, when it gets down to 20Mb or so 'free'.


    When the operating system runs out of free RAM, it buffers data to the hard drive as "Swap used", and that's hundreds of times slower than writing to RAM. Burning a disc is MUCH more timing-dependent than other program processes. If your DVD burner runs out of data to write, it eventually 'times-out' and causes an error.


    If your data is on your local hard drive, when you burn it to DVD, the same SATA interface in your computer is reading the data from the HD to RAM, AND writing from RAM to the DVD. When it begins to run out of RAM, it starts writing the data (it just read from the hard drive) back to the hard drive to buffer it because RAM is full.

    ... 'beachballs' occur... burn fails.  If you're reading or writing that data from an external HD or DVD drive via USB, you've added another interface that runs significantly slower than SATA.


    With hangs in other apps where I'm NOT trying to burn a disc, patience can be a virtue. Quitting ALL other apps to free more RAM often lets them recover from the hang in a matter of a few minutes. Disc-burning is not nearly as forgiving...


    Have you looked at how much Free RAM (the green part of the memory 'pie' chart in Activity Monitor) is available, especially when the DL burn fails? I run Activity Monitor (yes, it uses some RAM and Processor, and might contribute to the problem) and I set the Dock icon to 'Show Memory Usage'. It gives me a picture of what is going on. Safari, especially when I'm on social media sites for several hours, seems to eventually swallow ALL available RAM.


    Which screen size of mid-2009 MBP and what clock speed?

    How much RAM is installed in your system?

    How much free space is on your hard drive?

    Is the data you're burning on an internal or an external drive?

    Are you burning to an internal or external DVD drive?

    Are you running any other apps at the same time during the burns?


    My OS X 10.6.8 MacBook is a mid-2007 2.16Ghz with 3GB RAM (4GB installed, but the early Core2Duos only make use of 3GB) and a 500GB HGST hard drive with at least 120GB free. Since I've monitored RAM and hard disk free space and used the SLOWEST speed available to burn, I've not had any 0x80020022 errors (April 2010 was my first post). I have had discs fail to VERIFY, and produced a few 'coasters', but most of them were scratched RW's I was attempting to re-use.


    Summary: Those who reported some improvement in 0x80020022 errors have mentioned some or all of the following:

    1) rebooting right before burning (='maximizes' available RAM)

    2) burning a slower speed (=more time for the interfaces to buffer and transfer data successfully)

    3) ensuring they had LOTS of free hard disk space by various means (15-20GB is the suggested minimum free hard disk space anyway)

    4) "brand name" discs worked better for some people

    5) cleaning the DVD drive lens - I recommend compressed air ONLY (CAUTION: Most "brush-type" lens cleaner on a disc CAN and probably WILL damage slot-type CD/DVD drives, or get stuck in the slot!)


    Message was edited by: kostby

  • Hypnoctopus Level 1 Level 1

    Thanks for the detailed reply. Here are the answers to the questions you posted:


    Which screen size of mid-2009 MBP and what clock speed?

         13 inch, 2.26GHz Intel Core-2 Duo (this is the clock speed, correct?)

    How much RAM is installed in your system?


    How much free space is on your hard drive?

         27 GB

    Is the data you're burning on an internal or an external drive?

         Internal HD

    Are you burning to an internal or external DVD drive?

         Internal DVD drive

    Are you running any other apps at the same time during the burns?

         I don't recall if I was during the previous error. I'll attempt a burn after rebooting, and while running      no other applications. I'll update this post after that.

  • kostby Level 4 Level 4

    2GB isn't very much RAM, even for OS X 10.6.8. You'd gain some performance benefits (20% or so, depending on OS version) by upgrading to 4GB. Depending upon what apps your run, 8GB might help a bit more.


    My son purchased the same MacBook Pro for college in 2009, and he upgraded to 4GB right away.

  has a free Mac tool Download Geekbench (as well as paid benchmark tools) to measure system performance and upload the results for comparison. These are 'benchmarks' designed to measure performance, not real-world applications.

  • Hypnoctopus Level 1 Level 1

    To update my previous post, I attempted a burn after rebooting, running no applications, and with an 8.5 dual layer disc. No luck.

  • kostby Level 4 Level 4

    Thanks for that update documenting that your error is likely not because of a lack of available RAM.

  • adestefMac Level 1 Level 1

    I just burned a little under 3GB to a memorex 4.7 DVD+R successfully.  Then next file I needed to burn was over 6 GB.  So, I got memorex 8.5 GB DVD+R discs, and I have wasted two of them getting this same error.  After reading thru this thread, I'm going to give it another shot using 4X speed (I had used 6X on the previous two tries).  Amazingly annoying.  I have been singing Apple's praises... but this is inexcusable.  I know we have the cloud and flash drives and everything, but for delivering files to clients, they don't necessarily have the sophistocation to use Dropbox (or want to pay for extra space there), and thumb drives are expensive to just hand out to clients. 


    Pray - coming up on 96% (but then the other failures failed as they were almost complete, too.....)


    Disk activity....  fingers crossed.....





    still "Finishing..."


    Disk activity....


    drumroll.... (not really, but.....)



    (thinking of how many hours I've been screwing around with this that I'll never get back and can't charge my client for)

    For the record, while it's verifying, I will say that in this case, I right-clicked on the file, selected "Burn" from the menu, inserted the DVD, and chose the 4X speed.  There's been some discussion about whether it makes a difference to drag and drop or whatever.  So, for the sake of documentation....


    11% complete verifying.... OMG - maybe it was just getting bored to death.


    This is burning on a Macbook pro with Mavericks, and 4G RAM (for those who care).


    I have an iMac, but when I got it, was talked out of getting a CD/DVD drive (after all, I have it networked with the MacBook pro...)  That was convenient for the sales person.... 


    37% verified.... I'm dyin' over here....

    NOOOOOOOO!!!!  at 53% verified, it barfed out the disk and I got this:  "The disc can't be verified and might be unreliable.  Try again using a new blank disc (error code 0x80020063). 

    State: Failed.


    So.... I cleared the error dialog, waited for the drive to reset, and put the disk back in.  I'm in the Disk Utility. 

    NOW I have the choice to Verify Disk or Repair Disk (note: after other attempts I got the 0022 error, and "repair" was not an option)


    Clicking "Verify".


    Same message as before: Invalid B-tree node size.... This disk needs to be repaired. Click Repair Disk.  (at least this time it is enabled.... clicking...


    Nope: Disk Utility can't repair this disk...


    Unbelieveably annoying.  I hope the details here will help someone somewhere.... 

  • geneandamy Level 1 Level 1



    I am having SAME issues...  This is ridiculous because I have DVD's that need to be delivered to clients as part of my wedding and birth packages. 


    What are options to get a DVD burned?  I have a 21" iMac (mid 2010) with (OSX 10.8.5 / 3.2 GHz Intel Core i3/ 4GB 1333 MHz Ram) and have not been able to burn a DVD since I upgraded to Leopard.  I was using Snow Leopard and have recently upgraded to Moutain Lion (end of Jan, 2014).


    ANY help for this frustrating problem is appreciated.  I have tried several workarounds and no luck with any of them.  I would really like to use iDVD because I do like the themes (some of the other DVD burning software themes are downright silly and cheesy looking).


    Thanks for any advice in advance


    - Amy

  • Newisma Level 1 Level 1

    I came to this forum out of desperation.  I'm experiencing the same issue of not being able to burn a music cd today.  This problem has occurred on and off for the last 2 months...could have been with the last update of Lion. 

    I have a Mac Pro, 2 HDs ,1 Terabyte/2 Terabyte with a ton of space available along with 8 GB of RAM.  It has a 3.33 Ghz 6-core Intel processor and OSX Lion 10.8.5. 

    Two weeks ago a Mac Tech replaced one of the CD/DVD drives as it was making a humming noise.  As it usually goes, everything worked fine until today.  I got the "error code 0x80020022".

    I use Memorex CD-R 52X700 MB blanks.  I "burned" a CD two days ago.  Although it was a successful burn, I personally thought, the process seemed to be a little slow with some "beach ball" action.  These CDs I have been burning(or attempting to) have not had a lot of data(music) on them...we're talking like 33 to 80 Mb.  I have had this computer just a little over a year and I have not burned more than 50 CDs total. My burn speed has been set at 16X and I lowered it and it didn't help. I guess I will have to have the tech come back out next week as I tried the "reset suggestions" from above and it still failed to burn a disc. 

    Last thing, I have been able to burn DVDs and have not had any problems at all with that process.

    Glad I had my PC to bail me out today....

    I'm definitely open for suggestions and "yes" I'm a new Mac user.  Thank you for your help in advance....