Previous 1 2 3 4 5 Next 139 Replies Latest reply: Mar 15, 2015 4:27 PM by amomoftwo Go to original post Branched to a new discussion.
  • unvaluablespace Level 1 (0 points)
    SLIM Man,

    I am unsure of the hosts file on Mac OS X. Might I direct you to look into my first post on this thread with a link to my other thread on the modmyi forums. There is a user there (TypeRBass) who seems to have fixed this on his snow leopard. Maybe if you PM him on there and ask nicely, he may be able to provide you with the assistance on getting the fix to work on your Mac. Good luck and sorry I can't help you more.
  • TheHammer417 Level 1 (0 points)
    I posted this over on the MMi forums also (I'm TypeRBass), I had the same issue. Stop blaming it on jailbroken phones because that's not the problem, I'm now using an iPhone 4 and I ran into this problem BEFORE the jailbreak while trying to update to 4.0.1. Same thing I posted over there.

    "I just followed these steps..

    Step 1 – Open the Terminal.app
    Either by start typing Terminal on the Spotlight, or by going into Applications -> Utilities -> Terminal.

    Step 2 – Open the hosts file
    Open the hosts by typing on the Terminal that you have just opened:
    sudo nano /private/etc/hosts


    Type your user password when prompted.


    then i scrolled down to the bottom, and where it says :
    127.0.0.1 gs.apple.com, I just added a # and a space before it. Then saved it, and it updated without a problem."
  • Norato Level 1 (0 points)
    Excellent write-up, 100% correct!
  • UptownBen Level 1 (0 points)
    Hey All.

    So I have this issue also. Except that I am trying to update my iPad which is NOT jailbroken. I am trying to perform the update on my Mac, where I successfully updated my iPad to 3.2.1 a few weeks ago. My hosts file does NOT contain any reference to gs.apple.com. There are no apple.com references there at all. I don't understand why I would be able to update my iPad to 3.2.1 just a few weeks ago, and now I can't update at all. Can anyone from Apple please step up and provide some possible fix?
  • gugawag Level 1 (0 points)
    Perfect. It worked for me.
  • SteveDSD Level 1 (0 points)
    Same issue, my non-jailbroken iPhone 3G (ios 4.0.1) and non-jailbroken iPad wifi+3G (ios 3.2.1) on the UK network 3, both have the same error 1638 when trying to "Verifying iPad upadte with Apple"

    Noticed the following errors in the OS X console for both devices, I'm guessing it's something to do with the provider settings update I got sent from Apple after updating to 3.2.1 -
    13/08/2010 22:29:41 iTunes[156] AMDeviceCopyAuthInstallPreflightOptions (thread 0xb0a6f000): device reports an incompatible baseband certid
    13/08/2010 22:29:41 iTunes[156] AMDeviceCopyValue (thread 0xb0a6f000): There was an error getting the value for []:[BasebandNonce] from lockdown: GetProhibited
    13/08/2010 22:29:41 iTunes[156] AMDeviceCopyAuthInstallPreflightOptions (thread 0xb0a6f000): device reports an incompatible baseband nonce
  • Pyro7i9 Level 1 (0 points)
    OMG unvaluablespace you're awesome. Just changed that on my Mac and was able to restore my iPhone after hours of looking on the internet and trying different "solutions" to the problem. Thanks!
  • Joshie! Level 1 (0 points)
    I did this update using terminal, and finally i could update again. Never had a problem before until recently...anyone know why this has happened all of a sudden???
  • juanca82 Level 1 (0 points)
    Hi. can you please tell me how can i save the changes on my mac please. I'm new to the mac world. thank you
  • juanca82 Level 1 (0 points)
    how do you save the changes?
  • juanca82 Level 1 (0 points)
    i need help saving the changes. thx
  • Natasiah Level 1 (0 points)
    This also worked for me! Thank-you so much!

    Saving host files on Mac:
    Source: http://decoding.wordpress.com/2009/04/06/how-to-edit-the-hosts-file-in-mac-os-x- leopard/

    "*Step 4 – Save the hosts file*

    When done editing the hosts file, press control-o to save the file.
    Press enter on the filename prompt, and control-x to exit the editor."
  • Eg7737 Level 1 (0 points)
    how do i do these steps on windows xp
  • Vinura Level 1 (0 points)
    Try editing the host file. If you are on a Mac go to finder and then at the top click on the Go drop down menu then click on Go to Folder and type etc hit return
    look for a file called hosts click on it and at the bottom if you have some 72. something delete that line then go to file save as and save to desktop uncheck the check box on there(sorry doing this from memory dont have actually stuff) hit save.
    after that drag the desktop hosts file to the etc file and you are done

    Sorry for inconvinience
  • controller2k Level 2 (155 points)
    Thanks much this worked like a charm when I suddenly started seeing this problem this morning while trying to update to 4.2.
Previous 1 2 3 4 5 Next