Previous 1 2 3 Next 165 Replies Latest reply: Dec 27, 2010 2:30 PM by Wunderboy
corn Level 1 Level 1 (15 points)
HI,

there are a few topics that have similar issues, but not exactly, so I'll start another one.

My new MBP core i7 2.66 with 8Gig of ram is unable to automatically go to sleep when on battery or when plugged in. It sleeps when selected from the Apple menu or when the lid is closed.. however when the time limit is reached in the Energy Saver prefs, the display will happily switch off but the machine will not sleep.

I have calibrated the battery, reset the SMC, it is a fresh clean install and I have turned off as many application and back ground apps that I can think of. No love.

Any ideas?

MBP Core i7 2.66 GHz 8GB RAM, Mac OS X (10.6.3)
  • Kay Marczoch Level 7 Level 7 (21,685 points)
    Goto
    Library/Preferences/SystemConfiguration
    Delete
    com.apple.PowerManagement.plist
    com.apple.AutoWake.plist
    Reboot

    Again set those preferences through "System Preferences"

    Reboot again

    Open a Terminal windows an type:

    pmset -g

    what are the results?
  • RicD Level 2 Level 2 (230 points)
    My 15" i7 has also been suffering from lack of automatic sleep. I think I've figured it out.

    I tried all of the suggestions here (reset PRAM, reset SMC, delete various plist files) and nothing worked. I set up a new user on my Macbook Pro and logged in as the new user and noticed that automatic sleep worked for the new user. I started comparing processes and eventually narrowed it down to the Mail.app. If the Mail.app is active, then automatic sleep does not work.

    I'm using the default power settings (10 minutes for display and computer). Mail.app is set to check every 5 minutes. These are the exact same settings that I use on my 17" Macbook Pro C2D and on my 15" Powerbook and those machines have no problems with automatic sleep.

    There must be something peculiar to the new machines that is causing this.
  • corn Level 1 Level 1 (15 points)
    Hi,
    thanks for the prompt response.
    I've tried your suggestion and still no luck.
    The com.apple.Autowake.plist was not in the folder
    The results of pmset -g are:
    Active Profiles:
    Battery Power 1
    AC Power -1*
    Currently in use:
    womp 1
    halfdim 1
    sms 1
    hibernatefile /var/vm/sleepimage
    gpuswitch 2
    disksleep 10
    sleep 1
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 1
    acwake 0
    lidwake 1

    what does this mean?
  • corn Level 1 Level 1 (15 points)
    I am not using Mail. But thanks
  • RicD Level 2 Level 2 (230 points)
    Correction to my previous post -- if there is any app active in the dock, my 15" i7 will not automatically sleep. It's not just a Mail.app thing.
  • corn Level 1 Level 1 (15 points)
    Well, for me, I don't have any apps open. I've also unistalled anything that was running in the background.

    On top of that, I booted in safe mode, logged into a new account and still no luck.
  • corn Level 1 Level 1 (15 points)
    I should also mention, when I calibrated the battery, it shut down without sleeping.
  • corn Level 1 Level 1 (15 points)
    ok.. some more information to add:
    Archive and install did not work.
    I also booted in safe mode again after my reinstall.. no luck.
    I'm wondering if this is a hardware problem then?

    I tried PleaseSleep
    http://www.dragonone.com/products/macosx/pleasesleep/
    It works!! I just wish I didn't have to rely on a 3rd party piece of software though
  • MAQ 1017 Level 1 Level 1 (10 points)
    Hi there,

    Just like the original poster

    I've got a brand new i7 15" MBP, which is refusing to notice energy saver settings... Basically the thing will stay on all night if I don't manually sleep it, and with network access waking enabled its basically up all night !

    I can put the machine to sleep myself no problem, its just the energy saver settings never seem to kick in.. After a reboot, sometimes the display sleeping will kick in, and on the rare occasion even a full system sleep.

    I've done all the usual, PRAM resets, plist deletes, uninstalled software that could be playing up, but I'm honestly left thinking this is an OS bug at the point, maybe even an issue with the idle timer.

    Hope Apple can fix. I recommend anyone suffering leaves feedback as a bug report.

    Thanks in advance
    Martin
  • Shakenbake88 Level 1 Level 1 (0 points)
    Hey,

    I'm having the same problem with my 15 in i5. Although I wasn't able to fix it, I found a decent workaround.

    Just download "Please Sleep"
    http://www.dragonone.com/products/macosx/pleasesleep/

    It forces your mac to sleep at your desired time no matter what background apps are running. You can also customize it to allow it to stay awake when certain apps are running.

    Hopefully apple will fix it soon but until then this is the best solution I can think of.
  • MAQ 1017 Level 1 Level 1 (10 points)
    I can also confirm that my MBP fails to suspend when battery gets low... Instead of the nice suspend to memory and grey screen/white bars ticking back up when you power up again, I just get a fresh boot from scratch.

    This isn't great for a brand new 2000 quid machine!
  • corn Level 1 Level 1 (15 points)
    Yes, Please Sleep is working for me... but not the most favourable solution.

    I can confirm a fresh, clean install now does NOT solver the problem.

    I would ask for a replacement.. however, the other MBP i7 we bought at the same time for work is displaying the same problems.. which makes me think this is quite widespread.

    Is anyone with a MBPi7 not seeing these problems?
  • MAQ 1017 Level 1 Level 1 (10 points)
    I left my machine in sleep all night last night, and was suprised to find out the damned thing has been awake for most of the night, despite 'wake for network access' being turned off.

    I think power management on the i7's is a complete mess, as there is no reason it should wake itself with that option turned off...

    Hope Apple can devise a fix soon.

    Thanks
    Martin
  • rwross Level 1 Level 1 (5 points)
    Same issue...

    I've had some success by resetting SMC, but that success is short lived. Usually once I change states, i.e., from power to battery or the reverse, the auto sleep stops functioning again.

    The fact that a 3rd party app "Please Sleep," solves the problem for most folks is another clear sign that the pref pane is not doing its job.

    I'd rather not load a separate power management App, so would welcome any other ideas.
Previous 1 2 3 Next