Previous 1 2 3 Next 103 Replies Latest reply: Jul 15, 2014 3:28 AM by S.P.Wilson
petero221 Level 1 (0 points)
This problem relates to the fact that once again Belkin haven't bothered to update the installation software for their great USB Hub...not happy! Ironically this is the same problem Belkin had with this device when it came out back in 2007, with earlier versions of Mac OSX V (10.5); it's a simple fix and yet they have basically stumbled again for Snow Leopard!

PROBLEM: Belkin Network USB Hub F5L009 gives an error message "SXUPTP driver has not been installed" when you instal the software if you have Snow Leopard.

1. Download "SX Virtual link for Mac" V3.3.0 (Date 11/13/2009) from
2. You will have downloaded a zip file called ""; unzipping this will give you a folder named "s-42a330".
3. Within that folder, navigate to SXVirtualLink>contained_packages>Driver>10.6 (the 10.6 refers to Snow Leopard OS); inside there is a file called "Silex_kext" dated 5/11/2009
4. Drag this file into the installation folder Utility>Connect>contained_packages; it will ask if you want to replace the older version of this file that exists there. Click "yes".

Now you can go through the normal installation process using the modified package, as per the manual, and hey presto, everything works magically!!

[If for some reason you don't have the installation disk to start with, or have a problem sticking it on your desktop, it is available at as F5L009 Driver - Mac (version 1.5.0, OS compatibility : Mac OS 10.5; note there is no 10.6 compatible version - and THAT is the core of the problem with the installation disk in the first place).

QUESTION: I know nothing about what the **** I am doing, and yet managed to figure this out from Googling and reading - why can't the brains at Belkin have done the same - it is a trivial exercise for them to have made a version 1.6.0 compatible with Snow Leopard. I am seriously unimpressed!

Late 2009 iMac 20.5 inch 1TB, Mac OS X (10.6.3)
  • happyharriston Level 1 (0 points)
    All I can say is THANK YOU!!! My wife just got a MacBook and I was seriously bummed that she would not be able to print using our Belkin USB Hub, given that we have several other Windows machines hooked up to two printers in a remote location. This simple fix worked perfectly. And you're right: why in the world wouldn't the Belkin folks take a few minutes to update their installer files?

    Thanks for thinking of posting the solution for the world-wide community.
  • OliverSL Level 1 (20 points)
    many thanks for sharing this info.

    I followed the instrucctions and it worked. I could install the 1.5 driver in Snow Leopard, but I was having a problem disconnecting/connecting a shared printer.

    I noted that I still have a problem after printing, the printer does not disconnect because its status is "In Use". I solved this issue by running this command in a terminal window:

    cancel -a -

    So I created a file named disconnect.command, changed its mode with chmod +x and added this text:
    cancel -a -

    That solves my problem.

    Here is the link of the Belkin drivers:

  • missmercy Level 1 (0 points)
    Any chance of giving me a bit more (step by step) instructions on how to do this? I'm having the same issue - printer won't disconnect and every time I print a page it just stays on that one job and won't go to the next without deleting or disconnecting first and it is slowly driving me nuts.

    I've not a lot of experience with Terminal, so baby steps please, if it's not too much trouble.
  • bucko1 Level 1 (0 points)

    Can you explain this is in a bit more detail as I'm having the same issue and would like to
    understand your solution so I can sort it out.

  • ajdes05 Level 1 (0 points)
    Hi I downloaded the SX Virtual link and it installed perfectly however I have Seagate FreeAgent external hard drive connected to it and it keeps getting disconnected... any idea why???
  • moston Level 1 (0 points)
    Thanks for the research.
    Works for me as well. Why doesn't Belkin produce an updated driver? They don't even have to do much - just replace the Silex component...
  • Charles Larkins Level 1 (0 points)
    I want to use this to enable the Belkin Hub on my Mac using Snow Leopard, but am not clear on the exact install steps. I've downloaded the file from Silex, opened the zip file and see the 10.6 version. Here's where the confusion lies, I view the package contents but do not see a file called "Silex_kext".

    And if I did find the file it is not clear which folder to drag it into, the directions say "Drag this file into the installation folder Utility>Connect>contained_packages". Exactly where is the installation folder?

    Can you clarify the install process that you used?

  • azstefano Level 1 (5 points)
    This solved my problem with the original Silex extension via Belkin. The syslog was starting to complain about conflicts in this extension, and I'm certain it was the cause of some crashes. The new SXUPTP extension no longer gives me a warning in the system log for OS 10.6, and appears to work better for a data acquisition program I'm running using the wireless hub. Less CPU load and much fewer data dropouts.

    Thanks for posting this - it has saved me future grief.
  • bimatteo Level 1 (0 points)
    This didn't work for mee to,
    I have continuous disconnections of my Canon Pixma printer often needing to reboot OsX to getting it work.
    Any suggestions?
  • bimatteo Level 1 (0 points)
    I noticed that every time the printer gets stuck, a system reboot can solve the problem.
    Is there a way to restart silex kext without rebooting the whole system?

    Message was edited by: bimatteo
  • Questor72 Level 1 (0 points)
    Hi guys,

    I was able to do the steps and now have firmware 1.2.0 en SXUPTP driver 1.5.2 installed. The weird thing is that the Control Center is showing the drives, but i'm not able to press the button request use. Does anyone have this problem? Is this the same thing or am i doing something wroing?
  • giza Level 1 (0 points)

    Thank you very much for the Silex link! This has solved my Belkin Hub problem as well.  Ever since upgrading to OS X 10.6.7 I've been unable to print via the Belkin Hub even though it showed that it was connected in the Control Center. Great! Thanks again!

  • vinsup Level 1 (5 points)



    Thanks for all the instructions. Though, I am new Mac user (2 days old), I managed to follow your instructions and tried installing the Belkin software. Unfortunately, the installation failed. I have a MBA with 10.6.7. Any idea what might be going wrong?



  • vinsup Level 1 (5 points)

    For some reason the above mentioned trick could not install the Belkin device on my MBA. It did not give any specific error, but just said some pre-install scripts had to be run. After one full day of trying out, and further googling, I found a link to a pre-release software from Blekin which did the trick. Just downloaded from this link and the device got installed beautifully. No hiccups.



    Hope this helps you guys. I don't know why the people at Belkin don't update their link to this software.

Previous 1 2 3 Next