Previous 1 2 3 Next 83 Replies Latest reply: Jan 13, 2014 8:17 AM by aThanasi Branched to a new discussion.
Goldenlover Level 1 Level 1 (0 points)
How do I delete Unwanted Email addresses?
Auto-fill in saves them all !
When I start a new email, every email address I've
ever written to pops up (To:) This greatly increases my
chances of sending a new email to the wrong person.
.....there's got to be a way to delete just the addresses
I don't want !....but where & how ?

iPhone 3GS, iPhone OS 3.1.3, I hate PC's
  • userremoved Level 1 Level 1 (0 points)
    Are you using MAIL on a Mac? If so, it's fairly simple. You should be able to do this easily on your computer (not on your iPhone).

    Open MAIL on your Mac. Click on Window, then on Previous Recipients. Highlight the name(s) you wished removed; alternatively, click one name, then choose Edit/Select All. Finally, to remove those selected, click on 'Remove From List' on the small Previous Recipients dropdown window. The next time you sync your iPhone, all should be fine.

    If you're on a PC, sorry, can't help. Please note: I have yet to get my first iPhone, so these steps are conjecture on my part. If I'm wrong and others know a better way, please correct my suggestion. Thanks.
  • MMulhern Level 2 Level 2 (215 points)
    This is a problem that has plagued me for a long time too. I just went through and basically got rid of every previous recipient that was not in my address book, and then sync'd my iPhone. I would say that it has gotten rid of about 80%. Weird that it would pick and choose.

    **One thing I have noticed are that the email addresses that are left seem to be from similar groups- like addresses that would have been on a group email, like from my daughter's teacher and Girl Scout leader. I went through my trash and deleted those emails and then did another sync, but that did not change anything. I wonder if I deleted sent emails too?

    Message was edited by: MMulhern
  • userremoved Level 1 Level 1 (0 points)
    You may want to go in and take a look at your Contacts. I've found that sometimes, and for unknown reasons, an e-mail that I responded to caused that person's name/address to be added to my Contacts. Go figure, eh? I always suggest that, periodically, a Mac user do housekeeping) on Contacts and similar programs.
  • MMulhern Level 2 Level 2 (215 points)
    That's a good suggestion, but was not the case for me.
  • ADLC Level 1 Level 1 (0 points)
    Apple please answer this, it's really annoying and causes trouble when you email the wrong people and get spam addresses and lots of other garbage you don't want to see. On MS Outlook you just select and delete.
  • wrgilmore Level 1 Level 1 (0 points)
    This has to be a bug. There has to be a way to delete an email address on the iphone for autofill. If not, Apple please address this. It is a huge issue if a person has a typo of an email address, then currently forever this is a problem. Please, please help. It has not be easier and less work than going back to original settings, etc. It can be done with Google, with Mac, yahoo, everywhere except the Iphone. Please help.
  • IcaroDiver Level 1 Level 1 (0 points)
    I share the same frustration. Went to Apple Genius Corner to consult with a representative. The response was, "No way to delete erroneous e-mail addresses on the iPhone." Unless someone writes to Steve Job, nobody seems to care.
  • RWShaw Level 1 Level 1 (0 points)
    I just got my second iPhone 4 from the genius bar and installed it as a new phone. So I expected to not see all those old email addresses. Surprise, you still do. So since the phone is still under warranty I called Apple. Their answer was to delete the contact. Not a great answer I told the guy and he kept looking. Meanwhile I tried it and it does work. I replaced the contact and it comes back. You can test it by going to the Search window on the iphone. Enter the name and you should see the same list. And of course, there's no way to turn off autofill. From what I see they are being returned in a straight alphabetical order.
  • wrgilmore Level 1 Level 1 (0 points)
    This can't be correct. I have an email which is NOT tied to a contact. Just someone I emailed one time. There was a typo and now it still comes up. No way to delete it. There has to be a way.
  • BRAAP Level 1 Level 1 (0 points)
    I am also looking for a way purge the email addy autofill of old contacts that no longer exist. Many a family and friends have since changed their E-mail addy's, I have deleted their old addy's from contacts, yet the iPhone autofill still manages to hang on to those in some stored cache that is NOT accessible to purge or delete! This is something I've struggled with regarding the iPhone since my first iPhone months after it originally released years ago, have since owned a few other iPhones as they progressed, currently an iPhone 4, on os 4.01, same issue persists. Have restored my phones, started from new during some restores, etc, those old defunct E-mail addy's still autofill!
    I sync with my iMac yet do not even have my mail client set up on the iMac, never have since we bought the iMAc, web based E-mail only, so this issue has nothing to do with mail client on the computer it syncs to.

    It would be nice if someone from Apple would reply with acknowledgment that they are indeed aware of this and hopefully it is on their to-do list.

    Regards,
    Paul
  • MetaChimp Level 1 Level 1 (5 points)
    Unbelievable....

    I have the same issue with a typo in an email address, and now it always comes up as the first result for that client. HORRIBLE!

    There is NO way to fix such a simple issue? Typed once, and stuck for life? Any droid or blackberry can do it...

    And no, "wipe & restore" is not a fix, just like bulldozing a house is not a "fix" for a leaky faucet.
  • Harry53 Level 1 Level 1 (0 points)
    Apple please fix this problem. I have an email address with a typo in and can't delete it anymore. Make it similar as the wipe delete of a podcast episode.
  • John Maton Level 1 Level 1 (30 points)
    I agree that this is a problem on iOS that does not match the functionality of mail on a OSX Mac, but you could try this...

    Create an address in your address book with the name "do not use this email address" or something that makes it clear that the address is wrong. Then load up the wrong e-mail addresses to this address book entry. Now at least when you type in (part) of the name or whatever that is also part of the e-mail address that you do not want, the suggestion provided will now say "do not use this email address" or whatever you called it.

    Note that I tried deleting the new address book entry, in the hope that the wrong e-mail address would also be removed from the old recipient list but then they just go back to the way that it was.
  • Ed Flores Level 1 Level 1 (0 points)
    So I bought the new iPhone4 and everything was fine....Then I noticed that old email addresse's kept popping up on auto-fill. Not only on one email account , but now they are both synced with the same email addresse's. Not good at all since I emailed a contact from an account that was supposed to be for business purposes only. I tried getting help from Apple , but they didn't seem to know much about it. They said it could be my setting's on Outlook. This is such an annoying problem you would think Apple would of came up with a delete option. Expensive phone ! Does anyone know of a solution ? Apple ? HELP !!!!
Previous 1 2 3 Next