Previous 1 2 3 4 Next 49 Replies Latest reply: Oct 9, 2010 11:31 AM by Carol Willette Bachofner
karlus Level 2 Level 2 (165 points)
Hello, I've got problem to see videos :
I bought yesterday 6 movies, which I can't see in iTunes (9.2, quicktime X, safari 5). I only see a black screen, and no sound at all.
I tried to read one of those movies on another computer (iTunes 9,1, quicktime X, Safari 4) ... And it works !
Does anyone have an idea to solve my problem, considering that the older videos works fine on my computer ? Thanks in advance for your answers.

MBP 17", Mac OS X (10.6.3)
  • roadapple_gl Level 1 Level 1 (0 points)
    I have the same problem, and can't get any answers.
  • Sybil13 Level 1 Level 1 (0 points)
    Same problem with TV shows. TV Shows that I downloaded a few months ago still work fine. I spoke with an Apple person this morning who had me uninstall and reinstall iTunes 9.2. That didn't work. I think 9.2 still has kinks.
  • Dan Buchan Level 1 Level 1 (25 points)
    Yep -- count me in, too. Since the "update" of both 10.6.4 and iTunes 9.2 yesterday, ALL purchased content is UNplayable. Anyone know *** is going on here???

    Here are the steps I've taken so far, and they're all useless:

    - I used the Combo updater (I always use the Combo updater).
    - Permissions repair before and after install.
    - Booted into single user mode and did 'fsck -yf' both before and after install.
    - Deleted ALL cache files (my account and /Library/Caches and /System/Library/Caches).
    - Downgraded back to iTunes 9.1.

    Nothing helped. I still get a black screen (gray for HD videos), and am told "iTunes needs to authorize this computer", then after entering my password in iTunes it tells me that "this computer is already authorized." The only videos that play are ones I've ripped myself from DVDs.

    Looks like I'll be spending a long weekend downgrading to 10.6.3.

    Way to go Apple.
  • aksisson Level 1 Level 1 (0 points)
    Me as well....first time I've tried iTunes for Video......what a waste of money. $60 for The Office Season 6, and NONE of them that have downloaded so far will play. First I uninstalled and reverted back to 9.0 because of the 'Aiuthorize, over and over again issue.

    9.2 was driving me crazy always prompting me to Authorize over and over again. That has stopped, but the screen is blank for every epsiode I try to play. I think this'll be the LAST time I download anything from iTunes.

    PATHETIC!!!!!
  • Bluefang08 Level 1 Level 1 (0 points)
    I am getting the same issue on 10.6.4 with iTunes 9.2. Just purchased a Top Gear season and now all it does is show a grey box with no audio AND keeps prompting me for my password as well...

    ALL of my other shows that I have purchased prior to 9.2 are working fine AND do not prompt me for my password...
  • mkummer Level 2 Level 2 (285 points)
    Same thing here. I bought a movie via iPad - it plays back fine. Transferred here to the iMac - only a grey box and no sound. 9.2 seems to be buggy??
  • aksisson Level 1 Level 1 (0 points)
    I uninstalled 9.2, deleted the Library file, and re-installed 9.0.x The multiple Authorization requests have stopped everytime I try to run an episode, but they are still all grey with no sound. DRM Tech really stinks....doesn't it?

    Sure wish I could decode all of these once they are downloaded. Seems like some kind of refund is in order if I can't even watch what I paid for. That ought to be fun to request.... IF it isn't fixed today...that's what I plan to do.
  • aksisson Level 1 Level 1 (0 points)
    Has anyone gotten any response from Customer support as to why our purchased content will not play? I just wish tehre was a good old fashioned phone number I could call.

    Andrew
  • karlus Level 2 Level 2 (165 points)
    For the moment, I have no explanation from Apple support. Just a clue to solve the problem with identification (erase the /users/shared/SC Info file as indicated here http://support.apple.com/kb/TS1389?viewlocale=en_US ... But this didn't solve the problem !

    Something weird happened when I synchronized my iPhone. In a first time, I was forced to synchronize my TV library (not manually) to put the files on my iPhone (otherwise I got an error message "You're not authorized to view the file on your computer (...)". After that, I lost all my iPhone musics (...). But I didn't have identification request on my computer anymore. ID problem appeared once again when I deleted the SC info file (....................).

    I bought a new TV show, to see if the problem remains on a new file. All works fine !

    To conclude, absolutely no clear answer from Apple support, and one new file with no problem. Still strange.
  • aksisson Level 1 Level 1 (0 points)
    Thanks. I have not yet heard from support either. I too went through the same steps including the SC delete. After degrading back to 9.0 from 9.2 the only good thing I noticed was the "Authorization" prompts stopped. Every episode from my download, however, is not playable. Just grey and no sound like everyhone else.

    Andrew
  • nex9 Level 1 Level 1 (0 points)
    Same problem here. Spoke/emailed 3 levels of apple tech support - no help. Took laptop to Genius Bar & they kept me waiting for over an hour while they screwed around with it, finally told me they want to keep it overnight & will now charge me $85. ***? I was going to upgrade my old macbook to a new macbook pro, but now they just lost the sale for me. Also going to be getting my videos from amazon or netflicks from now on.
  • Mugenteg Level 1 Level 1 (0 points)
    Having the same problem here. I bought some Blu-rays that have digital copies and all I get is a grey box when I try to play them in itunes.
  • sonic11900 Level 1 Level 1 (5 points)
    I'm having the same issue two! Come on Apple fix this!
  • scthiel Level 1 Level 1 (0 points)
    I have a similar problem:


    1) I use the menu to authorize my computer using Store -> Authorize Computer

    2) I open either of the two Top Chef files, and get the prompt "The computer is not authorized to play 'Best Moments'. Would you like to authorize it?"

    3) I authorize by entering my account name and my password.

    4) I get TWO notices popping up at once. One says, "This computer is already authorized." and the other says, "This computer is not authorized to play 'Best Moments.m4v'."

    5) The file begins to play, but with no sound or video.

    6) I open other previously purchased content and the files play fine and I am not prompted to authorize.

    This is a brand-new problem that started with iTunes 9.2. Apple support has not been helpful.
Previous 1 2 3 4 Next