Previous 1 2 3 4 Next 46 Replies Latest reply: Jun 29, 2010 6:47 PM by jeko1 Go to original post
  • jcarvajal Level 2 Level 2
    I removed Stanza and the problem went away immediately, didn't even have to restart. I've still got Kindle, no problems there, but I don't have eReader...
  • rml52 Level 1 Level 1
    You can forward your e-mail containing a pdf (or other file type) to your (free) Evernote account. It's then easy to read in Evernote. Not too hard, and the pdf also becomes searchable, and whatever else you can do with an Evernote note.
  • rml52 Level 1 Level 1
    I meant to point out that this is a workaround for the co-existence of the unpatched Stanza app that apparently is complicating things.
  • flymosez Level 1 Level 1

    I had exactly the same problem as you guys and I've got great help following this discussion, but I solved it a little differently. I tried to fix the problem by deleting Stanza but I still had the problem then I realised that I had two more PDF viewers; QuickOffice and ReaddleDocs.
    The problem was ReaddleDocs. I had choosen to use the Readdle PDF Expert instead od the iPhone OS viewer in the Settings/Viewers menu of ReaddleDocs and by choosing the iPhone OS viewer instead the problem was solved.

  • beaner430 Level 1 Level 1
    I have been having the same problem, PDFs in mail only having the options to "save image" and "copy".

    I tried removing Stanza, that didn't help. I removed the Kindle app and Evernote, and that didn't work either.

    Any ideas?
  • flymosez Level 1 Level 1
    You might have some other app that works as a PDF viewer... (See my answer just before yours)
  • beaner430 Level 1 Level 1
    Thanks, didn't see that one...

    I'll take a look and see if it helps any
  • vaevictis Level 1 Level 1
    I can't figure this one out. I deleted Stanza, Evernote, and even iBooks itself. I don't have Readdle on my iPhone or quickoffice. I had the same problem with pdfs on my iPad, but deleting Stanza fixed it. What other iPhone apps are there that could cause the problem? When I was having this problem with the iPad, it was not a problem with the iPhone.
  • pieroxy Level 1 Level 1
    I had to remove Stanza and eReader, and now everything is fine.
  • vaevictis Level 1 Level 1
    I fixed the issue by following advice from a different thread and deleting Stanza through iTunes rather than simply deleting from the phone.
  • Johann Visagie Level 1 Level 1
    I've deleted Stanza, Air Sharing Pro, Papers and iBooks itself, and the problem still persists.

    I do still have at least one other PDF-capable application that I forgot about — Quickoffice. I'll try that as well. Sigh.
  • Johann Visagie Level 1 Level 1
    …and for the record, it wasn't Quickoffice either.

    Not exactly sure what to do now!
  • Ben428 Level 1 Level 1
    Ok, the following steps, which have been posted elsewhere, worked for me:

    1) Sync with iTunes.
    2) Delete Stanza and Air Sharing from iTunes (both have been reported as causing this problem; I think it could happen with any app that can open PDFs).
    3) Sync again.
    4) Reset iPod by holding down the power and home buttons until the Apple logo appears.

    Having done the following, I was able to open PDFs in Mail and then select the option to add them to the iBooks library.

    I then re-downloaded Air Sharing (I don't ever use Stanza anyway) and everything continued to work.

    One note: I had to delete the apps from iTunes, not simply uncheck them as some have reported as working elsewhere.

    One odd thing, which is probably related but not a big deal: in the "Open in" dialog for a PDF in Mail, the iBooks logo is now appearing on the Air Sharing button, and I've also seen the Air Sharing logo appearing on the iBooks button
  • Max Cascone Level 1 Level 1
    I am not getting the "Open in iBooks" button in iPhone mail, and I DO have Stanza installed. I get the "1 page only as an image!" bug.

    I got it to work quite easily by opening Gmail in iPhone's Safari. Open the message in Gmail and the "Open in iBooks" button is automatically there, without removing any apps or anything like that. ( do they do that?...)

    Give it a few moments to think and it will transfer the PDF to iBooks. It's really quite nice-looking.

  • potpourri Level 1 Level 1
    I, too, have problems getting mailed pdf's onto my 3G iBooks PDF bookshelf, so I took my ios4 3G iPhone and my iPad to the genius bar saying I wanted to see the PDF bookshelf in iBooks on both devices. The great genius couldn't do it either and said maybe this was corrupted because I did an upgrade to ios 4 instead of treating my phone as a new phone and asked if it was ok with me to do a reinstall as a new phone and I said yes since my imac's iTunes has everything on it I can put back on my iPhone. It appears that to get the PDF bookshelf on my iPhone that the PDF bookshelf has to be "initialized" first via safari so she found a govt PDF little file on the web and then once we picked the option to open with iBooks appeared, I had a PDF bookshelf on my iPhone. (Later, to get the PDF shelf in iBooks on my iPad, I had to drag a PDF file to the books folder in iTunes which then "initialized" the PDF shelf and allowed me to synch a PDF file to iBooks on my iPad.

    What I really wanted to do is to create an iPad Pages document with embedded pictures and get it on my 3G without having to synch devices. Mailing the Pages doc to my MobileMe I'd made the PDF viewable in email, but there was no option to store it in iBooks. So I exported my ipad's Pages doc to Iworks and then from my MobileMe I'd on my iPhone I opened the invitation to view the doc and was presented with option to open with iBooks and doc is now on my PDF bookshelf (with no syncing of either device with iTunes).

    This doesn't solve all the problems with pdf's but it solves my problem. Maybe this will be helpful to some of you.