Skip navigation

iOs4 upgrade, Now car stereo doesnt work with iphone

236776 Views 539 Replies Latest reply: Feb 21, 2012 9:32 AM by KiltedTim RSS
  • Mr.Rage-Quit Level 1 Level 1 (0 points)
    Hey i just purchased a new 2011 Mitsubishi lancer with the sound system upgrade (Mitsubishi Fuse, Similar to the Microsoft Sync) and i am unable to connect my iphone 4 via usb to it, it is not getting detected by the system. Music does play back with bluetooth but controls are very limited via the radio. I am unable to get voice control to my iphone unless i have it pluged in via USB ( Tried this with my older sister ipod nano 3rd gen). Same goes with my dad's Onkyo amp that was the latest model from 2010 (Sound comes out but cant use the remote or use the video playback). From what I read on this forum this problem been there since V4 of the ios. I am surprised that this issue has been an ongoing problem through the upgrades done to the Ios and figured it would be fixed. I have contacted apple and the only thing they said is it to check for firmware upgrade for my hardware and to reset the iphone. Seem like that what they always say, it the other hardware that at fault or try resetting your device. From this thread i can tell its an apple issue seeing how large the list of affected hardware is.
    iOS 4
  • tnttroy Calculating status...
    After a month of trying, I finally got a hold of JVC support.
    They gave me a file to update my KD-R600 JVC car stereo with instructions however the stereo would not take the updated file.

    I called them back and they said that they had discovered the file will not work and not to bother trying. They said the reason the file would not work is that Apple had stopped working with them to attempt to resolve the problem. Another punch in the face from Apple - not impressed with either company right now to be honest.

    This will be the last product I ever buy from Apple
    iPhone 3GS, iOS 4
  • another_alias Calculating status...
    Just to add another voice to the chorus: iPhone 4 and 3G both running iOS4.2.1. The 3G used to work in our Volvo XC60 using the USB connection prior to "upgrading" to iOS4. Neither phone now works.

    With so many different car stereos being affected, this is obviously an Apple problem. If they changed the API or whatever either fix the issue so that existing equipment will work again, or provide information to the manufactures so they can update their firmware.

    Very poor responsiveness on this on by Apple. Very disappointing.
    iPhone 3G, iPhone 4, iOS 4
  • tnttroy Level 1 Level 1 (0 points)
    While attempting to fix another problem (GPS not working correctly) I may have come close to a solution to this as well.

    In a final attempt to get my GPS working on my phone, I completely reset it and did not use a backup. This fixed the GPS problem, which is caused by the GPS cache files not being deleted...

    As an after thought, I plugged my iphone into my car stereo and was able to forward/reverse a song but this caused the phone to disconnect.
    I plugged it back in and tried to go from head to iphone mode and that worked....for a second then it disconnected.

    I havent had a chance to play around with it but that's one step closer than i was before....
    iPhone 3Gs, iOS 4
  • Nobody5000 Calculating status...
    Same problem with my 2011 Mitsubishi Lancer. Just upgraded to iOS 4.3 and guess what? IT STILL DOES NOT WORK Thanks apple you really came through on this one.

    Message was edited by: Nobody5000
  • not_the_messiah Calculating status...
    Upgraded to 4.3 last night and after a bit of playing around, I have managed to get A2DP streaming working on my Pioneer P80BT!!

    Now, I am not sure if this is a fix from 4.3, or if I never tried this particular solution before, but it works, so I am happy!

    In a nutshell, what I did was to forget the device in the phone itself and delete the iPhone settings from the P80BT unit. I then went to pair the phone, but instead of searching, I paired my iPhone (3GS by the way) with the P80BT from the phone. Once this had worked, I noticed that both the headset and the phone lights were lit. I then opted to download the phonebook and the headset light went off! :-| Bugger.

    Tried then going into BT Audio menu and connecting manually using the iPhone profile, which didn't work. However, after more fiddling and playing around, I tried the STANDARD BT profile in BT Audio and it works a treat!! Now I cannot remember if I tried the Standard profile under 4.1/4.2, so I don't know if this is a fix as of 4.3, but it works :-D

    Hope this helps someone

    Tim
    iPhone 3GS, iOS 4
  • PeterCoox Calculating status...
    iPhone4 with iOS4.3 plays perfectly using the Mercedes-Benz iPod Interfacer Kit but doesn't recharge. iPhone2 with iOS 3.1.3 however does charges without problems. Can you please fix this with the next update? Tnx.
    iPhone4, iOS 4
  • Addiction Calculating status...
    I just upgraded my 3rd gen touch to 4.3....

    I am happy to report that this once again works with my Alpine ida-x001. So for those who have the same head unit and had a connection issue it has been fixed. Well, I hope I am not a special case anyway.
    Windows Vista
  • jplatts Calculating status...
    I've just upgraded my 3GS to os 4.3 and tested it with my 2010 Volvo V70. It works fine - not the first time, but after disconnecting and then connecting again it works fine and also charges the phone.

    I still get the message on the phone that this isnt assuported device, but I can live with that
    Dell PC, Windows XP
  • robogobo Level 2 Level 2 (290 points)
    hey boys and girls, Apple does not officially monitor these forums. So anyone expecting a reply from them on this matter, don't. Instead, file official feedback, which they do read and listen to.

    http://www.apple.com/feedback/iphone.html
    MacPro 4x2.66, Mini C2D1.83, iMac 6,1, iPhone3Gs, Mac OS X (10.6.4), 23" ACD, 30" HP LP3065, Epson V700Pro, Epson 3880, Canon 5Dii
  • tnttroy Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 8:46 AM (in response to jplatts)
    The 4.3 update did not fix the problem with my JVC KD-R600
    Once I plug it in, it just plays straight - no controls and cannot switch to ipod mode/head mode.

    Maybe Apple SHOULD start paying attention to these forums - when I spoke to support they said they weren't aware of any problems....shesh.....
    iPhone 3GS, iOS 4
  • Nobody5000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 11, 2011 6:04 PM (in response to tnttroy)
    Spoke to someone from apple support yesterday regarding this. All the guy did was search these forums to see if he could find a solution. After he couldn't, he told me it wasn't an Apple problem...
    Mac OS X (10.6.6)
  • tnttroy Level 1 Level 1 (0 points)
    Of course it isn't - It's a JVC, BMW, Lexus, Pioneer and every other third party manufacture of radios that supported Apple out there.

    Toss Apple some more money for extended support and they can't do a thing to help you....
    iPhone 3GS, iOS 4
  • n11bot Calculating status...
    My iPhone 3GS now (at last) working again via USB with latest OS 4.3 in my Volvo V70 2010 albeit with warning message showing on device that reads something like 'this accessory is not compatible'. Episode has not left me with a warm glow. Shall take a good look at the alternatives when selecting my next phone.

    Volvo iPod interface still rather 'clunky' to use but at least the phone is on charge whilst being able to access its iPod functions so better than just having a USB memory stick with the same media on it. Does not feel like the cutting edge of science.
    iphone 3gs, iOS 4
  • CBrentL Calculating status...
    My iPhone 4 has worked fine with my Kenwood KDC-MP345U for months. I got home, updated my iPhone to iPhone 4.3, and went to leave again and it no longer worked, so the update obviously screwed something up. It tries to play, I hear what I want to play but it is stuttering to the point where you can't make out a single word, and on the screen of the stereo it just constantly says "Reading..." but doesn't fully load up. I sent this in as a bug as well, so hopefully something will come from it.

    For what it's worth, it still charges my phone, but to get it to play correctly I have to hook it up with an auxiliary cable as well, so to charge and play I have two cables going from it at the same time. Not cool...
    Windows XP

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.