Previous 1 2 3 4 5 6 Next 114 Replies Latest reply: Apr 19, 2011 11:15 AM by lampjewortel Go to original post
  • Outlaw69 Level 1 Level 1 (0 points)
    Hard reset while connected to car radio fixed it
  • Lanttu Level 1 Level 1 (0 points)
    Same problem here. At the moment I am restoring my iphone to older version. My Car stereo is Pioneer DEH-5100UB which was working perfectly whit older version.

    Now if I just plug my iPhone in, it says Error-19 and my iphone keeps making Connect and Disconnect sounds until it says that my car audio system isn't compatible and might not work well.

    Hard reset will work for a while, but randomly on skip, mute or some other control takes iphone out and I have to reset it once again. I dont like this manouver, because it wasn't necessary with the older versio.
  • sb1165 Level 1 Level 1 (0 points)
    Dear all,

    it appears more and more to be definitve a general problem with iOS4, and only a handful of you could fix this issue - why ever.
    Since there is only the statement of german Apple support "that they're not willed to do anything", it would be a good idea not only to post the problems here in the forum, but to contact Apple support in your country.
    As more of you will do this, they will (perhaps) change their position and will release short timed a solution respectively update (two days ago they released the first update to solve the issue with the carrier detection).
    If anyone of Apple reads this, it would be great if you help us to solve this issue!!
  • martywaz Level 1 Level 1 (0 points)
    just recently bought the 2010 Infinite M37. I connected the new iPhone 4 to it via the USB cable. It showed connected in the M37 display dash....even showed the typical navigation menu (i.e. playlists, artists, songs, etc). However, I was unable to navigate at all in the menu (it appeared locked....and yes, i had entered my passcode on the iPhone , or play any songs. Also, when I played Pandora, it also did not go through the car speakers.

    I've always bought the Infiniti's.....and they've always worked with my iPhone 3G. Looks like either this car is an exception, or something has significantly changed with the iPhone that prevents it from working.

    My question is: I wonder if Apple is working with any car manufacturers to address this. My guesss is that other cars will have this issue with the new iPhone.
  • crash02 Level 1 Level 1 (0 points)
    To start with I have tried all the "fixes" in this thread with no luck at all with either of our phones.

    I am having troubles with both my 3GS and my wife’s iPhone4. We are both running iOS4. We have a 2010 Chevrolet Silverado with navigation and both phones do not work correctly with it. My 3GS worked perfect until the update. Neither phone is able to search by artist. If you bring up the artist section it will become non-responsive. The Album section will still scroll as well as the song section. Both phones will give the not made for iPhone popup too. We still have her old 3G running on the 3.1.3 software and it works fine.

    I also just purchased an Alpine IXA-W407 this week. Both my 3GS and her iPhone4 are very unstable with the head unit. You can't search by artist when using the search by alphabet option. It will make the head unit lock up. It will also throw the not made for iPhone error sometimes. Sometimes it will say that there is no USB connected when the phone is connected.

    Apple please fix this issue ASAP. I just paid $700 for this head unit that no longer works with the new software.
  • dma28 Level 1 Level 1 (0 points)
    This is absolutely correct. The fallout of the latest iOS4 update in terms of not being able to utilize the music playback function in your cars is not a small issue since it probably affects millions of people world wide. As such, it is probably not one that Apple is likely to ingnore. However, they need to hear about the problem directly from their consumers, so, if you have posted on this thread, be sure to notify Apple through their support contact options:

    U.S. Technical Support: 1-800-APL-CARE (1-800-275-2273)

  • wrenbro Level 1 Level 1 (0 points)
    I had the same problem with my Lexus ES 350. The reset of settings did the trick!
  • pedXing Level 1 Level 1 (0 points)
    Having the same trouble as everyone else. I have an Infiniti g35, audio streaming no longer works in the car. I alse have an harmon/kardon home audio "bridge" docking station for my house that no longer works because of the 4os. Does anyone know of a way to revert back to the old working os? This is EXTREMLY frustrating.
  • Sebasbo Level 1 Level 1 (0 points)
    I have a Pioneer AVH-P3200BT and had the same problem. Took no chance and did the "settings reset", then turned off my iphone before plugging it in my radio turned on. As I plugged it, it turned on by itself and now it works perfectly.

    Problem solved for me !

    Good luck everybody.
  • Lanttu Level 1 Level 1 (0 points)
    Hi everyone

    I agree that you really should call to Apple and make yourself heard.

    (removed the rest)

    Right. I have nothing to complain.
  • Mr. Intense Level 1 Level 1 (0 points)
    Upgraded to OS 4.0 and my iPhone won't talk to my car stereo any more. I am not happy. I got less than one year from each device. This needs a fix!
  • pcrules Level 1 Level 1 (0 points)
    It appears that the hard reset (turning the phone on while connected to the car USB) works for some car manufacturer's and doing the Settings > General > Reset > Reset All Settings works for others.
    I have a 2010 Nissan Altima and the resetting of the settings worked. I called Apple and informed them that this issue looks like the car manufacturer is the difference in resetting or not. They said they are working on a new version due out in month.
  • xzetra Level 1 Level 1 (0 points)
    ACURA\HONDA vechicles are having the same problem. Reseting general settings fixes the problem.
  • eramib Level 1 Level 1 (0 points)
    To audiocenter:
    Which isimple system to do you have? I have an Odyssey & just had the PXAMG installed & it worked fine with my itouch running 3.1.3...after upgrading to 4.0 and connecting it, I keep getting this pop-up that this accessory is not supported. I also just read that "This product is not compatible with iPhone or iPod touch running iOS 4 (6-21-10).Use of this product with an iPhone or iPod touch with iOS 4 requires the PXAMG-IC hardware upgrade"
    So now I'm curious since you only had to do a "reset all settings"
  • sartalon Level 1 Level 1 (0 points)
    Wow, I guess Apple forums have trolls too.
Previous 1 2 3 4 5 6 Next