Previous 1 2 3 Next 71 Replies Latest reply: May 6, 2012 11:34 AM by BAMA10
T.Edwards Level 1 Level 1 (20 points)
I keep getting sound alerts saying I have a new email (which I do because they come through on the laptop) but the iPhone doesnt bring them up

Also I'm getting unread messages dates 01/01/1970, 01/01/2000 etc (which are blank emails)

The iPhone also doesn't sync back to my laptop when emails have been read.

Anyone else having the same?

MacBook (4GB), Mac OS X (10.5.4)
  • JayPeeEss Level 1 Level 1 (25 points)
    No problems here.

    I have four email accounts (two .mac, one work exchange, one web based account).

    I have had problems previously with MSN mail re-loading old emails even though deleted so stopped using the service BUT this was on a 3G iphone, not specifically the new one.

    I would suggest (assuming you didn't already) is delete the account and try re-creating to see whether this clears and internal 'cache' or other problem.

    Cheers JPS
  • Drew Thoeni Level 1 Level 1 (0 points)
    Yes. My Exchange server email sporadically says it can't send mail (then does a few minutes later) and says it can't move mail to the trash (then I try a bit later and it works). All of this is on WiFi, so it's not an issue with the 3G connection. I suspect there is a bug in the updated Exchange service that comes with iPhone 4.
  • iihavokii Level 1 Level 1 (0 points)
    I just started receiving "blank" messages (No Sender, No Subject)...funny thing is that some of them are dated 12/31/69.
  • Ironman_Walt Level 1 Level 1 (0 points)
    I have the exact same problem. The phone shows I have messages but they are not in my inbox. Later i have unread blank messages at the bottom of my inbox with dates that are 30 and 40 years old and are blank. It is very frustrating and I hope they solve the problem soon.
  • tool Level 2 Level 2 (320 points)
    I upgraded my 3G S iPhone to iOS 4 just before i purchased my new iPhone 4. Before i upgraded to iOS 4 on the 3G S - my e-mail was all working correctly. (I have about 20 different e-mail accounts that i manage and it's really important that they all work for me). I know i didn't change any settings before i upgraded to iOS 4. But after i did so, i was unable to receive any new mail, and i couldn't send any mail out.

    When i got my iPhone 4, the same thing happened - so that made me really think that it was an issue with iOS 4 (not the iPhone, or the e-mail settings, etc).

    What i ended up doing was just erasing all of my accounts off my iPhone manually, and then re-adding them one at a time and checking each one as i add it to make sure that it can send and receive e-mail.

    This was a time consuming process since i have so many e-mails. However, when i added them all in - it didn't want to download all of my pre-existing e-mails that should all be in my inbox, so basically all of my e-mail inboxes were empty when i re-loaded them onto the iPhone.

    I just took the most important messages off my computer and forwarded them to the same e-mail address so that i could receive them on my iPhone. Everything seems to be working at this point.

    Hope this helps!
  • jax44 Level 1 Level 1 (30 points)
    I have mobileme, have for three years. Mail is not pushing to the iphone4, it will sync instantly when I hit the Mail button. Also, when I read an email (on the phone) it will still show up as unread sometimes.

    Dave
  • clemclemmons Level 1 Level 1 (0 points)
    I have only 1 email account. my inbox reports 28 emails, but I have none. Every time I receive and email it tells me that I have 2. I delete the email it shows that I still have 1. So I have received and deleted 28, but it shows that I still have 28. (yes it actually displayed "Inbox54" before I deleted the actual 28. please advise.
  • JPBOSS Level 1 Level 1 (70 points)
    I had same issue with the blank, unopenable, 1969 e-mails and I rebooted phone (not the single boot but holding butttons until apple icon shows twice and phone stays off when buttons released), then powered it back up and issue went away and hasn't been back. I am sure it's related to a bug in iOS4 with the major changes to the e-mail app and sure it will be resolved soon. I would hate to be in the closed-door meeting at Apple over this antenna issue. It's just a matter of time before it hit's the fan.
  • gkiester Level 1 Level 1 (0 points)
    I have the iPhone4 and i have 2 yahoo accounts and 1 exchange account and I am receiving the correct emails and can read the body of the email in the preview only. Once I open the email to view it the message shows up blank. This just started doing this a few hours ago. Email worked perfect all day yesterday.

    I too would like to understand what is necessary to fix this.

    Thanks,
    Greg
  • saltysmith Level 1 Level 1 (0 points)
    This is happening to me and my Partner both With iPhone 4's and both with Mobile Me Accounts this never happened to me yesterday only started a few hours ago just like gkiester

    I have dont a soft rest of my partners phone to see if that works it does for a few mins then more emails appear blank ones dating back to the 1970's

    Apple we need a fix for this come on is it a iPhone 4 prob or iOS 4 prob


    Thanks

    Chris
  • MacDavid Level 1 Level 1 (0 points)
    Yes, having the same issue. I think it's an iOS 4 issue because i started having it when I upgraded my 3G on Monday. I thought the new phone would fix the problem but it persists with iPhone 4. I clearly have a new message, the Home screen indicates it and it shows on my laptop, but the iPhone mail app does not display it, or it shows at the bottom of the list as empty with a date in 1969.

    THIS IS A MAJOR PROBLEM THAT NEEDS TO BE FIXED.
  • C St Amand Level 1 Level 1 (0 points)
    I am also receiving blank emails with strange dates but show only on the iPhone - not on my computers web-base email. Also, loading new emails on iPhone is spotty. Looks like the blank ones represent the new emails that do show up on computer. I did a reboot on phone and so far so good. This problem appeared right away on Wednesday after switching to new phone.
  • Derald Level 1 Level 1 (65 points)
    I had this problem yesterday, I played around with the mail box for awhile, managed to delete an unread message. I finally found that the new mail is not like the 3gs mail. It now seems to group mail in some sort of category. I also had about ten of the 1969 no content no sender messages. I finally figured it out but I cannot explain it. I suggest you consult the I phone 4 user guide (i downloaded mine to my desktop) I believe we will all find answers in there. Here it Is:
    http://manuals.info.apple.com/enUS/iPhone_iOS4_UserGuide.pdf
  • Bob3868 Level 1 Level 1 (0 points)
    Same thing here. I hear my phone go off and the number pops up telling me I have 2 messages and when I go to my mail, nothing there. Now if I wait a while it will eventually show up.

    When I plug in my phone into the computer I am always hoping for an new update. Nothing yet.
Previous 1 2 3 Next