Previous 1 2 3 4 Next 57 Replies Latest reply: Feb 1, 2012 4:37 PM by Peacenik06
Jasong618653463 Level 1 Level 1 (45 points)
Anyone else having this problem? It's working pretty good for me right now but for most the day it has been loading pretty slow or mostly not at all even though I have full service. Is it the phone or is it AT&T?

iPhone OS 3.1.3
  • shaye2k Level 1 Level 1 (0 points)
    Yes im having this problem as well. Called both AT&T and Apple and just when i think i have it fixed my wife's iPhone 3G cooks my iphone 4 in loading websites. Please tell me this is just something with 4.0 that can fixed with a software update! I love my iPhone 4 but these problems (signal issue) are worrying me.
  • iPhone Lexington Level 1 Level 1 (40 points)
    I got the free Speed Test app today at the App Store. 3g speeds are blazing compared to my iPhone 3g. Remember, speed is a network issue as much as a phone issue. Got to macrumors.com and scroll down to see speed test results today too.
  • EBSkater Level 2 Level 2 (490 points)
    iPhone Lexington wrote:
    I got the free Speed Test app today at the App Store. 3g speeds are blazing compared to my iPhone 3g. Remember, speed is *MORE OF* a network issue *AND NOT* as much OF a phone issue. Got to macrumors.com and scroll down to see speed test results today too.
  • shaye2k Level 1 Level 1 (0 points)
    I ran this test with my wife's 3GS and my iPhone 4....not only was she getting better DL and upload speeds she also had a much lower ping around 300...mine being around 7000. Can anyone make sense of this? Apple acts like I'm being to picky but when it takes 80 seconds to bring up yahoo I believe there is something wrong.

    I'm hoping that this is something to so with ios 4.0 but with the lack of complaints I'm seeing about this I'm starting to believe I may just have a lemon.
  • RetardedGoat Level 1 Level 1 (0 points)
    I am having the exact same problem!

    Honestly, it's good to hear I'm not the only one. I took it into the Simply Mac store where I bought it and at first the guy told me sometimes 3G is slow and it just depends on the service area blah, blah, blah. Then I placed it on the desk right next to my girlfriend's iPhone 3Gs. Her phone was screaming fast while mine would actually timeout. He just told me to wait for an update. I really hope they fix this problem soon. It's very frustrating.
  • njdanny84 Level 1 Level 1 (0 points)
    I have been having the same problem. It takes about 60 seconds to load yahoo. All my other apps that require internet are also very slow. I called apple and at&t and one of the at&t tech told me to exchange the sim card. Hope this fixes the problem, I'll be going to at&t tomorrow.
  • Tekzilla Level 1 Level 1 (0 points)
    Having the same exact problem. Time outs left and right. They better get us a fix ASAP.
  • Helicop Level 1 Level 1 (0 points)
    Same problem here, SLC area. My data performance has been TERRIBLE. Most of my speed tests are 10,000+ ping and 0-75 kb DL and 0 upload!!! I can't do anything with the internet. There are periods during the day where it actually works like my old 3GS, then it craps out again. I also have a list of other issues (sensor problem putting calls on hold and randomly dialing other people, taking up to a full minute when making a call before it starts ringing, dropping 8 out of 10 calls where I can still here people but suddenly they can't hear me.....) I love the phone itself, it's gorgeous, but seriously, these issues are killing me!!This things getting returned if something doesn't get fixed SOON.
  • Willywonker Level 1 Level 1 (0 points)
    I have been having the same problem too. Sometimes fast, sometimes it would load about 10% and freezed for 60 secs then when it started to load it would load quickly. I also kinda noticed that it was running fast when I first used it until I synced it with my previous 3Gs phone restore. I think the problem might be the network settings get skewed when going from 3Gs to iphone 4. I reset my network settings (Settings>General>Reset>Reset Network Settings) and I haven't had an issue since. It has only been 1/2 day, but everything has been loading ok. Give it a shot. I'll let you know if it starts to lag again.
  • Willywonker Level 1 Level 1 (0 points)
    BTW - Has anyone else experienced how slow music transfers from itunes to iphone 4? Is it just the way it is or is it b/c I checked the box to convert music to 128 blah blah blah prior to syncing? Let me know...
  • NateBMac Level 1 Level 1 (0 points)
    I've had the same problem. It's fine on wifi and Edge but slow/not working on 3G. I just got back from AT&T where they replaced the sim and I still have the same issue. Next up is Apple I guess.
  • RetardedGoat Level 1 Level 1 (0 points)
    Now that you mention it, I don't think I had the problem until I synced for the first time. I did try resetting my network settings, but no dice. Still slooooow.
  • tuuky Level 1 Level 1 (0 points)
    Just wanted to echo the same issue here. Tried resetting network settings, but nothing seems to have changed.
  • Willywonker Level 1 Level 1 (0 points)
    Yeah, mine did eventually go back to spurts of fast and slow. I thought I experienced the same slow down through wifi, but I am unsure. I will double check, but def through 3G signal.
Previous 1 2 3 4 Next