Question:

Question: Mojave 10.14.4 fails to Authenticate Gmail account

Just update to Mojave 10.14.4 and now Apple Mail will NOT connect to one of my Gmail accounts.


This issue is UNIQUE to Apple Mail as I can access the Gmail account using Spark on the same computer without issues.


This issue is UNIQUE to Mojave 10.14.4 as it did not exist with 10.14.3 and it does not exist on another computer running an earlier version of Mac OS X.


The issue puts me in an endless loop. I get a notification "Google requires completing authentication in Safari." This takes me to a Sign in dialog where I enter email account and password. Password is correct and accepted, after which I'm back in the loop again asking to enter Google Password.


If I login to my Google account in Safari I can see the recent events that I signed in without any problems on this Mac, but Apple Mail does NOT connect and I am back in the endless loop.


Oddly I can add events to the Google Calendar for the account so apparently something is amiss strictly with Apple Mail.


Suggestions?

iMac 27" 5K, macOS 10.14

Posted on

Reply
Question marked as Helpful

Apr 2, 2019 12:22 AM in response to Ken Graham In response to Ken Graham

Finally a 100% working solution is very simple.

In safari: logout from your google suite account (to make sure you will fix the right one).

Go to https://accounts.google.com/DisplayUnlockCaptcha to repair the access (documented on https://support.google.com/accounts/answer/2461835?hl=en)

after fixing add the account in the mac os settings or over the mail app as usually (you don't even need to delete it first if it's already added).

After verification in the opened safari window everything will go well.


The trick was simply to fix the password with the google link

Question marked as Helpful

Mar 26, 2019 8:31 AM in response to Ken Graham In response to Ken Graham

I'm having the same issue with my company's G Suite account starting today, after updating to 10.14.4.


Mail and Calendar both require my password as soon as I log in again. Added another G Suite account, it worked fine.


My company uses G Suite with OneLogin as SSO. The log in process seems to work fine.


Enter the password for the account “(null)”.

Google requires completing authentication in Safari.



Question marked as Helpful

Mar 26, 2019 9:25 AM in response to macendo In response to macendo

UPDATE:

I contacted Apple and spoke with a tech support person, shared my screen so he could see what was happening. He verified that it is legit. Continuing with the process for each account, I was able to get my accounts online.

IF for some reason you do not get the prompt, click the sideways lightning strike (my description) next to the account that's offline, and you should then get the prompts to authenticate.

Question marked as Helpful

Mar 29, 2019 10:52 AM in response to Ken Graham In response to Ken Graham

Someone with the handle Gannett posted a fix on the MacRumors website and it worked for me. I don't know how to link directly to his post so I'm pasting his instructions below. The fact that he figured out a solution shows just how neglectful Apple has been about this problem.


Anyway, these are Gannett's instructions:


Okay, so I've tried to make this as easy as possible. We're going to use Charles to rewrite a response from google to include the email address which is for some reason missing in google's own response. This is a one time setup only needed for verification.

  1. Download, install and run Charles.
  2. If this is your first time using Charles it should prompt you to authorize automatic proxy configuration. Do this. (Otherwise just make sure the macOS proxy is enabled and working)
  3. From the Help menu choose SSL Proxying > Install Charles Root Certificate.
  4. Once the certificate is installed, find it in your keychain (type Charles into the search), open it, expand the Trust section and set to Always Trust. You will be prompted for your password when closing it.
  5. Back in Charles, from the Proxy menu choose SSL Proxying Settings.
  6. Add a new location with Host: people.googleapis.com.
  7. From the Tools menu choose Rewrite and click the Add button.
  8. Add a new location with Host: people.googleapis.com.
  9. Add a new action with the following details...
    • Type: Body
    • Where: Response
    • Replace Value: {"names":[{"metadata":{"primary":true},"displayName":"Your Name"}],"emailAddresses":[{"value":"your@email"}]}
    • (Make sure you put in your name and email address)
  1. Once you save this, we're all set. Go to your system Internet Accounts or (Mail) and authorize your account.
  2. If everything thing is working, you can quit Charles and feel free to delete the certificate from Keychain.

Question marked as Helpful

Mar 26, 2019 2:06 PM in response to Ken Graham In response to Ken Graham

Google support was able to resolve this issue for me, or at least provide a suitable workaround for my accessing mail*.


We were able to delete the account and them re-add it as an IMAP account as follows**.


User name: full email address

Incoming server: imap.gmail.com

Outgoing server: smtp.gmail.com


*Please note that this does not resolve calendar or contact syncing.

**Gmail must be set to allow less secure applications. This setting can be enabled in the Gmail web client under settings/security


Question marked as Helpful

Mar 26, 2019 10:46 AM in response to Ken Graham In response to Ken Graham

I was able to set up my gmail account the old fashioned way, using 'Add Other Account..." and add smtp and imap info manually... It doesn't bring in google calendar, but my email account is working again on Mojave, and iOS 12.2, which was experiencing the same issue for me.

Question marked as Helpful

Mar 26, 2019 9:41 AM in response to Ken Graham In response to Ken Graham

Same here. Things I've tried and failed so far:


-Removing and re-adding account

-Changing password

-Removing 2 Step verification for Google account

-Removing Google password from Keychain

-Enabling "less secure apps" on Google


Nothing worked and caused me hours. Shame on you Apple. Really. How can you miss that?

There’s more to the conversation

Read all replies
Question marked as Helpful

Mar 26, 2019 8:31 AM in response to Ken Graham In response to Ken Graham

I'm having the same issue with my company's G Suite account starting today, after updating to 10.14.4.


Mail and Calendar both require my password as soon as I log in again. Added another G Suite account, it worked fine.


My company uses G Suite with OneLogin as SSO. The log in process seems to work fine.


Enter the password for the account “(null)”.

Google requires completing authentication in Safari.



Mar 26, 2019 8:31 AM

Reply Helpful (17)
Question marked as Helpful

Mar 26, 2019 8:54 AM in response to WesleydeSouza In response to WesleydeSouza

I have tried removing and re adding but it has not fixed the issue. Also, I left the account that first had the issue removed and now another one of my gmail accounts has the issue.


Mar 26, 2019 8:54 AM

Reply Helpful (5)

Mar 26, 2019 8:58 AM in response to Ken Graham In response to Ken Graham

I am also having the same problem after updating to 10.14.4.


I have 4 other google accounts for which authentication works correctly.


I also have a second Mac, and it fails for the same google account on both of my Macs.


I tried enabling 2FA on the unauthenticatable account, no luck.


I also tried setting my default browser to Chrome, but Mail.app just interacts directly with Safari.

Mar 26, 2019 8:58 AM

Reply Helpful (3)

Mar 26, 2019 9:00 AM in response to Ken Graham In response to Ken Graham

I have multiple google accounts, one of which is a GSuite account, others are regular gmail accounts, and all are asking me for this. I googled this b/c I was concerned this may be some sort of malware causing this. The window that pops open does have a url that begins with https://accounts.google.com/signin/oauth/identifier?client_id= so it seems legit, however since it opens in a url which does not have a full browser heading, it is not possible to see information about the site. On my machine, Safari is not my default browser, however this site opens in Safari, which makes me more inclined - but not entirely convinced - it's legit.

Mar 26, 2019 9:00 AM

Reply Helpful (2)
Question marked as Helpful

Mar 26, 2019 9:25 AM in response to macendo In response to macendo

UPDATE:

I contacted Apple and spoke with a tech support person, shared my screen so he could see what was happening. He verified that it is legit. Continuing with the process for each account, I was able to get my accounts online.

IF for some reason you do not get the prompt, click the sideways lightning strike (my description) next to the account that's offline, and you should then get the prompts to authenticate.

Mar 26, 2019 9:25 AM

Reply Helpful (11)

Mar 26, 2019 9:42 AM in response to dboroditsky In response to dboroditsky

I went to this apple page https://support.apple.com/contact, and clicked "Get Help" under "Talk To Us." After I logged in, selected my computer, and then selected "Installations & Updates," and entered my phone number, I received a phone call from a tech at apple immediately.


Hope this helps

Mar 26, 2019 9:42 AM

Reply Helpful
Question marked as Helpful

Mar 26, 2019 9:41 AM in response to Ken Graham In response to Ken Graham

Same here. Things I've tried and failed so far:


-Removing and re-adding account

-Changing password

-Removing 2 Step verification for Google account

-Removing Google password from Keychain

-Enabling "less secure apps" on Google


Nothing worked and caused me hours. Shame on you Apple. Really. How can you miss that?

Mar 26, 2019 9:41 AM

Reply Helpful (5)
User profile for user: Ken Graham

Question: Mojave 10.14.4 fails to Authenticate Gmail account