Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Updated to iOS 14 and now mail sends from wrong email address

I have a preferred email address in Apple Mail (which is an alias) and use three other aliases for subscriptions etc.

Since updating to iOS 14 on my iPhone 11 when I select my preferred alias for the From field, the emails are being sent from one of the other aliases - but I don't know this is happening until the email is sent.

I went in to preferences and disabled the alias Mail was choosing - and it duly elected the next alias. So I disabled that address too, and it picked another...

After disabling the 3 aliases my preferred alias email address was next up - only I use a .mac suffix and the iphone is choosing to send it with a .me suffix. And I can't disable that.

Basically I can no longer send emails from my iPhone unless I use an address I don't want to use.

No issue on my iPad (which is running 13.7) nor macbook. It's happened following iOs 14 update on my phone.

I haven't seen any other posts about this. I went onto Apple chat and after 1 hour of hanging on and making zero progress (the support people are clearly handling several users at the same time and all you see is that they're typing... just not to you).

Thanks


iPhone 11 Pro

Posted on Sep 18, 2020 1:48 PM

Reply
Question marked as Solved
Answer:
Answer:

Stop sending me emails,I have no issues with wrong email address

Posted on Oct 14, 2020 10:37 AM

Question marked as Helpful

Oct 20, 2020 10:11 AM in response to wesley-nl In response to wesley-nl

Look’s like its finally fixed in iOS 14.1! This is from the release notes: “Fixes an issue where some emails in Mail were sent from an incorrect alias”. I haven’t updated so can’t confirm it’s been fixed but looks promising.

Oct 20, 2020 10:11 AM

Question marked as Helpful

Sep 22, 2020 5:05 AM in response to dingsquidge In response to dingsquidge

Had same problem. iOS 14 broke mail sending both iPad Mini and iPhone XS Max. “From” would always be from an alias. Even though I did not have it selected when sending.


SOLUTION:

Settings / tap your name / then tap iCloud.

Scroll ALL the way to the bottom.

Tap Mail.

Switch off (allow sending from) all your aliases.


Definite iOS 14 bug!


Sep 22, 2020 5:05 AM

There’s more to the conversation

Read all replies

Sep 19, 2020 3:15 PM in response to Carob Apps In response to Carob Apps

update. It gets ever more bizarre.

I have 4 alias email addresses. I’ll name them A, B, C & D


Emails I compose (new, not in reply) to send from A, B or C are all being sent from D. I select A or B or C in the ‘From’ field, compose and send - but the email sends from D. It shows in my sent folder as from D.


But when I send an email from D the email is actually sent from A. 🤔


When I reply to an email sent to A, the reply is sent from A.





Sep 19, 2020 3:15 PM

Reply Helpful (3)

Sep 19, 2020 3:37 PM in response to dingsquidge In response to dingsquidge

I too am having this problem. I have an IMAP account (not gmail) with a few aliases. I have been using this for YEARS and it's always worked fine. Today, I sent my first email from iOS 14 and it changed my from address after I sent the email. Note, the *correct* address was selected in Mail - it was changed during sending. I then sent some mails from other aliases, and those were also all wrong - never the right address. After some trouble shooting, I deleted all of my aliases except for the main address. It worked fine. I added back just 1 aliases and the same behavior occurred. Selecting alias 1 in the new email resulted in a message sent from alias 2. Selecting alias 2 resulted in alias 1 being used.


I then double checked on my iPad, and the same thing occurs. For now, I have just removed all aliases. I hope Apple will fix this, but as there is no way to alert Apple of any problems with their software, I worry they will not address it in a timely fashion.



For reference, aliases are defined in Mail->Accounts->(specific account)->Account. Then, under "IMAP ACCOUNT INFORMATION", if I click on the email, I am able to add additional 'from' email aliases. It is analogous to Use email aliases in Mail on Mac - Apple Support, but I could not find a support page for iOS.

Sep 19, 2020 3:37 PM

Reply Helpful

Sep 20, 2020 1:11 AM in response to dingsquidge In response to dingsquidge

I'm having the same problem after updating to IOS 14. I also use Apple Mail on my iPhone and have various aliases for different purposes. Apple Mail now refuses to send from my primary email address and instead substitutes one of the (incorrect) aliases. Even if I correct this before sending the email by changing the email address back to the correct one, it still sends from the wrong address. I use POP accounts. Please fix asap!

Sep 20, 2020 1:11 AM

Reply Helpful (1)

Sep 20, 2020 4:00 PM in response to dingsquidge In response to dingsquidge

The only way I found to rectify this was to log into the iCloud web interface and in Mail Settings/Preferences/Accounts - disable, not delete, the alias accounts. This of course, means that you cannot receive mail sent to this alias -- but it does stop IOS 14 from using it to send mail. A fix in needed in IOS.

Sep 20, 2020 4:00 PM

Reply Helpful (2)

Sep 21, 2020 12:59 AM in response to jkeator In response to jkeator

Obviously not an ideal solution. I am not using iCloud mail but a third party email provider so it's a problem with this as well. As you say, 'A fix is needed in IOS.' Does anyone know how to submit a report to the powers that be about this problem?

Sep 21, 2020 12:59 AM

Reply Helpful

Sep 21, 2020 5:42 PM in response to dingsquidge In response to dingsquidge

I have the same problem. The Apple mail client is completely useless after the iOS 14 update. I can not use it on any device with iOS 14 installed.


The Apple mail client will send using one alias on my iPad and a different alias on my iPhone. I have both Apple mail clients setup the same way on both devices.


I hope an update comes fast as I use both my devices for business.


Richard Shafer

CBDWholesaleCollab.com

Need a New Career or an Income Boost? Free Reseller Account Available Now!

Sep 21, 2020 5:42 PM

Reply Helpful

Sep 22, 2020 2:35 AM in response to dingsquidge In response to dingsquidge

Hello Apple


You need to fix this problem quickly. The main reason I use my iPhone XS and iPad Pro is for email. If I now can’t tell which email address my mail client will send from then I can’t continue to use it. It is not unusual for a user to want to select an alias email address to send from.

Sep 22, 2020 2:35 AM

Reply Helpful (1)
Question marked as Helpful

Sep 22, 2020 5:05 AM in response to dingsquidge In response to dingsquidge

Had same problem. iOS 14 broke mail sending both iPad Mini and iPhone XS Max. “From” would always be from an alias. Even though I did not have it selected when sending.


SOLUTION:

Settings / tap your name / then tap iCloud.

Scroll ALL the way to the bottom.

Tap Mail.

Switch off (allow sending from) all your aliases.


Definite iOS 14 bug!


Sep 22, 2020 5:05 AM

Reply Helpful (6)

Sep 22, 2020 5:12 AM in response to SGreat454 In response to SGreat454

Not a solution if you have only ever use your alias email addresses, which is my position. It would aslo require notifying everyone that uses those aliases - companies, subscriptions etc - of a change in email address, which isn’t feasible.

Sep 22, 2020 5:12 AM

Reply Helpful

Sep 22, 2020 6:28 AM in response to SGreat454 In response to SGreat454

Thanks for the tip but my email service provider is not Apple iCloud. The settings on my email service provider (Zoho mail) are set to allow alias sending (unchanged from using iOS 13). I have now downloaded the Zoho mail app for iOS which works fine. It’s unacceptable for Apple to ship a new iOS with such fundamental bugs in it.

Sep 22, 2020 6:28 AM

Reply Helpful
User profile for user: dingsquidge

Question: Updated to iOS 14 and now mail sends from wrong email address